No sound from latest installation | Realtek ALC256 | Mi Notebook 14 Horizon

I recently switched from Zorin OS to Majaro because there my mic ceased to work. I have installed Manjaro alongside W10 today and now I'm unable to use my speaker or mic.
Initally my card wasn't detected but after updating to 5.7 it is, yet, no sound.

Heres the result of inxi --full --verbosity=7 --filter --no-host

[

System:    Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.19.3 
           tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: TIMI product: Mi NoteBook Horizon Edition 14 v: N/A serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: TIMI model: TM1941 v: 014 serial: <filter> UEFI: TIMI v: XMACM401P0000 date: 03/20/2020 
Battery:   ID-1: BAT0 charge: 42.5 Wh condition: 49.1/47.0 Wh (104%) volts: 16.3/15.2 model: SUNWODA R14B01W 
           type: Li-ion serial: <filter> status: Discharging 
Memory:    RAM: total: 7.61 GiB used: 1.23 GiB (16.1%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP arch: Kaby Lake rev: C 
           L2 cache: 8192 KiB bogomips: 36812 
           Speed: 900 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 816 2: 800 3: 800 4: 800 5: 800 6: 801 
           7: 800 8: 800 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities arch_perfmon art avx avx2 
           bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm 
           dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
           hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce 
           md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb 
           pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse 
           sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx 
           vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
Graphics:  Device-1: Intel UHD Graphics vendor: Xiaomi driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9b41 
           Device-2: NVIDIA GP107M [GeForce MX350] vendor: Xiaomi driver: nouveau v: kernel bus ID: 06:00.0 
           chip ID: 10de:1c94 
           Display: x11 server: X.Org 1.20.8 driver: intel,nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.3 direct render: Yes 
Audio:     Device-1: Intel vendor: Xiaomi driver: sof-audio-pci bus ID: 00:1f.3 chip ID: 8086:02c8 
           Sound Server: ALSA v: k5.7.9-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:02f0 
           IF: wlp0s20f3 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 10.13 GiB (2.1%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: AGXA4103 scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / size: 123.52 GiB used: 10.10 GiB (8.2%) fs: ext4 dev: /dev/nvme0n1p4 label: N/A 
           uuid: c9712a98-0377-46b2-8dc5-f15f6823b9d4 
           ID-2: /boot/efi size: 256.0 MiB used: 30.6 MiB (11.9%) fs: vfat dev: /dev/nvme0n1p1 label: SYSTEM 
           uuid: B8CE-E92A 
Unmounted: ID-1: /dev/nvme0n1p2 size: 128.0 MiB fs: <root required> label: N/A uuid: N/A 
           ID-2: /dev/nvme0n1p3 size: 124.00 GiB fs: ntfs label: Windows uuid: FCDECFAADECF5B90 
           ID-3: /dev/nvme0n1p5 size: 225.56 GiB fs: ntfs label: Data Drive uuid: 0682346682345BFD 
           ID-4: /dev/nvme0n1p6 size: 1024.0 MiB fs: ntfs label: N/A uuid: 7E0672C706727FC7 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-2:2 info: Xiaomi MI Mouse A1w type: Mouse driver: hid-generic,usbhid interfaces: 1 
           rev: 1.1 speed: 12 Mb/s chip ID: 2717:004b 
           Device-2: 1-10:3 info: Intel type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
           chip ID: 8087:0aaa 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 38.0 C mobo: 37.0 C gpu: nouveau temp: 37 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 237 Uptime: 7m Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.18 
           running in: konsole inxi: 3.0.37 

]

Above is the screenshot of Pulse Volume.

Please O' Please help me out

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by