No sound.. used to work, but stopped working

I've just bought a new Dell G5 5500 laptop and I a having trouble getting the sound to work. Previously I installed Manjaro on this laptop and I couldn't get any sound and I managed to get "sof-hda-dsp" to install and it worked, but it was incredibly quiet. After a month or so of using Windows again, I've come back to tackle this again and now the sound has gone altogether.

Here is an output of alsa-info.sh --upload: http://alsa-project.org/db/?f=84deb282dd3746d205589fc6ebdccaf6a2302ccb

Any ideas how to get my sound coming back (ppl complaining I'm not replying to their messages, cuz I can't hear them lol)

System:    Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: Gnome 3.36.4 wm: gnome-shell 
           dm: GDM 3.36.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: G5 5500 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 06P54X v: A00 serial: <filter> UEFI: Dell v: 1.3.1 date: 06/08/2020 
Battery:   ID-1: BAT0 charge: 67.9 Wh condition: 67.9/68.0 Wh (100%) volts: 16.6/15.2 model: SMP DELL 72WGV05 type: Li-poly 
           serial: <filter> status: Full 
           Device-1: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 3 serial: <filter> 
           charge: 10% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP arch: N/A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 3500 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 3395 2: 3428 3: 3384 4: 3500 5: 3362 6: 3243 7: 3116 
           8: 3291 9: 1926 10: 3500 11: 3500 12: 3052 
Graphics:  Device-1: Intel UHD Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9bc4 
           Device-2: NVIDIA TU106M [GeForce RTX 2070 Mobile / Max-Q Refresh] vendor: Dell driver: nvidia v: 440.100 
           bus ID: 01:00.0 chip ID: 10de:1f14 
           Display: x11 server: X.org 1.20.8 driver: modesetting,nvidia unloaded: intel,nouveau alternate: fbdev,nv,vesa 
           compositor: gnome-shell resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.3 direct render: Yes 
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: sof-audio-pci bus ID: 00:1f.3 chip ID: 8086:06c8 
           Sound Server: ALSA v: k5.7.9-1-MANJARO 
Network:   Device-1: Intel Wi-Fi 6 AX201 vendor: Bigfoot Networks driver: iwlwifi v: kernel port: 4000 bus ID: 00:14.3 
           chip ID: 8086:06f0 
           IF: wlp0s20f3 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 585.63 GiB (62.9%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T3XHC-00SJG0 size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 102000WD scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Samsung model: PM991 NVMe 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 25306039 scheme: GPT 
Partition: ID-1: / size: 223.63 GiB used: 35.10 GiB (15.7%) fs: ext4 dev: /dev/nvme1n1p7 
Sensors:   System Temperatures: cpu: 67.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 376 Uptime: 4m Memory: 15.40 GiB used: 3.41 GiB (22.2%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: zsh v: 5.8 running in: gnome-terminal inxi: 3.0.37 

-- duplicate --

Anyone able to help? I feel like I'm at a loss here

Hello. Maybe steps described here work for you:

https://bbs.archlinux.org/viewtopic.php?id=194032

It didn't seem to enable the sound, so OK I had a look at that.. but I'm not totally sure what I'm looking for.
There was no file called ~/.asound.conf or a file called /etc/asound.conf. So I created both of these and checked alsamixer to make sure it wasn't on mute.

~/.asoundrc

defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0

/etc/asound.conf

defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0

...
The computer reports these:
aplay -L | grep :CARD

sysdefault:CARD=sofhdadsp
usbstream:CARD=sofhdadsp

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: sofhdadsp [sof-hda-dsp], device 0: HDA Analog (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 1: HDA Digital (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 3: HDMI1 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 4: HDMI2 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 5: HDMI3 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

aplay -l | awk -F : '/,/{print $2}' | awk '{print $1}' | uniq

sofhdadsp

lsmod | grep '^snd' | column -t

snd_soc_skl_hda_dsp       24576   2   
snd_hda_codec_hdmi        73728   1   
snd_soc_hdac_hdmi         40960   1   snd_soc_skl_hda_dsp
snd_hda_codec_realtek     135168  1   
snd_hda_codec_generic     98304   1   snd_hda_codec_realtek
snd_soc_dmic              16384   1   
snd_sof_pci               24576   0   
snd_sof_intel_byt         20480   1   snd_sof_pci
snd_sof_intel_ipc         20480   1   snd_sof_intel_byt
snd_sof_intel_hda_common  90112   1   snd_sof_pci
snd_soc_hdac_hda          24576   1   snd_sof_intel_hda_common
snd_sof_xtensa_dsp        16384   2   snd_sof_intel_hda_common,snd_sof_intel_byt
snd_sof_intel_hda         20480   1   snd_sof_intel_hda_common
snd_sof                   126976  4   snd_sof_pci,snd_sof_intel_hda_common,snd_sof_intel_byt,snd_sof_intel_ipc
snd_soc_skl               180224  0   
snd_soc_sst_ipc           20480   1   snd_soc_skl
snd_soc_sst_dsp           40960   1   snd_soc_skl
snd_hda_ext_core          36864   5   snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_soc_acpi_intel_match  45056   3   snd_sof_pci,snd_sof_intel_hda_common,snd_soc_skl
snd_soc_acpi              16384   4   snd_soc_acpi_intel_match,snd_sof_intel_hda_common,snd_sof_intel_byt,snd_soc_skl
snd_soc_core              299008  7   snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_hdac_hda,snd_soc_skl,snd_soc_dmic,snd_soc_skl_hda_dsp
snd_compress              32768   1   snd_soc_core
snd_pcm_dmaengine         16384   1   snd_soc_core
snd_hda_intel             53248   0   
snd_intel_dspcfg          28672   4   snd_hda_intel,snd_sof_pci,snd_sof_intel_hda_common,snd_soc_skl
snd_hda_codec             167936  6   snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda,snd_soc_skl_hda_dsp
snd_hda_core              106496  12  snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda,snd_soc_skl_hda_dsp
snd_hwdep                 16384   1   snd_hda_codec
snd_pcm                   147456  11  snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_compress,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
snd_timer                 45056   1   snd_pcm
snd                       114688  15  snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm,snd_soc_skl_hda_dsp

Any ideas? I'm not really sure what I am looking at here?

Interestingly the microphone seems to work fine as you can see that it is recording the levels when you talk in the settings control panel.

Post the dmesg output. It will post all the errors. I am a newbie and don't have teh solution but my audio problem on my Dell G3 3590 was solved because the person who gave me the solution found it in the dmesg output. Also check out the How to provide good information in your posts

--ignore this message as I provided the wrong information--

Here is the dmesg response that I've redone the one above might not be so useful.

I found a way to get the sound to work by editing the grub file and giving the option as follows: Find the line starting with GRUB_CMDLINE_LINUX_DEFAULT and append snd_hda_intel.dmic_detect=0 to its end.
So now the speakers work, but I've lost the microphone. What do I do now? lol

WOOT I worked it out. There is a hint in the page "https://wiki.archlinux.org/index.php/Dell_Inspiron_15_(7590)". There is a script which unmutes the volume meter. A lot of the pages I read said open up alsamixer and unmute the master volume, which I did and didn't seem to do anything as there is a bug in the latest version (1.2.3) of sof-firmware.

Creating the script:
~/.config/autostart-scripts/unmute-master.sh

amixer -Dhw:0 cset name='Master Playback Switch' on
amixer -Dhw:0 cset name='Master Playback Volume' 100%

and removing the grub command allows for the microphone and the speakers to work correctly.

1 Like

Forum kindly sponsored by