No such device, unknown file system, enter grub secure

I ll appreciate your help.
I used win10 previously. THEN I try to install manjaro, after the installation, I also give a try on debian. So I have 3 os.
Then I delete all debian partition.
finally, i cannot boot because of that error and enter grub rescue.
sorry for little research
could someone help saving my work.

Start here

but I can't reach the grub menu, and just have the grub rescue prompt. are they the same thing?

No. Grub prompt and grub rescue prompt are different.
You cannot get to grub prompt using livecd boot menu? Impossible.


If i may take a guess, the grub you used last was Debian's, since you installed it last. Now you deleted its partition, you also deleted its grub.


I run set on rescue command and output like this

root hd3 gpt1
Prefix   Xxxx
Cmd /efi/debian 

Does hd3 gpt1 means the boot partition of debian?
So I have to set it to manjaro boot partition.
Am I right ?
I also enabled uefi for further more info. I have notice there is a 500mb partition seems it’s related to uefi

I could attend grub prompt,and I lol try your tutorial .thanks in advance

1 Like

I got the error and stucked.

Do you have a separate /boot partition?
If yes, use the different method (if there is a separate boot partition section)
If you do not (have a separate boot partition)
what is the output?

grub> search.file /etc/manjaro-release

you then set root to that partition
Your (hd1,2) may not be in the output.
It could be (hd0,2) or (hd2,2) Then use it.

If only one output, you can use

grub> search.file /etc/manjaro-release

But repeat, that does not apply to a separate partition.
Your "ls ($root)/boot" does not have any output.
Either it is the wrong partition or you have a separate boot partition.

1 Like

What if I run

Search.file /intel-ucode.img

And got hd1 gpt2, and assign to root.
Then I type

ls ($root)/boot

and got ‘file /boot/ not found.
I think I do mount the /boot to (hd1,2)

Alright, do you have kernel vmlinuz-4.19-x86_64 or are you not sure?
Let's check that out.

At grub prompt, do following...

grub> search.file /intel-ucode.img root
grub> ls ($root)/

Do you get output of vmlinuz-4.19-x86_64 and initramfs-4.19-x86_64.img (besides other stuff)?
If you do not have vmlinuz-4.19-x86_64 but other kernel, use that other kernel below..

grub> search.file /etc/manjaro-release  abc
grub> probe -u $abc --set=pqr
grub> linux /vmlinuz-4.19-x86_64 root=UUID=$pqr rw
grub> initrd /initramfs-4.19-x86_64.img
grub> boot

careful where you use abc and pqr.

When booted to installed manjaro OS, at terminal, first check if you have /boot/efi at fstab

findmt /boot/efi
test -d /sys/firmware/efi && echo UEFI || echo BIOS

You have output for first command and (&&) 'UEFI' for second command?
If yes, continue.
If no, you installed wrongly and come back to us.
ps: if may be easier for you to reinstall if you installed wrongly

sudo pacman-mirrors -f3
sudo pacman -Syyuu
sudo grub-install 
sudo update-grub

Tell us what is "findmnt /boot/efi" I don't know your /boot/efi partition and 2 more commands are required to make it 'solid' (?) (better?)

ps: if you reinstall, please do not have a separate /boot partition, not necessary,
(but for uefi installation you must have a $esp partition in fat32 and mounted as /boot/efi, read up if not clear)

[EDIT] - if you want to go through fixing your wrongly installed OS (if wrongly installed), provide terminal output when booted (it will boot even if wrongly installed - a good grub will do that, a bad grub, no) of

sudo parted -l
sudo blkid
findmnt -s
efibootmgr -v

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by