no usb tethering

no usb tethering works on the debian and ubuntu version
ip link recognizes usb and tun easytether UP but no internet .
it works on the debian and ubuntu distro.
am I missing smth ...firewall ?

Which Device is it ? and which kernel are you using?

i'm sorry ,its
5.5.0-3.1-MANJARO-ARM xfce on pinebook pro on eMMC

:+1:Welcome to Manjaro!:+1:

Please read this:

and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...

:wink: :+1: :innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...

installed easytether aarch64.pkg ,updated -Syu
ip link shows
lo loopback,up lower_up
tun-easytether ... pointopoint,multicast,noarp,up,lower_up
on the android app shows as connected
but cant access internet not on firefox or any ping
systemctl --failed
systemd-networkd-wait-online.service load,failed wait for Network to be Configured
restarted systemd-networkd.service
restarted smb
but no dice it works on debian pbp
thanks for your patience ,lol

Usb tethering have always worked for me on Manjaro Pinebook Pro. I will try to replicate this tomorrow and see if its a problem on the latest kernel.
Have you tried a different cable or the usb port?
Also when did you download the img file for pinebook pro? Just wanted to confirm which uboot you're using.

Manjaro ARM 19.12 release i think a couple months back, eched to to sd ,booted from there then dd the another 19.12 image it to the internal emmc ,did the updates tried then and now never got it to work
on usb3 it doesn't even get auto recognized ,but usb2 ip link sees it _up
but there seems to be conflict with NetworkManager systemd claims
the same for android usb tether and the easytether app and its easytether drive for the linux
on a couple of X86-64 arch computers its working with dhcpcd

i just installed the newer Manjaro ARM 20.02.1 xfce on a sd installed aarch easytether pkg and its working now ...maybe have to dd the new img to emmc again. nmb. samba still gives me a fail though.

oh well new android pile of phone with newer version of easytether pro and its associated aarch64 manj arch driver ..shows connected but no internet
every other arch and debian /ubuntu version no problem.
i guess I'l forget about manjaro and stick with debian until somthing shows up.
update : kde 20.02.1 img downloaded on march.31 no update easytether working fine on sd ... huh,maybee i should reinstall xfce emmc fresch?

ok...reinstalling all 20.02.1 to death solved it,lol...just don't update or use wifi !

Yes this is something I am facing with 5.6.0 Kernel. If you revert to 5.5.0 kernel then this is not the issue. Also this issue is with devices with latest android version.

I will try to look into this with the kernel Dev @tsyseu. I hope he can help us with this.

Thanks for reporting.

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by