No way to start an openconnect VPN in Deepin

It is possible to create an openconnect connection, but there is no GUI way to connect to it.

Usually you right-click on nm-applet and can select VPN, then see the defined connection, click on it and get a password prompt.
In Deepin right-click on nm-applet doesn't work.:frowning:
The password prompt dialog should be somewhere, but I don't know the command to start it.

So if you fill out the basic information, click add you can't select it in the network manager?

Right. But there is actually no nm-applet among running processes, must be s.th. hard coded what Deepin uses. I also cannot start nm-applet from terminal.

Sounds odd, but I have no idea, as I don't use Deepin. Was just a thought.

cannot start or just not appearing? in this case you have to install gnome-keyring then try to run it again

@turtle93, not appearing, no right-click option.

I managed to connect following https://wiki.archlinux.org/index.php/OpenConnect with the terminal (output anonymized by *****):

[eugen@manjaro ~]$ openconnect ******.de
POST https://******.de/
Attempting to connect to server 132.252.184.209:443
SSL negotiation with ******.de
Connected to HTTPS on ******.de
XML POST enabled
Please enter your username and password.
GROUP: [UNI-DUE]:UNI-DUE
POST https://******
XML POST enabled
Please enter your username and password.
Username:******
Password:
POST https://******
Got CONNECT response: HTTP/1.1 200 OK
CSTP connected. DPD 30, Keepalive 20
mkdir: cannot create directory ‘/var/run/vpnc’: Permission denied
Failed to bind local tun device (TUNSETIFF): Operation not permitted
To configure local networking, openconnect must be running as root
See http://www.infradead.org/openconnect/nonroot.html for more information
Set up tun device failed
[eugen@manjaro ~]$ sudo openconnect ******.de
[sudo] password for eugen: 
POST https://******.de/
Attempting to connect to server 132.252.184.******
SSL negotiation with ******.de
Connected to HTTPS on ******.de
XML POST enabled
Please enter your username and password.
GROUP: [******]:******
POST https://******.de/
XML POST enabled
Please enter your username and password.
Username:******
Password:
POST https://******.de/
Got CONNECT response: HTTP/1.1 200 OK
CSTP connected. DPD 30, Keepalive 20
Connected tun0 as 132.252.******, using SSL
Established DTLS connection (using GnuTLS). Ciphersuite (DTLS0.9)-(RSA)-(AES-256-CBC)-(SHA1).

Feeling a bit uneasy that I need to connect with sudo...

I found a better solution. I needed to install network-manager-applet, run nm-applet (in terminal, because Deepin doesn't have a native "Run command" or I just don't know it) then I got the nm-applet icon on the panel and could left-click it to create (the definition made by Deepin wasn't detected) and then connect to the VPN openconnect connection.

An Update: openconnect VPN now has a native Deepin dialog window which asks for username and password:

So no need for network-manager-applet.

This dialog stopped working though. It used to work but after the last update when they changed the control center's appearance it seems that it doesn't show up. When I click connect, I directly get a notification that no password was provided

I've still got the exact same problem, any way to fix this ?

Forum kindly sponsored by