No wifi option in newly installed Manjaro KDE

I have a problem with my newly installed manjaro kde. I installed it and update its kernel version to 5.7 and I am not able to see any wifi options so please can you tell me what i have to do? Is wifi not preinstalled in this kernel version and if not please tell me how to come up with the wifi option.

My laptop is hp 15bs164tu.
I think wifi drivers i used in earlier time was realtek RTL8723DE.

Please help me in this and also when I installed wifi drivers in other linux versions then wifi range was very short in them like only 3 feet or something so please give me the solution so that wifi works for some long range like in windows.

Thank you very much in advance.

Oh no you didn't.

1 Like

Are you saying wifi works on other kernels ?
Then why use kernel 5.7 ? what other ones do you have installed?

Did you install linux57-headers?

A friend of mine who is new to Manjaro Linux installed the Gnome version on his new HP laptop. Kernel 5.7 was installed too and he had no WiFi either. After installing the LTS Kernel 5.4 WiFi works.

I would recommend you to switch to Kernal 5.4 as mentioned above.

@dalaker: Do you have the same HP model?

No i am new in manjaro.

I installed 5.6 then upgrade to 5.7 but not in both but now i m trying to install it after linux57-headers

I tried following commands:

sudo pacman -S git

sudo pacman -S dkms

sudo pacman -S linux$(uname -r| grep -o -E '[0-9]+' | head -n 2 | sed 'N;s/\n//')-headers

git clone -b 4.15-up

sudo dkms add ./rtl8723de

sudo dkms install rtl8723de/

sudo depmod -a


But got error on last third step.

Error: 1593070627278762044709

Build the driver on kernel 5.4 or kernel 4.19.

Please stop posting pics of terminal outputs.

If you don't have an Ethernet connection, you can use USB Android phone tethering for a temporary internet connection to post outputs.

You still have not posted your system specs. We do not even know if you are attempting to install the correct driver as you haven't provided your system specifications as requested.


[ronak@ronak-hplaptop15bs1xx ~]$ lspci -vvnn | grep -A 9 Network
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723DE 802.11b/g/n PCIe Adapter [10ec:d723]
DeviceName: WLAN
Subsystem: Hewlett-Packard Company RTL8723DE 802.11b/g/n PCIe Adapter [103c:8319]
Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 255
Region 0: I/O ports at 3000 [size=256]
Region 2: Memory at b1000000 (64-bit, non-prefetchable) [size=64K]
Capabilities: access denied

This what i get while searching for drivers and below is output of uname -a:

Linux ronak-hplaptop15bs1xx 5.7.0-3-MANJARO #1 SMP PREEMPT Wed Jun 3 03:15:33 UTC 2020 x86_64 GNU/Linux

Install kernel 5.4, install the kernel headers, build the driver again. If it errors again, test building the driver on kernel 4.19. If it errors again, test building the driver on kernel 4.14.

Ok, thank you. I will try it but Is there no wifi on kernel 5.7.0?

This ^^^ is the easiest way to get temporary internet service to download and install different kernels (if a wired connection isn't an option).



sudo modprobe rtw_8723de

you might also try


options rtw_8723de ant_sel=2 

This is officialy abandoned in kernels newer than 5.0

git clone -b current
dkms add ./rtl8723de
dkms install rtl8723de/
depmod -a

I tried all the above commands in kernel 5.7.0 and it worked finally and gives good connection.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by