Noise coming from laptop speakers

Hello everyone,

I would like to ask for your help.

My laptop produces a noise from its speakers when I am using any linux distro. This noise is really annoying, and it does not happens on Windows 10.

When I connect a headphone the noise is gone, but as soon as I disconnect it, the noise comes back. Also, if I mute the speakers the noise gets lower, but it does not disappear completely.

I already tried enabling and disabling the sound card power saving mode, but it does not decrease the noise in any matter.

Is there something else I could do to fix this? I don't know if this changes something, but on Windows I have to use the Creative SoundBlaster to get decent sound.

Thank you in advance.

This is the list of devices I have when I run aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Please post output from terminal

inxi -Fxxxza --no-hosts

too :slight_smile:

System:    Host: manjaro Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=9ded3f4a-5111-4b11-a5e9-91de886eed0a rw quiet apparmor=1 
           security=apparmor resume=UUID=a100c73b-d3c6-4c45-9a41-0ee72a683a67 udev.log_priority=3 
           Desktop: KDE Plasma 5.16.4 tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: OVERPOWERED product: OP-LP2 v: Standard serial: <filter> 
           Mobo: OVERPOWERED model: GK5CN6Z v: Standard serial: <filter> UEFI: American Megatrends v: N.1.05 date: 11/01/2018 
Battery:   ID-1: BAT0 charge: 46.7 Wh condition: 46.7/46.7 Wh (100%) volts: 12.9/11.4 model: standard type: Li-ion 
           serial: <filter> status: Full 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325 serial: <filter> charge: 55% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: B4 L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53004 
           Speed: 4101 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 4100 2: 4062 3: 4097 4: 4041 5: 4046 6: 4100 7: 4108 
           8: 4100 9: 4045 10: 4101 11: 4042 12: 4101 
           Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Tongfang Hongkong Limited driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:3e9b 
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Tongfang Hongkong Limited driver: nvidia v: 435.21 
           bus ID: 01:00.0 chip ID: 10de:1c20 
           Display: x11 server: X.Org 1.20.5 driver: modesetting,nvidia compositor: kwin_x11 resolution: 1920x1080~144Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 19.1.5 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Tongfang Hongkong Limited driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a348 
           Sound Server: ALSA v: k5.2.11-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 6000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Tongfang Hongkong Limited driver: r8169 
           v: kernel port: 3000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 4.55 TiB used: 330.40 GiB (7.1%) 
           ID-1: /dev/sda vendor: Crucial model: CT525MX300SSD1 size: 489.05 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: R070 scheme: GPT 
           ID-2: /dev/sdb model: BP5 size: 447.13 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
           serial: <filter> rev: 12.2 scheme: GPT 
           ID-3: /dev/sdc type: USB vendor: Western Digital model: WD easystore 25FA size: 3.64 TiB block size: 
           physical: 4096 B logical: 512 B serial: <filter> rev: 1014 scheme: GPT 
Partition: ID-1: / raw size: 139.96 GiB size: 136.76 GiB (97.72%) used: 10.66 GiB (7.8%) fs: ext4 dev: /dev/sdb5 
           ID-2: swap-1 size: 7.15 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sdb6 
Sensors:   System Temperatures: cpu: 47.0 C mobo: 47.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 292 Uptime: 1m Memory: 31.27 GiB used: 1.19 GiB (3.8%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           Shell: bash v: 5.0.9 running in: yakuake inxi: 3.0.36 
1 Like

I think there are two things you have to do:

  1. edit /etc/pulse/ and insert this lines into it:
load-module module-alsa-source device=hw:0,0
# the line above should be somewhere before the line below
  1. set the sampling rate in /etc/pulse/daemon.conf for the sound hardware to:
    avoid-resampling = yes

Then run from terminal:
pulseaudio -k ; pulseaudio -D
or simply reboot to make sure ...

1 Like

Thank you for the help, but it did not work.

The constant noise is still coming from the speakers. :frowning:

explain the noise, crackling? humming? high pitch? low?

@LangoLango instead of changing the configs in /etc/pulse/, edit the ones in ~/.config/pulse. if there is no ~/.config/pulse directory you should create it and copy the /etc/pulse files over.

mkdir ~/.config/pulse
cp /etc/pulse/ ~/.config/pulse/
cp /etc/pulse/daemon.conf ~/.config/pulse/daemon.conf
cp /etc/pulse/ ~/.config/pulse/
cp /etc/pulse/client.conf ~/.config/pulse/client.conf

if ~/.config/pulse already exists then the files in there take priority over the /etc/pulse files. and making edits to /etc/pulse will have no effect so make the changes @bogdancovaciu suggested to the ~/.config/pulse files instead and restart pulse afterwards
systemctl --user restart pulseaudio

kde sometimes has problems running pulseaudio properly, and often ignores changes made by the user. restarting the pulseaudio service with --user flag usually makes it behave as it's suppose to


It sounds like a coil whining, but a lot louder. When I connect a headphone, the noise is gone from the speakers.

It is something like: Shhhhhhhhhhhhhhhhhhhh. And it is constant, all the time.

The biggest problem is that I start to feel kind "sick" after some time hearing this noise.

i edited my previous post and added some more info to it

1 Like

Mic feedback?

I did it... No changes. =/

I don't know, but I tried to mute the microphone, and it did not change anything related to the speaker noise.

I saw this kernel patch yesterday about a similar problem with the Lenovo T440s. I

I don't know if this is the same problem:

can you run pavucontrol and go over to the configuration tab and list which drop down options you have available for your audio device.

and also the output of pactl list sinks

@LangoLango these are the model names you can try as module options for your ALC269 device. even if your not using a "dell" the workaround may still work. it just tells snd-hda-intel what device your using and how to handle it

  laptop-amic		Laptops with analog-mic input
  laptop-dmic		Laptops with digital-mic input
  alc269-dmic		Enable ALC269(VA) digital mic workaround
  alc271-dmic		Enable ALC271X digital mic workaround
  inv-dmic		Inverted internal mic workaround
  headset-mic		Indicates a combined headset (headphone+mic) jack
  lenovo-dock   	Enables docking station I/O for some Lenovos
  dell-headset-multi	Headset jack, which can also be used as mic-in
  dell-headset-dock	Headset jack (without mic-in), and also dock I/O

try each of those as a module option, you can do that like this only 1 option at a time

sudo nano /etc/modprobe.d/sound.conf

options snd-hda-intel model=auto
#options snd-hda-intel model=basic
#options snd-hda-intel model=headset-mic
#options snd-hda-intel model=dell-headset-multi
#options snd-hda-intel model=inv-dmic
#options snd-hda-intel model=laptop-amic
#options snd-hda-intel model=laptop-dmic
#options snd-hda-intel model=alc269-dmic

only uncomment 1 line at a time, reboot after change

1 Like

I know that - hear it all day - my wife says it is called tinnitus :slight_smile:


Doesn't go away when you plug in the headphones. :wink:

1 Like

i have a constant high pitch in my right ear which is also tinnitus from what im told

1 Like

The lenovo-dock improved the situation. I would say it decrease the noise in 50%. However, I can still hear it, while on Windows 10 has no noise whatsoever.

This is the result for pactl list sinks:

Sink #1
        State: SUSPENDED
        Name: alsa_output.pci-0000_00_1f.3.analog-stereo
        Description: Built-in Audio Analog Stereo
        Driver: module-alsa-card.c
        Sample Specification: s16le 2ch 44100Hz
        Channel Map: front-left,front-right
        Owner Module: 29
        Mute: yes
        Volume: front-left: 55666 /  85% / -4.25 dB,   front-right: 55666 /  85% / -4.25 dB
                balance 0.00
        Base Volume: 65536 / 100% / 0.00 dB
        Monitor Source: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
        Latency: 0 usec, configured 0 usec
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
       = "ALC269VC Analog"
       = "ALC269VC Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xa5d10000 irq 145"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
       = "8086"
       = "Intel Corporation"
       = "a348"
       = "Cannon Lake PCH cAVS"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
       = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                alsa.mixer_name = "Realtek ALC269VC"
                alsa.components = "HDA:10ec0269,1d051053,00100203 HDA:8086280b,80860101,00100000"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
                analog-output-speaker: Speakers (priority: 10000)
                analog-output-headphones: Headphones (priority: 9000, not available)
        Active Port: analog-output-speaker

you tried all the other ones i listed as well?

Forum kindly sponsored by