non-free VESA nVidia Quadro K620M issues

Hi. I have a Lenovo W550s with an Nvidia Quadro K620M Mobile GPU. Today I installed the non-free VESA drivers (because I want to use CUDA with avatarify and avatarify wasn't using CUDA so I thought this mught have been it) for it using Manjaro Settings Manager, but I had problems with the display. I took screenshots in order to show you what is happening, but the screenshots show ok! So then I took pictures with my phone, and I attach them.

the problem is:
xrandr is not properly detecting my display.

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 2880 x 1620, current 2880 x 1620, maximum 2880 x 1620
default connected 2880x1620+0+0 0mm x 0mm
   2880x1620      0.00* 

The screen of my laptop is split in two, and what should be on the left half of it, appears on the right, and viceversa. For example, if I am moving the mouse pointer on the right side of the screen, when I move it beyond the right screen edge, mouse pointer appears again in the left side of the screen, as a Pacman (video game character) it were.IMG_20200606_191454439

inxi -Fx

typeSystem:
  Host: josei-pc Kernel: 4.19.125-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: i3 4.18.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20E2CTO1WW v: ThinkPad W550s 
  serial: <root required> 
  Mobo: LENOVO model: 20E2CTO1WW v: SDK0E50510 WIN serial: <root required> 
  UEFI: LENOVO v: N11ET41W (1.17 ) date: 03/01/2017 
Battery:
  ID-1: BAT0 charge: 37.5 Wh condition: 37.6/44.4 Wh (85%) 
  model: SANYO 45N1741 status: Unknown 
  ID-2: BAT1 charge: 51.4 Wh condition: 51.4/71.3 Wh (72%) 
  model: SANYO 45N1777 status: Full 
CPU:
  Topology: Dual Core model: Intel Core i7-5500U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 19155 
  Speed: 799 MHz min/max: 500/3000 MHz Core speeds (MHz): 1: 800 2: 798 
  3: 799 4: 798 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: NVIDIA GM108GLM [Quadro K620M / Quadro M500M] vendor: Lenovo 
  driver: nouveau v: kernel bus ID: 08:00.0 
  Display: x11 server: X.Org 1.20.8 driver: vesa resolution: 2880x1620~N/A 
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.7 
  direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.19.125-1-MANJARO 
Network:
  Device-1: Intel Ethernet I218-V vendor: Lenovo driver: e1000e v: 3.2.6-k 
  port: 4080 bus ID: 00:19.0 
  IF: enp0s25 state: down mac: 54:ee:75:4e:c5:23 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: efa0 
  bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: 34:02:86:43:da:eb 
  IF-ID-1: wwp0s20u4 state: down mac: 3a:8a:af:0d:2b:b4 
Drives:
  Local Storage: total: 4.34 TiB used: 537.93 GiB (12.1%) 
  ID-1: /dev/mmcblk0 vendor: Samsung model: SP512 size: 476.71 GiB 
  ID-2: /dev/sda vendor: Samsung model: MZ7LN256HCHP-000L7 size: 238.47 GiB 
  ID-3: /dev/sdb type: USB vendor: Seagate model: Expansion size: 3.64 TiB 
Partition:
  ID-1: / size: 171.62 GiB used: 141.35 GiB (82.4%) fs: ext4 dev: /dev/sda8 
  ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 190 Uptime: 2m Memory: 15.54 GiB used: 2.35 GiB (15.1%) 
  Init: systemd Compilers: gcc: 10.1.0 clang: 10.0.0 Shell: bash v: 5.0.17 
  inxi: 3.0.37 
 or paste code here

Thanks for your help.

Care to explain what you did and what do you mean by "non-free VESA drivers" ?
According to this:

You are still using the free drivers.
Go trough this and see what best suits you, what works with that hardware:

1 Like

Thanks @bogdancovaciu
I think you might be just right. What I did in order to install what I thought were the non-free drivers, was to use the Manjaro Settings Manager GUI, as you can see in the following Screenshot, I clicked on install in the lower right corner checkbox, and so it went from unchecked, as you can see in the screenshot, to checked. Isn't this the non-free driver? 2020-06-07-200437_2880x1620_scrot

Anyway, I must mention my inxi -Fx output was not right, because I executed the command when using the original vesa driver (lower right corner not checked). But I just updated the original post with the relevant info, when using the installed vesa-driver. It still says nouveau though.

I tried looking for a nvidia driver in AUR but I got confused with so many options. I tried narrowing by looking at nVidia's website recommendation, that recommends the 440.82 driver when I look for my GPU model, and my actual kernel (4.19), and I find the following packages that look interesting:

multilib/lib32-opencl-nvidia-440xx 440.82-1 (24.1 MiB 73.2 MiB) 
    OpenCL implemention for NVIDIA (32-bit)
multilib/lib32-nvidia-440xx-utils 440.82-1 (31.3 MiB 96.3 MiB) 
    NVIDIA drivers utilities (32-bit)
community/linux-lts-nvidia-440xx 1:5.4-3 (13.2 KiB 0.0 B) [linux-lts-extramodules] 
    NVIDIA drivers for Linux (metapackage)
extra/opencl-nvidia-440xx 440.82-1 (3.3 MiB 27.8 MiB) 
    OpenCL implemention for NVIDIA
extra/nvidia-440xx-utils 440.82-1 (108.0 MiB 292.3 MiB) 
    NVIDIA drivers utilities
extra/linux419-nvidia-440xx 440.82-12 (14.0 MiB 14.1 MiB) [linux419-extramodules] 
    NVIDIA drivers for linux.
core/mhwd-nvidia-440xx 440.82-1 (20.4 KiB 1.4 KiB) (Installed)
    MHWD module-ids for nvidia 440.82`

Should I install some of these?
Or should I just try to choose an option from the link you gave me (any help in choosing one, beyond the post info, is deeply appreciated) and install it following manjaro's wiki install instructions using mhwd?

Thanks a lot again. :grin:

Since none of the hybrid drivers come up in MHWD UI, i wonder what would be the best approach and why you have no option for nonfree drivers. You could run from terminal:
sudo mhwd -f -i pci video-hybrid-intel-nvidia-440xx-prime
so that will properly install the nonfree drivers for hybrid graphics, but i honestly would check if the K620M is supported.

FIRST you have to remove all the other drivers. Either trough MHWD UI or from terminal:
sudo mhwd -r pci video-linux
sudo mhwd -r pci video-modesetting

Since it reports to be installed, it could be because you installed it trough pamac, but you must do it trough mhwd to load properly, or set things manually ...

1 Like

Thanks!
Yes, previously, among many other experiments, I did install the driver through pacman once). I did follow your instructions, but when I tried to sudo mhwd -r pci video-modesetting system said there was no such driver installed.
Anyway, I installed the nvidia-440xx driver (yes, the nVidia site states my card is supported by it), but upon rebooting I was confronted with a black screen. Not the normal message stating it couldn't start LightDM (I'm using i3), but just the black screen.

I attach my Xorg log for that session: (btw, I noticed my xorg.conf file was apparently not touched when I installed 440xx drivers with mhwd, instead, it created a file under /etc/X11/mhwd.d and another (that started with the number 90) on /etc/X11/xorg.conf.d, but both files were empty (only a couple of commented lines at the beginning)

[    56.937] 
X.Org X Server 1.20.8
X Protocol Version 11, Revision 0
[    56.937] Build Operating System: Linux Manjaro Linux
[    56.937] Current Operating System: Linux josei-pc 4.19.125-1-MANJARO #1 SMP Wed May 27 16:33:46 UTC 2020 x86_64
[    56.937] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=bacd33e3-f003-47ef-a686-ace7a97d09d3 rw quiet resume=UUID=b89caf19-3070-4be6-afd4-87b356314373
[    56.937] Build Date: 07 May 2020  08:12:07AM
[    56.937]  
[    56.937] Current version of pixman: 0.40.0
[    56.937] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    56.937] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    56.937] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun  8 09:32:50 2020
[    56.937] (==) Using config file: "/etc/X11/xorg.conf"
[    56.937] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    56.937] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    56.937] (==) ServerLayout "layout"
[    56.937] (**) |-->Screen "Screen0" (0)
[    56.937] (**) |   |-->Monitor "Monitor0"
[    56.938] (==) No device specified for screen "Screen0".
	Using the first device section listed.
[    56.938] (**) |   |-->Device "iGPU"
[    56.938] (==) Automatically adding devices
[    56.938] (==) Automatically enabling devices
[    56.938] (==) Automatically adding GPU devices
[    56.938] (==) Automatically binding GPU devices
[    56.938] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    56.938] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    56.938] 	Entry deleted from font path.
[    56.938] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
[    56.938] 	Entry deleted from font path.
[    56.938] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi").
[    56.938] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
[    56.938] 	Entry deleted from font path.
[    56.938] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi").
[    56.938] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF
[    56.938] (==) ModulePath set to "/usr/lib/xorg/modules"
[    56.938] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    56.938] (II) Module ABI versions:
[    56.938] 	X.Org ANSI C Emulation: 0.4
[    56.938] 	X.Org Video Driver: 24.1
[    56.938] 	X.Org XInput driver : 24.1
[    56.938] 	X.Org Server Extension : 10.0
[    56.938] (++) using VT number 7

[    56.938] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    56.939] (II) xfree86: Adding drm device (/dev/dri/card1)
[    56.950] (II) xfree86: Adding drm device (/dev/dri/card0)
[    56.951] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"
[    56.951] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"

In that case try to see what is different from this


Do things accordingly and for each step. I know it might be a bit frustrating from TTY (i hope you can access that at least), but you should be up an running after that.

1 Like

thanks @bogdancovaciu
This did the job. Using nvidia and CUDA. Although, not very sure if it is running at maximum speed though.
Anyway, now I'll follow your first link to try to install a way of switching between iGPU and dGPU

thanks!!

Or it's not possible to switch forth and back with prime driver?

For that you will have to follow this


I think that is what you are looking for.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by