Not a manjaro problem , but still need help...

output this:

root@router:/mnt# mount | grep sda5
/dev/sda5 on /mnt/sda5 type ntfs (ro,relatime,uid=0,gid=0,fmask=0177,dmask=077,nls=utf8,errors=continue,mft_zone_multiplier=1)

So it won't get mounted as r/w, apparently there's something preventing that - could be filesystem error or incompatibility (see Fabish's post above).

Can you start Windows and run a filesystem check?

but S.M.A.R.T is OK ...

S.M.A.R.T is fine...and everything is good before i plug it in to the PVE system

SMART is not a filesystem check.

and after mount ,i can see everything in the disk,it seems all fine...

Yes, the filesystem is mounted correctly, that's why you can see everything.
That doesn't mean that there is zero problems though.

is fsck has the same function?

That answers why you cannot make it rw.

Your ntfs filesystem is in a dirty state. To revert that you need to boot into Windows.

Disable Windows Fastboot and Hybrid sleep.

Always ensure a clean shutdown otherwise the ntfs-3g driver will only mount ro.

fsck will not work on a ntfs file system - to fix such system you need to boot into Windows and run the Windows tool either GUI or from a terminal using the chkdsk drive: command.

1 Like

fsck = filesystem check

For the rest, as linux-aarhus said, boot into Windows and run fsck as well as disable fastboot/hybrid.

i use it most of the time in a openwrt like system in router...few times plug into Windows to copy some files...

I'd suggest to create a native linux filesystem and create a share to interact with Windows. NTFS is just a bad idea to use in Linux.

1 Like

i have install a Manjaro system in my pc
Is there a better way to do something? i don't want to change anything in my Windows...

i have install a Manjaro system in my pc
Is there a better way to do something? i don't want to change anything in my Windows...:sweat_smile:

Hello,

If this drive is formatted ntfs, Please log into windows, and make sure to completely shut down. If you are using fastboot in windows, it does not completely shut down and will still have the drive as mounted. Once you shut down windows, then boot into linux and see if the drive will mount cleanly.

i'm not doing what you have suggest...just plug in my Manjaro system...
it mount on Manjaro correctly,with rw...
why it can't mount on PVE with rw?

[captain@captain-pc captain]$ chmod -v 755 soft/
'soft/' 的权限模式已由 0777 (rwxrwxrwx) 更改为 0755 (rwxr-xr-x)

i am not change it before ,but the original mode is 777...:drooling_face::joy:

the error in PVE is this:


create storage failed: error with cfs lock 'file-storage_cfg': mkdir /mnt/sda5/images: Read-only file system at /usr/share/perl5/PVE/Storage/Plugin.pm line 952. (500)

SOLVED!!
format HDD to ext4 mode
then,run fsck -y /dev/sda1

everything is fine now...:partying_face::partying_face::partying_face::partying_face::partying_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by