Not able to boot after doing a system update. How do I fix it?

ok just create
sudo nano /boot/vmlinuz-5.6-x86_64 and save
redo
mkinitcpio -P

1 Like

i still get this

[manjaro /]# mkinitcpio -P
==> Building image from preset: /etc/mkinitcpio.d/linux56.preset: 'default'
  -> -k /boot/vmlinuz-5.6-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.6-x86_64.img
==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-5.6-x86_64'
==> Building image from preset: /etc/mkinitcpio.d/linux56.preset: 'fallback'
  -> -k /boot/vmlinuz-5.6-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.6-x86_64-fallback.img -S autodetect
==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-5.6-x86_64'

can you return

mhwd -li
1 Like
[manjaro /]# mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux          [quote="stephane, post:20, topic:142017"]
mhwd -li
[/quote]

> Blockquote  2018.05.04                true            PCI
    video-nvidia-430xx            2019.10.25               false            PCI


Warning: No installed USB configs!

sorry

mhwd-kernel -li 
1 Like
[manjaro@manjaro ~]$ mhwd-kernel -li 
Currently running: 5.6.11-1-MANJARO (linux56)
The following kernels are installed in your system:
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
   * linux56
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)

you have quit chroot be very careful!

manjaro-chroot -a 
mhwd-kernel -li 
1 Like

that was a mistake. I had another open terminal lol. this is the result from chroot

[manjaro /]# mhwd-kernel -li 
Currently running: 5.6.11-1-MANJARO (linux56)
The following kernels are installed in your system:

then

pacman -Syy
pacman -S linux56
1 Like

hmmm..

[manjaro /]# pacman -Syy
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from www.mirrorservice.org : Could not resolve host: www.mirrorservice.org
error: failed retrieving file 'core.db' from mirrors.dotsrc.org : Could not resolve host: mirrors.dotsrc.org
error: failed retrieving file 'core.db' from manjaro.ynh.ovh : Could not resolve host: manjaro.ynh.ovh
error: failed retrieving file 'core.db' from mirror.datacenter.by : Could not resolve host: mirror.datacenter.by
error: failed retrieving file 'core.db' from mirror.koddos.net : Could not resolve host: mirror.koddos.net
error: failed retrieving file 'core.db' from ftp.free.org : Could not resolve host: ftp.free.org
error: failed retrieving file 'core.db' from ftp.cuhk.edu.hk : Could not resolve host: ftp.cuhk.edu.hk
error: failed retrieving file 'core.db' from manjaro.osmir.ch : Could not resolve host: manjaro.osmir.ch
error: failed to update core (invalid url for server)
error: failed retrieving file 'extra.db' from www.mirrorservice.org : Could not resolve host: www.mirrorservice.org
error: failed retrieving file 'extra.db' from mirrors.dotsrc.org : Could not resolve host: mirrors.dotsrc.org
error: failed retrieving file 'extra.db' from manjaro.ynh.ovh : Could not resolve host: manjaro.ynh.ovh
error: failed retrieving file 'extra.db' from mirror.datacenter.by : Could not resolve host: mirror.datacenter.by
error: failed retrieving file 'extra.db' from mirror.koddos.net : Could not resolve host: mirror.koddos.net
error: failed retrieving file 'extra.db' from ftp.free.org : Could not resolve host: ftp.free.org
error: failed retrieving file 'extra.db' from ftp.cuhk.edu.hk : Could not resolve host: ftp.cuhk.edu.hk
error: failed retrieving file 'extra.db' from manjaro.osmir.ch : Could not resolve host: manjaro.osmir.ch
error: failed to update extra (invalid url for server)
error: failed retrieving file 'community.db' from www.mirrorservice.org : Could not resolve host: www.mirrorservice.org
error: failed retrieving file 'community.db' from mirrors.dotsrc.org : Could not resolve host: mirrors.dotsrc.org
error: failed retrieving file 'community.db' from manjaro.ynh.ovh : Could not resolve host: manjaro.ynh.ovh
error: failed retrieving file 'community.db' from mirror.datacenter.by : Could not resolve host: mirror.datacenter.by
error: failed retrieving file 'community.db' from mirror.koddos.net : Could not resolve host: mirror.koddos.net
error: failed retrieving file 'community.db' from ftp.free.org : Could not resolve host: ftp.free.org
error: failed retrieving file 'community.db' from ftp.cuhk.edu.hk : Could not resolve host: ftp.cuhk.edu.hk
error: failed retrieving file 'community.db' from manjaro.osmir.ch : Could not resolve host: manjaro.osmir.ch
error: failed to update community (invalid url for server)
error: failed retrieving file 'multilib.db' from www.mirrorservice.org : Could not resolve host: www.mirrorservice.org
error: failed retrieving file 'multilib.db' from mirrors.dotsrc.org : Could not resolve host: mirrors.dotsrc.org
error: failed retrieving file 'multilib.db' from manjaro.ynh.ovh : Could not resolve host: manjaro.ynh.ovh
error: failed retrieving file 'multilib.db' from mirror.datacenter.by : Could not resolve host: mirror.datacenter.by
error: failed retrieving file 'multilib.db' from mirror.koddos.net : Could not resolve host: mirror.koddos.net
error: failed retrieving file 'multilib.db' from ftp.free.org : Could not resolve host: ftp.free.org
error: failed retrieving file 'multilib.db' from ftp.cuhk.edu.hk : Could not resolve host: ftp.cuhk.edu.hk
error: failed retrieving file 'multilib.db' from manjaro.osmir.ch : Could not resolve host: manjaro.osmir.ch
error: failed to update multilib (invalid url for server)
error: failed to synchronize all databases

ok just create ( error name )

nano /boot/vmlinuz-5.6-x86_64 and save
mkinitcpio -P
1 Like

ok it finally worked

manjaro /]# nano /boot/vmlinuz-5.6-x86_64
[manjaro /]# mkinitcpio -P
==> Building image from preset: /etc/mkinitcpio.d/linux56.preset: 'default'
  -> -k /boot/vmlinuz-5.6-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.6-x86_64.img
==> Starting build: 5.6.11-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.6-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux56.preset: 'fallback'
  -> -k /boot/vmlinuz-5.6-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.6-x86_64-fallback.img -S autodetect
==> Starting build: 5.6.11-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.6-x86_64-fallback.img
==> Image generation successful

then

update-grub 
exit ( quit chroot )

then reboot

1 Like

ok this is what i got. I will reboot now and will report back shorty.

[manjaro /]# update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.6-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.6-x86_64.img
Found initrd fallback image: /boot/initramfs-5.6-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.6-x86-64
Found initrd image: /boot/intel-ucode.img
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your device.map.
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

it's ok ( security on USB iso )

exit ( quit chroot )

then you can reboot

1 Like

And I'm back on my system! Thank you so much! but I have 1 more problem, my Windows 10 installation is missing on grub menu.

can you please recheck this

sudo pacman -Syyu
sudo mhwd-kernel -i linux54 
sudo pacman -Qs os-prober
sudo pacman -Qs lsb-release

for windows 10 boot repair

1 Like

here's what i get

$ sudo pacman -Qs os-prober
local/os-prober 1.77-1
    Utility to detect other OSes on a set of drives
$ sudo pacman -Qs lsb-release
local/lsb-release 1.4-13
    LSB version query program

i cant boot fine to my windows 10 though through boot manager not just from grub, there is no windows 10 entry anymore.

nvm after rebooting, my windows installation is back :smiley:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by