Not able to boot KDE after update (Dec. 11 or 12)

I was not able to complete the update to Manjaro 16.10 KDE on Dec. 11 or 12. The system was waiting for the mkinitcpio.
Now I am not able to boot at all. My system hangs. I have tried several kernels.

Generate customized manual initcpio
Users can generate an image using an alternative configuration file. For example, the following will generate an initramfs image according to the directions in /etc/mkinitcpio-custom.conf and save it at /boot/linux-custom.img.

mkinitcpio -c /etc/mkinitcpio-custom.conf -g /boot/linux-custom.img

If generating an image for a kernel other than the one currently running, add the kernel version to the command line. You can see available kernel versions in /usr/lib/modules.

mkinitcpio -g /boot/linux-custom2.img -k 3.3.0-ARCH


The primary configuration file for mkinitcpio is /etc/mkinitcpio.conf. Additionally, preset definitions are provided by kernel packages in the /etc/mkinitcpio.d directory (e.g. /etc/mkinitcpio.d/linux.preset).
Warning: lvm2, mdadm, and encrypt are NOT enabled by default. Please read this section carefully for instructions if these hooks are required.

I have no problem with Manjaro Gnome/Cinnamon/LXQt.

Can you take a closer look at the line HOOKS=... in your /etc/mkinitcpio.conf?

/etc/mkinitcpio.conf for KDE:

HOOKS="base udev autodetect modconf block keyboard keymap plymouth resume filesystems fsck"

/etc/mkinitcpio.conf for Cinnamon:

HOOKS="base udev autodetect modconf block keyboard keymap plymouth resume filesystems fsck"

The HOOKS = ... is same for KDE and Cinnamon.

1 Like

Look at this topic

Is your problem a similar one?

No, my problem could be simple or complex. I have no idea.

I am not able to boot at all. The system could be in an end-less loop. It might be doing fsck or just waiting for something.

I will save my files and re-install KDE 17.xx sometime next year.

I have Gnome/Cinnamon/LXQt in good working shape. All my systems are indentical except the GUI.

Manjaro Gnome is rock solid. I am staying with Kernel 4.8.X for all my systems.

If mkinitcpio failed during your update do you even have an initramfs to enable the boot process?

When did you last update your KDE system prior to the 12-Dec update? There was a systemd update included on 12-Dec, and if you were updating from 2.31-1 it has the potential to leave your system in an unstable state. This was clearly pointed out at the top of the Stable Update thread.

To find out what is going on boot into a Live environment, mount your system partition, change your root directory with manjaro-root, and check your journal logs, kernel logs, systemd failed units, etc... assuming your boot process actually loads the kernel and systemd. Pacman logs could if your pacman system upgrade failed for any reason.

I have tried several kernels. I am not getting any output from the boot process.I suspect the system is waiting for something.

I have to interrupt the update because it was in an end-less loop.

I am thinking to re-install a future version of KDE.

Gnome/Cinnamon/LXQt are running systemd 232 without any problem.

It was KDE Dec. 12 update or me interrupting update which was in an end-less loop which caused this problem.

This is NOT a KDE problem. KDE is an innocent bystander caught in a kernel failure.

I was using Kernel 4.9 in KDE 16.10. Dec. 12 update did update the Kernel 4.9. But I had to interrupt the update because of an end-less loop.

Now the same end-less loop is happening at boot time. But now Kernels 4.8.x or 4.4.x also will not boot. So a dead KDE 16.10 desktop.

Well, I can wait for a good KDE 17.xx desktop in 2017.

A new KDE wont fix it, because its not a KDE problem. You horked your kernel. KDE is just the lipstick, not the pig. Your pig died. A new shade of lipstick won't fix that.

1 Like

The kernel series linux44 and linux48 got a lot of updates lately. It may also depend on your hardware. KDE has nothing to do with it, as you never reach the Xorg-Session at all. This is only related on the current installation of Manjaro on that system. However I don't know what might have caused it.

I re-installed KDE 16.10.3 and applied all the updates. Both Kernels 4.8.x and 4.4.x are now working fine.

Thanks everyone for great help.

Might be worthwhile you doing some reading to get a better conceptual understanding of the Linux boot process, could help you being able to fix a similar issue next time rather than simply re-installing without knowing what caused it.


Forum kindly sponsored by