Not able to install bootloader grub of manjaro in windows 10 dual boot

Hahaha, he may be asleep.
I apologize for not having the expertise to advise you.
Thanks for your patience. :innocent:

1 Like

can you boot wit USB install manajro
open a terminal and returns

inxi -Fxxxz
parted -l

Right now Im following this post,

Im using live dvd...and im not having any usb sticks available right now

Hey it's alright. Thank you for taking your time out for me.

I am outside typing from phone.
Will answer in 3 hours time.
Meantime, try booting your installed manjaro os using this post in uefi. Provide information as required in that link.

Oh.. efi partition must be in fat32 .
You will have to do quite a few things to fix it. But need the data. Print please, not screen shots.

Please explain what you mean.

Why do you call that partition "the efi partition"? Are you sure Windows was installed in UEFI mode?

How did you "install grub on that"?

Boot to Live DVD (Manjaro installer) and get and post info as requested.
It looks possible that Windows is in MSDOS Legacy and you are trying to install Manjaro in UEFI. If not, describe more about it.
From a Manjaro boot, we need

sudo parted -l
efibootmgr -v

More comments after more info :wink:

I messed up even more by trying to install grub in different partitions , Thereby losing option to boot windows itself.
I was presented just with a grub > on restart .
As I couldnt move further, I installed a fresh copy of windows 10 .
Now I'll try answering all your questions by using the Live DVD

I'll do this now....Thank you for replying

Now that I have installed a fresh copy of Windows in legacy mode, I should be booting the live DVD of manjaro also in legacy right?

Yes. and the drive in msdos. Good luck.

1 Like
[manjaro@manjaro ~]$ inxi -Fxxxz
  Host: manjaro Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: KDE Plasma 5.15.2 tk: Qt 5.12.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Gigabyte model: 970A-DS3P serial: <filter> 
  BIOS: American Megatrends v: FC date: 06/01/2015 
  Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP arch: Bulldozer 
  L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 42212 
  Speed: 1406 MHz min/max: 1400/3500 MHz boost: enabled 
  Core speeds (MHz): 1: 1434 2: 1447 3: 1423 4: 1426 5: 1406 6: 1400 
  Device-1: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:128b 
  Display: x11 server: X.Org 1.20.4 driver: nouveau unloaded: modesetting 
  alternate: fbdev,nv,vesa compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: NV106 v: 4.3 Mesa 18.3.4 direct render: Yes 
  Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 chip ID: 1002:4383 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: ZOTAC 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e0f 
  Sound Server: ALSA v: k4.19.28-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
  Local Storage: total: 931.51 GiB used: 83.4 MiB (0.0%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 2A scheme: MBR 
  ID-1: / size: 4.39 GiB used: 83.4 MiB (1.9%) fs: overlay 
  source: ERR-102 
  System Temperatures: cpu: 31.2 C mobo: N/A gpu: nouveau temp: 64 C 
  Fan Speeds (RPM): N/A 
  Processes: 175 Uptime: 8m Memory: 5.85 GiB used: 577.9 MiB (9.6%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 
  running in: konsole inxi: 3.0.32 

[manjaro@manjaro ~]$ efibootmgr -v
EFI variables are not supported on this system.

[manjaro@manjaro ~]$ sudo parted -l
Model: ATA TOSHIBA MQ01ABD1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type      File system  Flags
 1      1049kB  577MB   576MB  primary   ntfs         esp
 2      577MB   105GB   104GB  primary   ntfs         boot
 3      105GB   566GB   461GB  primary   ntfs
 4      566GB   1000GB  434GB  extended               lba
 5      566GB   803GB   237GB  logical   ntfs
 6      892GB   1000GB  108GB  logical   ntfs

Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Error: Can't have a partition outside the disk!
Ignore/Cancel? ignore                                                     
Model: ATAPI iHAS124 F (scsi)
Disk /dev/sr0: 2100MB
Sector size (logical/physical): 2048B/2048B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      8385MB  8402MB  16.8MB  primary               esp

[manjaro@manjaro ~]$ efibootmgr -v
EFI variables are not supported on this system.

There is no fat32 or ext4(linux) partition visible.
So, there is no installed Manjaro.
Or explain more... :wink:

You should install Manjaro in MSDOS mode (not UEFI).

I removed manjaro now , Installed windows 10 on that partition...
Have allocated free space for installing manjaro again.
I'll be allocating the free space for manjaro, but then what should I choose as boot/esp thing?
There is no fat32 also as I deleted that partition I created..

Forget about fat32 (and $esp, wrong partition flag), it's only for UEFI installation, which you are not.
Install Manjaro as usual (boot Live media in MSDOS-Legacy mode, not UEFI) in the space left and choose to install bootloader to sda.

1 Like

I'll try this now

1 Like

Thank you for the help @AgentS and @gohlip . Now the problem is solved.
I have reinstalled both windows 10 and Manjaro in Legacy mode.
And the problem was that the first installation of windows was in uefi and boot partition was ntfs and not fat32.

Now its solved. thanks again!
Happy manjaro user again! :smile:

We had a discussion about this some time ago.
I thought I remembered another report about Windows $esp being NTFS, but we found no mention at UEFI specification papers.
Please confirm that Windows was running in UEFI with $esp partition being NTFS. (we have the parted report for the partitions).
@gohlip note this down :wink:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by