Not all ram detected [SOLVED]

Hello Everyone!

As you read in the title my system is not sensing all of my ram. I have 8 gigs of ram but my system tells me I only have 4-5 gigs. Help would be appreciated.

Can we see inxi -Fxxxz

Is it a laptop that shares RAM with the GPU?

System: Host: isaac-inspiron3785 Kernel: 5.6.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: i3 4.18.1
info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine: Type: Laptop System: Dell product: Inspiron 3785 v: 1.4.0 serial: Chassis: type: 10 v: 1.4.0
Mobo: Dell model: 0VY1RG v: X01 serial: UEFI: Dell v: 1.4.0 date: 05/29/2019
Battery: ID-1: BAT1 charge: 40.6 Wh condition: 40.6/42.0 Wh (97%) volts: 13.0/11.4
model: Simplo 0x32,0x39,0x37,0x55,0x00,0x00,0x0006 type: Li-ion serial: status: Full
CPU: Topology: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen
L2 cache: 2048 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31952
Speed: 1493 MHz min/max: 1600/2000 MHz boost: enabled Core speeds (MHz): 1: 1464 2: 1596 3: 1429 4: 1594 5: 1369
6: 1373 7: 1448 8: 1402
Graphics: Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] vendor: Dell driver: amdgpu v: kernel
bus ID: 03:00.0 chip ID: 1002:15dd
Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
resolution: 1600x900~60Hz
OpenGL: renderer: AMD RAVEN (DRM 3.36.0 5.6.12-1-MANJARO LLVM 10.0.0) v: 4.6 Mesa 20.0.6 direct render: Yes
Audio: Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Dell driver: snd_hda_intel
v: kernel bus ID: 03:00.1 chip ID: 1002:15de
Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Dell driver: snd_hda_intel v: kernel
bus ID: 03:00.6 chip ID: 1022:15e3
Sound Server: ALSA v: k5.6.12-1-MANJARO
Network: Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: 2000
bus ID: 01:00.0 chip ID: 10ec:8136
IF: enp1s0 state: down mac:
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel
port: 2000 bus ID: 02:00.0 chip ID: 168c:0042
IF: wlp2s0 state: up mac:
Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 3-2.4:5 chip ID: 0cf3:e009
Drives: Local Storage: total: 931.51 GiB used: 53.07 GiB (5.7%)
ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm
serial: rev: 0D scheme: GPT
Partition: ID-1: / size: 906.94 GiB used: 53.07 GiB (5.9%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 8.80 GiB used: 2.9 MiB (0.0%) fs: swap dev: /dev/sda3
Sensors: System Temperatures: cpu: 77.1 C mobo: N/A gpu: amdgpu temp: 77 C
Fan Speeds (RPM): fan-1: 0
Info: Processes: 255 Uptime: 23h 34m Memory: 5.76 GiB used: 2.11 GiB (36.7%) Init: systemd v: 245 Compilers: gcc: 9.3.0
Shell: bash v: 5.0.16 running in: xfce4-terminal inxi: 3.0.37

Yes it is a APU chip. As such it is normal for some RAM to get reserved for use with the integrated GPU.

1 Like

Yes, with Ryzen 5 APU about 3GB is normal. It isn't something you can control in Linux.

There may be a setting in your BIOS to alter how much RAM is reserved for graphics.

1 Like

So my gpu uses half of my 8 gig ram?

Doesn't look like half. It looks like there is 5.76GB for the OS and you have 2GB in use by the OS/Applications.

1 Like

Should my gpu use 2 gigs of memory?

That is pretty typical, yes. I think my Ryzen 5 laptop reserves 2-3GB.

It is a balance between GPU performance and available memory.

Sometimes this can be altered in the BIOS.


Would it be bad if I altered it?

It depends what you do with your laptop. If you do GPU intensive tasks like gaming or rendering, yes, you might lower performance. If not, it would probably be fine.

Of course, that assumes that you BIOS has a way to change it. Not all of them do.

1 Like

OK, I will probably leave it. Thanks for the help @dalto

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by