Not detecting Nvme ssd with windows 10 installed on GRUB

I recently installed Manjaro on my hard drive as a backup to Windows 10, which is installed on my Nvme ssd. I was confused why the GRUB menu was not coming up during boot, so I managed to re-enable it and Windows was not listed in the boot list. I looked through drives, partitions, and fdisk to try and see if the drive was even recognized, but it did not appear anywhere.

fdisk -l results

Disk /dev/sda: 931.53 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC WD10SPZX-21Z
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 198E9521-2006-BE46-9CFE-766AC2738BA7

Device      Start        End    Sectors   Size Type
/dev/sda1    4096     618495     614400   300M EFI System
/dev/sda2  618496 1953520064 1952901569 931.2G Linux filesystem


Disk /dev/mapper/luks-9c3cbd6e-d43f-428a-86da-7bf9aec00399: 931.22 GiB, 999883506176 bytes, 1952897473 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/loop0: 24.73 MiB, 25915392 bytes, 50616 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 54.97 MiB, 57614336 bytes, 112528 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop2: 160.16 MiB, 167931904 bytes, 327992 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop3: 57.32 MiB, 60096512 bytes, 117376 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop4: 48.3 MiB, 50642944 bytes, 98912 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

lsblk results

NAME       MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
loop0        7:0    0  24.7M  1 loop  /var/lib/snapd/snap/snapd/6434
loop1        7:1    0    55M  1 loop  /var/lib/snapd/snap/core18/1705
loop2        7:2    0 160.2M  1 loop  /var/lib/snapd/snap/gnome-3-28-1804/116
loop3        7:3    0  57.3M  1 loop  /var/lib/snapd/snap/discord/109
loop4        7:4    0  48.3M  1 loop  /var/lib/snapd/snap/gtk-common-themes/1474
sda          8:0    0 931.5G  0 disk  
├─sda1       8:1    0   300M  0 part  /boot/efi
└─sda2       8:2    0 931.2G  0 part  
  └─luks-9c3cbd6e-d43f-428a-86da-7bf9aec00399
           254:0    0 931.2G  0 crypt /

Hope someone can figure this out.

Something to look into might be the SATA operation in firmware/bios settings. Change from RAID to AHCI and see if it works.

I am on RST with Optane. The other option is AHCI, but when I change to that Windows does not boot.
I can try converting it using this link

I am afraid this could be the cause of the problem. As far as I know Optane is not supported by Linux. Perhaps others might provide more insight to this issue.

The ssd is not optane, it is just the default configuration

Honestly I am not familiar with the process described in the link, I have never done such a thing myself.

You might want to wait for some one with this experience to come along to give comments/suggestions.

Otherwise

PROCEED AT YOUR OWN RISK!

As it says in the article.

Keep my fingers crossed.

Thank you for the help! I have solved the problem.

I used this guide and the installation was able to recognize the other drive. I was not able to boot into the drive using the same device however. To get into my linux installation after completing the steps below, I had to re-add the boot file. I realized this after I installed a fresh edition of linux on my Nvme drive however. GRUB worked perfectly without me having to enable it.

DO THIS AT YOUR OWN RISK. Can potentially make windows unbootable without repairing it through installation media

  1. Right-click the Windows Start Menu. Choose Command Prompt (Admin) .
  2. If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows. If so, use this method instead to get to the Command Prompt:
    1. Click the Start Button and type cmd
    2. Right-click the result and select Run as administrator
  3. Type this command and press ENTER: bcdedit /set {current} safeboot minimal
  4. If this command does not work for you, try bcdedit /set safeboot minimal
  5. Restart the computer and enter BIOS Setup (the key to press varies between systems).
  6. Change the SATA Operation mode to AHCI from either IDE or RAID or RST with Optane (again, the language varies).
  7. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  8. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin) .
  9. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
  10. If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot
  11. Reboot once more and Windows will automatically start with AHCI drivers enabled.
2 Likes

That's great!
Congrats and welcome to Manjaro Forum!

:bouquet:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by