Not getting screen lock after suspend

I have manjaro community edition with i3 . Everything is working fine exept that i am not receiving the blurlock unlocking option after my laptop suspend. Whenever i close my lid it went to sleep but after i opened it , the screen is already unlocked . I saw several posts related to that and changed it in i3exit and some other files but i am still having the issues. PLease anyone who know how to solve it?

I had same problem I solved it by locking the screen by mod+9 and then closed the lid.
I know it is not what you asked for.

yeah it is just a temporary fix not a permanent. But i have siblings and travel a lot and i know i wont be consistence in doing mod+9 every time i close my laptop so i want a permanent fix.

Have you tried the settings in "Xfce Power Manager" ?

I went ahead and made a service that will lock it every time I will suspend. Thanks
Made a file

/etc/systemd/system/i3-lock.service

And past this in it dont forget to change your user name and the lock system you are using . In my case, it uses blurlock to do it.


[Unit]
Description=i3lock service
Before=sleep.target
Before=suspend.target

[Service]
User=<user>
Type=forking
Environment=DISPLAY=:0
ExecStart=/usr/bin/blurlock -c 000000

[Install]
WantedBy=sleep.target

Then enable this service by typing

sudo systemctl enable i3-lock.service

And it wil works now....

1 Like

Forum kindly sponsored by