NTFS HDD Not Mounting After Swapping Out Windows SSD

I have a dual boot system with x2 SSDs (1 for Manjaro, 1 for Win 10) and an HDD that up until recently I used as shared storage between the systems (and larger scale storage). The HDD is formatted as NTFS, but that's not been a problem as I'm not running programs off it or anything, just storing media, docs etc.

About 2 weeks ago, I switched out my old 120GB SSD (Win10 drive) for a 1TB SSD and had a fresh Win10 install on it. Since then, I've been unable to access my HDD from the Manjaro side, though it works fine on Win10.

Some more details:

inxi --full --verbosity=7 --filter --no-host
System:    Kernel: 5.4.44-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: H97M-G43(MS-7924) v: 1.0 serial: <filter> UEFI: American Megatrends v: 2.1 
           date: 04/29/2014 
Memory:    RAM: total: 15.57 GiB used: 2.60 GiB (16.7%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Quad Core model: Intel Core i7-4790 bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 8192 KiB 
           bogomips: 57621 
           Speed: 3241 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3241 2: 2292 3: 3538 4: 3708 5: 3042 6: 3283 7: 2252 
           8: 2491 
           Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid 
           cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase 
           fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr nonstop_tsc 
           nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good 
           sdbg sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
           tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nvidia v: 440.82 bus ID: 01:00.0 
           chip ID: 10de:1b81 
           Display: x11 server: X.Org 1.20.8 driver: nvidia compositor: kwin_x11 resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: Intel 9 Series Family HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:8ca0 
           Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f0 
           Sound Server: ALSA v: k5.4.44-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8168 
           v: 8.048.03-NAPI port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter driver: ath9k v: kernel port: d000 bus ID: 04:00.0 
           chip ID: 168c:002e 
           IF: wlp4s0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 6.82 TiB used: 1.12 TiB (16.4%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> rev: 4B6Q 
           scheme: MBR 
           ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> rev: 3B6Q 
           scheme: GPT 
           ID-3: /dev/sdc vendor: Western Digital model: WD20EZRX-00D8PB0 size: 1.82 TiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 0A80 scheme: MBR 
           ID-4: /dev/sdd type: USB vendor: Seagate model: Expansion Desk size: 3.64 TiB serial: <filter> rev: 9401 
           scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / size: 457.16 GiB used: 171.57 GiB (37.5%) fs: ext4 dev: /dev/sdb2 label: N/A 
           uuid: 6d15d5e4-b92e-4fc7-a4d6-5e07ce1556e1 
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/sdb1 label: N/A uuid: 254E-8907 
           ID-3: /run/media/user/D6084D8E084D6F15 size: 930.97 GiB used: 194.32 GiB (20.9%) fs: ntfs dev: /dev/sda2 label: N/A 
           uuid: D6084D8E084D6F15 
           ID-4: /run/media/user/Seagate Expansion Drive size: 3.64 TiB used: 777.34 GiB (20.9%) fs: ntfs dev: /dev/sdd2 
           label: Seagate Expansion Drive uuid: FA783A8A783A45A3 
           ID-5: /run/timeshift/backup raw size: 465.46 GiB size: <root required> used: <root required> fs: ext4 
           dev: /dev/sdb2 label: N/A uuid: 6d15d5e4-b92e-4fc7-a4d6-5e07ce1556e1 
Unmounted: ID-1: /dev/sda1 size: 50.0 MiB fs: ntfs label: System Reserved uuid: 4E3C4B163C4AF88B 
           ID-2: /dev/sda3 size: 505.0 MiB fs: ntfs label: N/A uuid: 1A7205FF7205DFFD 
           ID-3: /dev/sdc1 size: 99.0 MiB fs: <root required> label: N/A uuid: N/A 
           ID-4: /dev/sdc2 size: 1.82 TiB fs: ntfs label: Evan uuid: 0642A25942A24D6D 
           ID-5: /dev/sdd1 size: 128.0 MiB fs: <root required> label: N/A uuid: N/A 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 1-1:2 info: Intel ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 8087:8009 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 14 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 2-1:2 info: Logitech Gaming Keyboard G213 type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 
           rev: 2.0 speed: 12 Mb/s chip ID: 046d:c336 serial: <filter> 
           Device-2: 2-2:3 info: Razer USA Razer Naga Epic Chroma type: Mouse,Keyboard driver: hid-generic,usbhid 
           interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 1532:003e 
           Device-3: 2-4:4 info: Seagate RSS LLC SRD0NF2 [Expansion Desktop Drive] type: Mass Storage driver: uas 
           interfaces: 1 rev: 2.1 speed: 480 Mb/s chip ID: 0bc2:3322 serial: <filter> 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 3-1:2 info: Intel ports: 8 rev: 2.0 speed: 480 Mb/s chip ID: 8087:8001 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 32.0 C mobo: N/A gpu: nvidia temp: 41 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 220 Uptime: 27m Init: systemd v: 245 Compilers: gcc: 10.1.0 clang: 10.0.0 Shell: bash v: 5.0.17 
           running in: konsole inxi: 3.0.37 

The drive in question is:

/dev/sdc

I can see the Drive name appearing in Dolphin as it did before, but now when I click it I get

The requested operation has failed: Error mounting /dev/sdc2 at /run/media/user/Evan: Unknown error when mounting /dev/sdc2

I did some reading of other forum posts and think that the problem is he partition table on the drive.

$journalctl | grep -i ntfs
.
.
.
Jun 03 14:17:23 baphomet user[116060]: 05efi: debug: /dev/sdc2 is ntfs partition: exiting
Jun 03 14:17:23 baphomet user[116060]: 50mounted-tests: debug: mounted using GRUB ntfs filesystem driver

.
.
.

Jun 24 12:53:30 baphomet udisksd[3323]: The device '/dev/sdc2' doesn't seem to have a valid NTFS.

Jun 24 13:09:05 baphomet udisksd[3856]:    or the partition table is corrupt (partition is smaller than NTFS),
Jun 24 13:09:05 baphomet udisksd[3856]:    or the NTFS boot sector is corrupt (NTFS size is not valid).
Jun 24 13:09:05 baphomet udisksd[3856]: The device '/dev/sdc2' doesn't seem to have a valid NTFS.

I also noticed that when I ran the inxi command, i says there are 2 partitions sdc1 and sdc2, with one of them being 99Mb. But when I look in Windows at the disk manager partition table, it only shows the 1 partition (no 99Mb) partition.

I also checked hat ntfs-3g was installed and up to date with pacman -Qs ntfs-3g and it is installed and up to date

Maybe I changed something about the drive in Win10 side and that's caused problems for Manjaro?

Any help as to how to properly mount this drive once more would be greatly appreciated!

Thanks

Reboot into Windows. Open the Explorer and right click on the device you cannot read from Manjaro - repair the filesystem.

Also - disable Windows Fast Boot and hibernation and Hybrid Sleep.

1 Like

thanks for your response.

I've checked the drive for errors in Windows (Properties > Tools > Check), but the utility finds no errors on the drive. I've got Hybrid Sleep, hibernation and fast boot all disabled.

Whilst I know this is now in Windows, not manjaro, territory the log file for the Check I ran reports:

Stage 1: Examining basic file system structure ... Stage 2: Examining file name linkage ... The sparse flag in standard information attribute in file 0x4f should not be set. Correcting sparse file record segment 79. "chkdsk /scan" is aborting due to self-healing command failure: 0xc0000102 "chkdsk /f" will be required to repair the volume.  
   00530A00372E09002268100000000000FD3A0000000000000000000000000000 

So I ran chkdsk /f on the drive from a command prompt but that says that there's no problems.

Should I try chkdsk /r overnight to see if that picks up any bad sectors?

I should also say, that when I went back onto Windows, I checked the disk manager. There is only 1 drive letter allocated (E:/) but appears to be two volumes potentially? (the 99MB and the other 1.86TB). I noticed that it is listed as a 'Dynamic' Drive and just looked this up here: https://docs.microsoft.com/en-us/windows/win32/fileio/basic-and-dynamic-disks#basic-disks.

Could this have something to do with it? Is there a way to change the drive back into a 'Basic' disk without losing the data stored on it?

:man_shrugging: Maybe?

It seems that the term dynamic disk is comparable to LVM on Linux.

It also appears Microsoft has deprecated the use of dynamic disks in favor of storage spaces.

Also it is not possible to change a dynamic disk to basic without removing all data from the device.

Ok, thanks for your help!

It might be that the easiest solution is just to backup the data on another drive and reformat.

My own personal opinion is that there is something not quite right about this drive. Generally you don't receive error messages about a drive that are uncorrectablle unless its got problems.

Personally I would only use this drive for non essential data from now on. For example, as redundant backup media storage. I wouldn't trust this drive anymore for important data you can't afford lose.

That's probably just me, but I always feel better safe than sorry.

Thanks for the advice. I ended up transferring all of the important data to a new drive and just swapping it out (lucky I had an unused blank HDD lying around). Having some strange, possibly unrelated issues in Win 10, but everything is working fine on the Manjaro side!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by