NTP showing wrong time .... How to fix?

Hi,
I am using Manjaro XFCE 64. Problem is the clock is showing wrong time.

How do I fix this ?

There's "Time Settings" in the menu. Have you tried that?

I just typed time and time settings on the menu search area but nothing appeared.

Are you dual booting with Windows? The two may be fighting one another for control of the clock. Here's one article on it -- Google lists many.

1 Like

I got Windows as dual boot but I almost never boot to Windows. I am pretty sure I haven't booted to Windows after installing Manjaro.

It's in the System menu in my Manjaro XFCE. The command that runs it is gksudo timeset-gui (you could try that in a terminal).

If running the command doesn't work, you can install timeset-gui with the software manager.

Start menu > Settings Manager > Manjaro Settings Manager > Time and Date

7 Likes

Installed timeset-gui and configured it but it seems to have no effect on the time.

1 Like

Start menu > Settings Manager > Manjaro Settings Manager > Time and Date
THen selected Set time and date automatically but it too has no effect on the time.

Maybe using timedatectl?

$ timedatectl
Local time: Sun 2016-07-31 06:46:18 IST
Universal time: Sun 2016-07-31 01:16:18 UTC
RTC time: Sun 2016-07-31 06:46:18
Time zone: Asia/Kolkata (IST, +0530)
Network time on: yes
NTP synchronized: no
RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
This mode can not be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
'timedatectl set-local-rtc 0'.

The tome zone is correct. Dunno whats going wrong here.

timedatectl set-time "yyyy-MM-dd hh:mm:ss"
For example for me it would be: timedatectl set-time 2016-07-30 22:24:50

In timeset-gui you tried #4 "Synchronize time from the network"?

$ timedatectl set-time "2016-07-31 07:57:00"
Failed to set time: Automatic time synchronization is enabled

I am facing an issue with timeset-gui. When I click on show timezone the timezone dialog box appears but I cant select my timezone. There is no area to select the timezone.

https://wiki.archlinux.org/index.php/time#Set_clock Check there, it may help you.

"Show timezones" is just a list of timezones. You said your timezone is already correct.

But your timedatectl command also returned "NTP synchronized: no" so I thought you should just try "synchronize time from the network" and see if it syncs properly.

Sorry I made a mistake. "Show timezones" shows the timezones. Setting of the timezone is handled by set system timezone".

Yes, I clicked on the "Synchronize time from the network" but the time is still stuck at 01:56 but the correct local time now is 7:27.

Change your BIOS clock to local time, Windows to local time, Manjaro to local time.

Regards

Hey guys. I had the same problem in my laptop with Windows 10 and Manjaro. I solved it by doing the following steps:

  1. Boot into Manjaro.
  2. Go to "Manjaro Settings Manager".
  3. Go to "Time and Date".
  4. Turn on "Set time and date automatically".
  5. Boot into Windows 10.
  6. Open "Time and date settings".
  7. Turn off "Set time automatically" and "Set time zone automatically".
  8. Launch Command Prompt as Administrator.
  9. For 32 bit Windows execute:
    Reg add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_DWORD /d 1

For 64 bit Windows execute:
Reg add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_QWORD /d 1

That's all.

3 Likes

Forum kindly sponsored by