Nvidia Driver not detected after reinstalling driver

Hi everyone.
I'm posting here because I'm facing to a gpu driver issue after trying to reinstall the driver.
After this, I tryed to reinstall the driver with the mhwd automatic detection, but nothing is happening more.
The result of the command inxi -G : (sorry for the screen captures but I obviously can't post this from my computer)
1593480572719-1355243019

Any help would be really appreciated, thank you in advance!

Hi there

How? What did you do?

Lets return this for what mhwd sees, and assuming its a regular prime setup check inxi using prime:

mhwd -li
prime-run inxi -G

From the graphic tool in the settings, I wanted to resolve the Minecraft gpu focus, so I changed the intel/nvidia hybrid driver to the only nvidia one, I guess it was not a good idea

1593481669819587418565

It doesnt look like you removed it through mhwd.
(it still shows as installed)
Do you mean you removed some packages through pamac?
Reinstall the intel-nvidia-prime profile through Manjaro Settings Manager or mhwd.

It's because I reinstall it.
I also removed some programs with pamac, because I wanted to clean some nvidia-utils I installed by mistake, it looks it uninstalled something which should not.

You mean the hybrid driver? I tried to reinstall it like 3 times

sudo pacman-mirrors -f && sudo pacman -Syyu
# ^ mirrors and update because why not ^
sudo pacman -Scc
# ^ clear pkg cache ^
sudo mhwd -f -i pci video-hybrid-intel-nvidia-440xx-prime
# ^ force reinstall driver profile ^
systemctl reboot
# ^ thats a restart ^
2 Likes

I did all of this, I still got the exact same result with inxi -G and mhwd -li, after reboot

Hm.
Just to double check:

glxinfo | grep "OpenGL renderer"
prime-run glxinfo | grep "OpenGL renderer"

I forgot to precise the result of glxinfo in the original post, sorry, but anyway it shows the same:

3487230067-1980471448

Well thats not good.
I wonder whats messed up.
Hm.
OK... double check you dont have anything weird forcing some config in
/etc/X11/[xorg.conf.d,mhwd.d]/
(you will probably see something for keyboard .. thats fine)

Lets try to start over.
Lets remove the prime profile.

sudo mhwd -r video-hybrid-intel-nvidia-440xx-prime

And reinstall video-linux

sudo mhwd -f -i pci video-linux

And make sure to use modesetting

sudo mhwd -i pci video-modesetting

Then reinstall the prime profile

sudo mhwd -i pci video-hybrid-intel-nvidia-440xx-prime

(reboot)

Note - we prefer text here whenever possible. It saves bandwidth, is searchable, and is easier to read.
Just copy/paste here, highlight, and use the </> code button to format it.

Note2 - if that still doesnt work we might want to look at SDDM:

cat /etc/sddm.conf && echo && ls /etc/sddm.conf.d/
2 Likes

I obviously would like to just copy and paste it here but as you know I don't have any access to the UX or to my web browser so it needs to save the text in a file and then boot on windows to post it, which takes more or less 15 minutes every time, because I don't have SSD, so well

Anyway nothing happened more after the reinstallation, so here is the result of the command:
1593489588197-1873117233

sorry some more checks:

ls /etc/X11/{xorg.conf,mhwd}.d/
systemctl status sddm.service

Sure:
15934906866881030849561

EDIT: btw the file 90-mhwd.conf is empty

Huh.

systemctl stop sddm
systemctl start sddm

I also wonder .. kernel?
Try installing one 5.4 that you dont have already .. 5.6 or 5.7:

mhwd-kernel -i linux57

..And after your edit I guess I am now wondering whats in that nvidia.conf file.
Can you check if a package owns it ?

pacman -Qo /etc/X11/mhwd.d/nvidia.conf

Also fun for use .. you can post output to certain cli pastebin services like this:

cat /etc/X11/mhwd.d/nvidia.conf | curl -F 'f:1=<-' ix.io

This says that no package contains this

http://ix.io/2qxk

Nothing more interesting after the reboot

EDIT: but something strange I guess, the manjaro version displayed is 5.4.44-1, while the update worked perfectly, at least what I saw

There we go.
Did you install the new kernel ?
Check uname -a and mhwd-kernel -li

I am pretty sure this intel-nvidia-prime requires a newish kernel.
5.7 is a good target.
If you have it installed, but you are somehow booting into the older kernel then hit Shift or Esc during boot to bring up grub and select your kernel.

1 Like

I installed the 5.7 like you told, now as you said I booted into this version from grub, but it keeps on starting with the black screen.

Entering the terminal confirms I booted on 5.7.0-3

Thank you anyway for trying to help.
In the xorg log files I found an error which says Screens not found, I'm going to try what they are talking about here:

EDIT: I've found interresting data with journalctl -g nvidia : (a great part of the result is foundable here)
15936387738051926305347

I remember being once in a similar pickle. I found a guide with a command which was able to manually remove everything nvidia related from my system.

Then I referred to the nvidia driver installation guide from the Lutris GitHub page: lutris / docs / InstallingDrivers
Make sure you follow the "Arch / Manjaro / Other Arch derivatives" section.

P.S.
I have seen your other topic regarding backups. If you prefer to use graphical interface try booting from Manjaro USB stick and use Deja Dup Backup Tool.

Good luck!
D.

1 Like

Well thank you, I have not found any guide about this, but I'm fed up, I just started the backup from Deja Dup Backup, it's true that it seems much simpler than with tty.

Have a nice day!

Forum kindly sponsored by