nvidia driver - second monitior doesent have 1920x1080

hello
I have the problem that when i use the proprietary nvidia driver my second monitor has no 1920x1080 resolution. I tried the 440 and 435 drive with kernel 5.4 and 5.5. whit the free drive there is no problem but i need the proprietary driver for gaming.

Screen 0: minimum 8 x 8, current 2944 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 298mm
   1920x1080     60.00 + 144.00*  119.98    99.93    59.94    50.00  
   1440x900     119.85  
   1280x1024     75.02  
   1280x960      99.78  
   1280x720      60.00    59.94    50.00  
   1024x768     119.99    75.03    60.00  
   800x600      119.97    99.66    75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480      119.52    99.77    75.00    59.94    59.93  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 connected 1024x768+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00*+
   1600x900      59.82  
   1400x900      59.88  
   1368x768      59.88    59.85  
   1280x800      59.91    59.81  
   1280x720      59.86    59.74  
   1024x576      59.90    59.82  
   960x540       59.82    59.63  
   864x486       59.92    59.57  
   800x600       72.19    60.32    56.25  
   800x450       59.82  
   700x450       59.88  
   684x384       59.88    59.85  
   640x480       59.94  
   640x400       59.98    59.88  
   640x360       59.86    59.83  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.82    59.63  
   432x243       59.92    59.57  
   400x300       72.19  
   320x240       60.05  
DP-3 disconnected (normal left inverted right x axis y axis)

Hello, some more information about your system is necessary e.g. inxi -Fxxxz. Otherwise it is unlikely that anyone can help you.

If nothing else helps you can also try to add undetected resolutions:
https://wiki.archlinux.org/index.php/Xrandr#Adding_undetected_resolutions

1 Like
System:    Host: michel-pc Kernel: 5.5.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.5 
           tk: Qt 5.14.1 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: ECT product: One Gamestar PC Xtreme v: N/A serial: <filter> 
           Mobo: ASUSTeK model: ROG STRIX Z370-F GAMING v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 0430 
           date: 11/01/2017 
CPU:       Topology: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 88824 
           Speed: 2332 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 2400 2: 2400 3: 2400 4: 2400 5: 2400 6: 2400 7: 2400 
           8: 2400 9: 2400 10: 2400 11: 2400 12: 2400 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: ASUSTeK driver: nvidia v: 435.21 bus ID: 01:00.0 
           chip ID: 10de:1b80 
           Display: x11 server: X.Org 1.20.7 driver: nvidia compositor: kwin_x11 resolution: 1024x768~60Hz 
           OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a2f0 
           Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f0 
           Device-3: Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series] driver: snd_hda_intel v: kernel 
           bus ID: 05:00.0 chip ID: 1102:0012 
           Device-4: C-Media Auna Mic CM900 type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-1:2 
           chip ID: 0d8c:0134 
           Sound Server: ALSA v: k5.5.2-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           chip ID: 8086:15b8 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 6.40 TiB used: 2.15 TiB (33.7%) 
           ID-1: /dev/sda vendor: Western Digital model: WDS500G2B0B-00YS70 size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 40WD scheme: GPT 
           ID-2: /dev/sdb vendor: Western Digital model: WDS500G2B0A-00SM50 size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 30WD scheme: GPT 
           ID-3: /dev/sdc vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> rev: 1B6Q 
           scheme: GPT 
           ID-4: /dev/sdd vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 0A80 scheme: GPT 
           ID-5: /dev/sde type: USB vendor: Western Digital model: WD My Passport 25E1 size: 2.73 TiB serial: <filter> 
           rev: 1015 scheme: GPT 
           ID-6: /dev/sdf type: USB vendor: SanDisk model: Ultra size: 28.64 GiB serial: <filter> rev: 1.00 scheme: GPT 
Partition: ID-1: / size: 440.30 GiB used: 110.70 GiB (25.1%) fs: ext4 dev: /dev/sdb2 
           ID-2: swap-1 size: 17.13 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3 
           ID-3: swap-2 size: 8.00 GiB used: 48.5 MiB (0.6%) fs: swap dev: /dev/sdc2 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 55 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 21% 
Info:      Processes: 301 Uptime: 6h 20m Memory: 15.57 GiB used: 8.81 GiB (56.5%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.37 

Nvidia recommends the 440.xx driver for your card, so I would recommend to switch back to that driver, but you can also keep the 435 if you want. I can not see anything which could conflict with your settings in the configuration.
You can try to set a custom resolution with nvidia-settings or with the link I gave you.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by