Nvidia drivers from mhwd not working

I've tried installing the proprietary drivers for both bumblebee and regular. A quick google of my card (Nvidia Quadro M620) tells me its optimus enabled, so when I auto-ran the install it installed bumblebee, which makes sense. But after 2 reboots, the output of "inxi -G" is:

[marco@marco-Precision-3520 ~]$ inxi -G
Graphics: Card-1: Intel Device driver: i915 v: kernel
Card-2: NVIDIA GM107GLM [Quadro M620 Mobile] driver: N/A
Display Server: N/A driver: intel tty: 97x27
Message: Advanced graphics data unavailable in console. Try -G --display

How can I make sure the driver is properly installed? does N/A mean the driver isn't installed? The hardware manager gui I used says it completed.

PS the gui says "video-hybrid-intel-nvidia-bumblebee" is installed.

To list your installed mhwd driver ...

mhwd -li

Then you are using the proprietary nvidia bumblebee mhwd driver.

When using bumblebee your intel gpu is active by default, hence the i915 driver in your inxi output. This is by design to save power, your nvidia gpu is must be activated explicitly.

Graphics: Card-1: Intel Device driver: i915 v: kernel
Card-2: NVIDIA GM107GLM [Quadro M620 Mobile] driver: N/A

You use the primusrun command to switch to your nvidia gpu ... bbswitch process does the actual switching.

Run glxgears test app on intel gpu.

glxgears

Run glxgears test app on nvidia gpu.

primusrun glxgears

To check that bumblebee service has started correctly.

systemctl status bumblebeed

To check which gpu is enabled, either

cat /proc/acpi/bbswitch

OFF = intel ; ON = nvidia

Or alternatively you can use optirun, which was superceded by primusrun, but is still useful using the status or verbose flags.

optirun --status

To run nvidia settings with bumblebee

optirun -b none nvidia-settings -c :8 

I have these aliases in my .bashrc, easier to remember ...

alias nvset='optirun -b none nvidia-settings -c :8'
alias bb='cat /proc/acpi/bbswitch'
alias bbs='optirun --status'
2 Likes

Awesome reply, thanks a lot!! You explained everything really well, and I learned a lot, thank you. It turns out my drivers were correctly installed, I ran "optirun --status" while I ran optirun glxgears and it said 2 applications where using bumblebeed.

Additionally, where previously nothing was stated, it nows says nvidia:
3D controller: NVIDIA Corporation GM107GLM [Quadro M620 Mobile] (rev a2)
Subsystem: Dell GM107GLM [Quadro M620 Mobile]
Kernel driver in use: nvidia

Thank you!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by