Nvidia Graphics card not working.

I'm new to Manjaro Gnome, and I'm unable to switch my graphic card to nVidia. The hybrid drivers are installed too, but it shows nothing on how to change from intel to nVidia in the NVidia X server settings thing.

Hi!
search on the forum about prime run

This should help:


or you go with this, but pay attention that the tutorial is made for KDE Plasma and is different than the optimus-switch mentioned above.

1 Like

To explain: The tutorial is meant to be DE agnostic, since various DMs are included, but I tested it and showed on the example of KDE. Also, users with Plasma have fewer issues compared to ones with Gnome, because GDM is inherently problematic with optimus-manager, so choosing optimus-switch may be a good idea.

2 Likes

A lot of these replies (and any other's you're likely to get) aren't very helpful and can really screw up your machine. The way you're supposed to run applications on your dedicated GPU is by adding prime-run to the beginning of your command. Try this in a terminal:

glxinfo | grep vendor

Vs:

prime-run glxinfo | grep vendor

From what I know, GNOME should have the option to run apps on the dedicated GPU by right clicking them in the overview, but this might not be enabled on Manjaro. To make it so that certain applications are run on the GPU, install the package menulibre and search for it in the menu.

Then, open the application and search for the app you want to run on the dedicated card. When you find it, add prime-run to the command entry.

As a not-so-useful example with Firefox, change:

/usr/lib/firefox/firefox %u

to

prime-run /usr/lib/firefox/firefox %u

Save and exit, then run the application. With something like Steam, you'll have to set the launch options in the game's Properties menu instead of the Steam application itself because results can change depending on how some games are launched. The options would be:

prime-run %command%

Including yours?
Or only you comment is valid and could never

?

If you want to give technical advice, do it, but please do not qualify as harmful the comments that point to options that got tested by countless users.

First it would be nice to know what hardware you have. For that run in terminal:

inxi -Fxxx0

Then show us your driver configuration:

mhwd -li

If your current and default hybrid setup is hybrid-intel-nvidia-440xx-prime, the you simply need to run any program with prime-run parameter to use Nvidia card. So for example:

prime-run steam

More info is under the links that @bogdancovaciu gave you.

1 Like

optimus-switch and optimus-manager are hard to support/troubleshoot because of the complicated way they handle things. I would say teaching someone how to use the most supported way (and the one easiest out of the box) is better. I did not call out anyone in particular.

Including yours?
Or only you comment is valid and could never....

Mine is literally just explaining the out-of-the-box solution. Unless you consider Manjaro broken out of the box, that accusation doesn't make sense. And no, I wasn't saying only mine was valid, I was saying that the others are very inconsistent (and can be kind of unnecessary) when it comes to results. Honestly, I really don't get where this is coming from.

If you want to give technical advice, do it, but please do not qualify as harmful the comments that point to options that got tested by countless users.

I've personally had issues with both of your options if you must know. If they wanted to disregard mine, that's fine, but I don't see the problem in saying that the others could be harmful if they were for me. Also, I wasn't throwing shade at anyone or something like that. I was just conveying that there is a lot of misinformation about this topic.

False assumption. I considered that the OP was not satisfied with the default and wanted more control on switching between iGPU and dGPU.

I personally had problems with many utilities, but that doesn't mean are not working for others. Both contain all the information available for anyone to test. If works fine, if not then that is that.

The problem is that YOU consider people in this forum would give advice that is potentially dangerous to laptop owners, and that is not true. OK? We are responsible people here.

What now? Did @michaldybczak and @dglt spread misinformation by writing those tutorials? Really?

Do you often contradict yourself in the next sentence, or just in this case?

Okay let's just settle down here and realize we're arguing about the merits of 20 words in a post. I do not agree with some of the advice here, and I don't see the problem with saying that. I didn't personally attack anyone or anything like that, so there isn't a point in beating this dead horse.

Nobody speaks if doesn't want to make a point. So, you not only wanted to let us and OP know that we provide dangerous advice, but more than that.

You brought it here like that.

I switched back to KDE since I was having other bluetooth audio issues as well on gnome. I have posted the info you requested below, but another thing I felt I should mention is that I tried using the optimus manager qt on KDE, but everytime I switch, to nVidia from intel in that, it will log out and when I log back in it's still on intel.
inxi -Fxxx0
System:
Host: Abn0nOS Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 10.1.0 Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 wm: kwin_x11
dm: SDDM Distro: Manjaro Linux
Machine:
Type: Laptop System: ASUSTeK product: Zephyrus M GU502GU_GU502GU v: 1.0
serial:
Mobo: ASUSTeK model: GU502GU v: 1.0 serial:
UEFI: American Megatrends v: GU502GU.309 date: 04/24/2020
Battery:
ID-1: BAT0 charge: 66.3 Wh condition: 70.5/76.0 Wh (93%)
volts: 15.8/15.8 model: ASUSTeK ASUS Battery type: Li-ion serial:
status: Charging
ID-2: hidpp_battery_0 charge: N/A condition: N/A volts: 3.7/N/A
model: Logitech G703 LIGHTSPEED Wireless Gaming Mouse w/ HERO type: N/A
serial: 4086-91-a0-be-bf status: Discharging
CPU:
Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP
arch: Kaby Lake rev: A L2 cache: 12.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 62431
Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 801 11: 800
12: 800
Graphics:
Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:3e9b
Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: ASUSTeK
driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:2191
Display: x11 server: X.Org 1.20.8 driver: modesetting
compositor: kwin_x11 resolution: 1920x1080~144Hz
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
v: 4.6 Mesa 20.0.7 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348
Sound Server: ALSA v: k5.6.16-1-MANJARO
Network:
Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi
v: kernel port: 5000 bus ID: 00:14.3 chip ID: 8086:a370
IF: wlo1 state: up mac: dc:fb:48:15:b5:49
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus ID: 05:00.0
chip ID: 10ec:8168
IF: eno2 state: down mac: 04:d4:c4:df:51:5d
Drives:
Local Storage: total: 476.94 GiB used: 63.81 GiB (13.4%)
ID-1: /dev/nvme0n1 vendor: Transcend model: TS1TMTE220S
size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: 5E318201F517933B0153
rev: 42A0S63A scheme: GPT
ID-2: /dev/nvme1n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
speed: 31.6 Gb/s lanes: 4 serial: BTNH92541499512A rev: 002C
scheme: GPT
Partition:
ID-1: / size: 468.46 GiB used: 63.78 GiB (13.6%) fs: ext4
dev: /dev/nvme0n1p2
Sensors:
System Temperatures: cpu: 63.0 C mobo: N/A gpu: nouveau temp: 39 C
Fan Speeds (RPM): cpu: 8400 gpu: nouveau fan: 0
Info:
Processes: 266 Uptime: 12m Memory: 31.22 GiB used: 1.27 GiB (4.1%)
Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17
running in: konsole inxi: 3.0.37

mhwd -li
Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

video-hybrid-intel-nvidia-440xx-prime 2019.10.25 false PCI

Also :
prime-run glxinfo|grep vendor
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 24 (X_GLXCreateNewContext)
Value in failed request: 0x0
Serial number of failed request: 39
Current serial number in output stream: 40

This worked out for me in the KDE version! Thank you!

1 Like

This indicates problems with DM, in this case SDDM. Did you make the necessary sddm config modification as showed in tutorial? Without it, this is usually what happens.

1 Like

Haha maybe, I'm unsure, I went back to KDE and then used your guide for it to get it working! Thank you so much for the help!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by