Nvidia Graphics: unable to load module Nvidia

I have just fresh installed Manjaro using manjaro architect. I laptop has NVIDIA GTX-1050 and intel integrated graphics. I tried to install non free drivers. I think im missing something because on doing sudo nvidia-settings the output is

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

I have faced this issue with previous installations as well therefore im, its something that im definitely doing wrong.

sudo systemctl status bumblebeed

   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: activating (auto-restart) (Result: exit-code) since Mon 2019-07-08 03:32:22 IST; 37s ago
  Process: 11864 ExecStart=/usr/bin/bumblebeed --use-syslog (code=exited, status=1/FAILURE)
 Main PID: 11864 (code=exited, status=1/FAILURE)

Jul 08 03:32:22 vedant systemd[1]: bumblebeed.service: Scheduled restart job, restart counter is at 25.
Jul 08 03:32:22 vedant systemd[1]: Stopped Bumblebee C Daemon.
Jul 08 03:32:22 vedant systemd[1]: Started Bumblebee C Daemon.
Jul 08 03:32:22 vedant systemd[1]: bumblebeed.service: Main process exited, code=exited, status=1/FAILURE
Jul 08 03:32:22 vedant systemd[1]: bumblebeed.service: Failed with result 'exit-code'.

sudo mhwd -li

=> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
         network-r8168            2016.04.20                true            PCI


Warning: No installed USB configs!

optirun glxspheres64

                                                                                                                           
[ 1938.180360] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 1938.180419] [ERROR]Could not connect to bumblebee daemon - is it running?


[ 1938.180360] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 1938.180419] [ERROR]Could not connect to bumblebee daemon - is it running?

I will post any other output that you may need
Please help me get my bumblebee working

EDIT:

uname -r
4.14.130-1-MANJARO

sudo systemctl enable bumblebeed.service

red that thread for the rest. nvidia-settings has to be opened a certain way for bumblebee

bumblebeed.service is already enabled

The thread suggests adding user to bumblebee group. I have already added but Im still facing the same issue

have you rebooted since then?

1 Like

yes, i have rebooted. Same result

have you considered using something else besides fumblebee?

you might want to check your other options before wasting many hours trying to get bumblebee to function. if you want to use your laptop for anything vulkan/dxvk then bumblebee wont work as it has no support for it.


i recommend prime or optimus-switch but you decide which fits you best.

Can you try to install the Nvidia driver only?

i have installed nvidia drivers as well

Are you suggesting me to get rid of bumblebee?

But where is video-linux?

Anyway, at first I'd checked if all packages are synced: sudo pacman -Syu. Then install video-linux. The reinstall video-hybrid-intel-nvidia-bumblebee. Reboot. This is a simple sequence of steps that generally should provide you with working Bumblebee solution.

Never do that on laptops with Bumblebee. The command should be /usr/bin/optirun -b none nvidia-settings -c :8.

Bumblebee needs bbswitch to load and unload nvidia module. Do lsmod | grep bb to see if it is loaded. If it is not, then Bumblebee service will fail to work properly.

if you dont care much about graphical performance, external monitors, vulkan/dxvk, or headaches then no, bumblebee will be a perfect fit. :smirk:

if you do want any/all of those then yes, go with another option from that link i posted.

Hey man, a couple of objections:

I have one, it works :slight_smile:

pvkrun %command% :slight_smile:

only when the nvidia gpu is powered on unless your hdmi port is also connected directly to the intel iGPU which most are not. so the nvidia gpu needs to on for hdmi to work.

primus_vk? it's cool someone decided to make it but it's still just "lipstick on a pig".

bumblebee makes sense for some people and sometimes it even works :sweat_smile:. sure, you can play around and sometimes get it to work as it's intended but even then it's performance will never be great.

i just dont understand the point of using it when it's often the cause of the infamous "black screen after login" when people try installing, get frustrated and leave for something like ubuntu because "manjaro would'nt work" when really it's bumblebee and bbswitch causing the headaches. this is the reason i usually tell people to install manjaro using the free nouveau drivers and change them after manjaro is installed because in most situations your able to boot the live environment without needing to edit the cmdline first, install manjaro, and boot to a desktop afterward to work from instead of needing a second device for reading instructions or having to chroot from the installer.

and all this for what? sub-par performance on a good day?

Well it depends you know. In my case I have a perfectly working bumblebee with absolutely no issues (Intel HDMI isn't that rare btw) and a headache with Arch/Manjaro Prime implementations like optimus-{manager|switch}, which is a forever blinking screen on login with no way to stop it except for force reboot. If I were a newcomer to Manjaro facing such issue I'd surely ragequitted without delay.
What you'd do with such log I wonder?

Jul 09 03:23:43 systemd-coredump[26971]: Process 26956 (Xorg) of user 0 dumped core.
                                         
                                         Stack trace of thread 26956:
                                         #0  0x00007f70321d3b3d _Unwind_IteratePhdrCallback (libgcc_s.so.1)
                                         #1  0x00007f703384b445 dl_iterate_phdr (libc.so.6)
                                         #2  0x00007f70321d4c06 _Unwind_Find_FDE (libgcc_s.so.1)
                                         #3  0x00007f70321d12b4 uw_frame_state_for (libgcc_s.so.1)
                                         #4  0x00007f70321d24c0 uw_init_context_1 (libgcc_s.so.1)
                                         #5  0x00007f70321d320c _Unwind_Backtrace (libgcc_s.so.1)
                                         #6  0x00007f703381f1c6 __backtrace (libc.so.6)
                                         #7  0x00005641bda7669d xorg_backtrace (Xorg)
                                         #8  0x00005641bda6cbe8 n/a (Xorg)
                                         #9  0x00007f703374f7e0 __restore_rt (libc.so.6)
                                         #10 0x00007f7033939fa6 _dl_fixup (ld-linux-x86-64.so.2)
                                         #11 0x00007f703394096e _dl_runtime_resolve_xsavec (ld-linux-x86-64.so.2)
                                         #12 0x00007f702eaf4d7c n/a (libglamoregl.so)
                                         #13 0x00005641bdae90df n/a (Xorg)
                                         #14 0x00005641bdabf79e n/a (Xorg)
                                         #15 0x00005641bdaff7c4 RRCrtcSet (Xorg)
                                         #16 0x00005641bdb00227 ProcRRSetCrtcConfig (Xorg)
                                         #17 0x00007f702eff7ead n/a (nvidia_drv.so)
-- Subject: Process 26956 (Xorg) dumped core
-- Defined-By: systemd
-- Support: https://archived.forum.manjaro.org/c/technical-issues-and-assistance
-- Documentation: man:core(5)
-- 
-- Process 26956 (Xorg) crashed and dumped core.
-- 
-- This usually indicates a programming error in the crashing program and
-- should be reported to its vendor as a bug.
Jul 09 03:23:45 kernel: [drm:nv_drm_fence_context_create_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to allocate fence signaling event
Jul 09 03:23:45 kernel: [drm:nv_drm_fence_context_create_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to allocate fence signaling event
Jul 09 03:23:45 kernel: BUG: scheduling while atomic: Xorg/27001/0x00000003
Jul 09 03:23:45 kernel: Preemption disabled at:

drove me nuts on my latest install months ago. this happens when xorg-xrandr is not installed which is a vital part of a prime setup. for some reason it's no longer installed by default or with nvidia drivers, i added it install instructions to be sure a little while back.

i can agree with you on that much :sweat_smile:, the names are very similar but thats about all the similarities it shares with optimus-switch, which btw i admit could have been created by a mildly intelligent 5 year old (which also describes my current coding knowledge :laughing:) but it's all thats needed.

for some bumblebee just works after installing but if you had to put a ratio of working after install and not working after install. im guessing 70:30 in favor of "not working". in a perfect world, bumblebee would be the best option, no reboot or restart of DE needed to use nvidia which for some it does now. convenience at the cost of function/performance. theres nothing wrong with bumblebee if thats a tradeoff your ok with. i merely just presented the options.

whats this from?

$ pamac search xorg-xrandr

xorg-xrandr                                          [Installed] 1.5.0-2  extra 
  Primitive command line interface to RandR extension

You see, the problem is not that simple. Xrandr is surely installed, I use it for setting extra resolutions with higher refresh rates, and no, it is not the reason of blinking.

Oh no, I wanted just to list some Prime-based options, no irony was meant.

It's from journalctl -b -1 -p3 indicating those endless Xorg crashes (screen blinking: each blink - core dump) I mentioned earlier. By posting that I wanted to say that despite being a little experienced user, I have no idea how to deal with such logs to figure out the reason of crashes. F for frustration :laughing:

@ivedantlodha sorry for hijacking your thread, I just couldn't resist.

as in today (your time)? with bumblebee and bbswitch installed? would i correctly be guessing your referring to optimus-manager?

Yep, those are installed, bumblebee service is stopped and disabled of course, and yeah, optimus-manager was meant.

when i searched those errors earlier, not much came up. the nvidia_drm error is the issue but until you posted it i had never come across it before.
@jonathon's post here from back in 2018

i only found 1 thread on it from nvidia's support/forum that was unresolved. :man_shrugging: it's not a common issue or there would be much more info on it. have you ever used a PRIME setup on that laptop? if it works with prime then it works with optimus-switch, and ideally with optimus-manager as well?

Oh this had hit me upon an idea to check modprobe.d directory and rename mhwd-nvidia.conf. I hope it was the reason, no fails for now, but it should be tested for a longer period.

1 Like

Forum kindly sponsored by