Nvidia GTX1050 Ti driver problem

I am usin Asus gl502ve which has 1050 ti as gpu. I tried several driver combinations but I can not install properly. I am currently using with Intel HD.

I have Manjaro 4.14.34-1, Xfce and light dm.

My inxi -G output

Graphics:  Card-1: Intel driver: i915 v: kernel 
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A 
           Display Server: N/A driver: modesetting unloaded: fbdev,intel,vesa resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 18.0.0 

lspci -k output (Related part)

01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)
	Subsystem: ASUSTeK Computer Inc. GP107M [GeForce GTX 1050 Ti Mobile]
	Kernel modules: nouveau
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device 1920
	Kernel driver in use: i915
	Kernel modules: i915

Also when I try to open NVIDIA X Server Settings program, it pop ups
"You do not appear to be using Nvidia X Driver. Please edit your X conf. file.(Just run nvidia-xconfig as root and reboot.)
I tried this too but this just sucks up system. It is fixed when i delete new xconf file.

If you installed with the "non-free" option then you'll have Bumblebee installed. Installing only the NVIDIA driver afterwards won't work correctly, there's other manual setup required to use the NVIDIA GPU as the default (if that's what you're wanting to do).

With Bumblebee you have to run:

optirun nvidia-settings -c :8 

like what ?
$sudo optirun nvidia-settings -c :8
gives

[  300.821254] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  300.821288] [ERROR]Aborting because fallback start is disabled.

That entire post was qualified by the "If you installed with the "non-free" driver option, then..."

Did you install with the non-free driver option? Do you have Bumblebee installed?

Install Manjaro or the driver? Which driver? What methods have you tried? What does "not properly" mean here?

Yes I tried with bumblebee. This is my general order.
->Install nvidia driver
->install bumblebee drivers.
->enable bumblebeed service
->try to activate with mhwd. which gives;
sudo mhwd -a pci nonfree 0300 -f
output:

Using config 'video-hybrid-intel-nvidia-bumblebee' for device: 0000:00:02.0 (0300:8086:591b) Display controller Intel Corporation 
> Removing video-hybrid-intel-nvidia-bumblebee...
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-hybrid-intel-nvidia-bumblebee/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
modprobe: FATAL: Module bbswitch not found.
Removed /etc/systemd/system/multi-user.target.wants/bumblebeed.service.
checking dependencies...
:: vulkan-icd-loader optionally requires vulkan-driver: packaged vulkan driver
warning: dependency cycle detected:
warning: primus will be removed after its bumblebee dependency

Packages (9) libxvmc-1.0.10-1  primus-20151110-7  bumblebee-3.2.1-18  lib32-nvidia-utils-1:390.48-1  lib32-primus-20151110-3  linux414-bbswitch-0.8-31  linux414-nvidia-1:390.48-4  nvidia-utils-1:390.48-1  xf86-video-intel-1:2.99.917+823+gd9bf46e4-1

Total Removed Size:  217.19 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
removing linux414-bbswitch...
removing linux414-nvidia...
removing lib32-primus...
removing lib32-nvidia-utils...
removing xf86-video-intel...
removing libxvmc...
removing bumblebee...
warning: /etc/bumblebee/xorg.conf.nvidia saved as /etc/bumblebee/xorg.conf.nvidia.pacsave
warning: /etc/bumblebee/bumblebee.conf saved as /etc/bumblebee/bumblebee.conf.pacsave
removing nvidia-utils...
removing primus...
:: Running post-transaction hooks...
(1/5) Updating linux414 module dependencies...
(2/5) Reloading system manager configuration...
(3/5) Reloading device manager configuration...
(4/5) Arming ConditionNeedsUpdate...
(5/5) Updating the desktop file MIME type cache...
> Successfully removed video-hybrid-intel-nvidia-bumblebee
> Installing video-hybrid-intel-nvidia-bumblebee...
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-bumblebee/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: primus will be installed before its bumblebee dependency

Packages (9) libxvmc-1.0.10-1  primus-20151110-7  bumblebee-3.2.1-18  lib32-nvidia-utils-1:390.48-1  lib32-primus-20151110-3  linux414-bbswitch-0.8-31  linux414-nvidia-1:390.48-4  nvidia-utils-1:390.48-1  xf86-video-intel-1:2.99.917+823+gd9bf46e4-1

Total Installed Size:  217.19 MiB

:: Proceed with installation? [Y/n] 
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing primus...
installing nvidia-utils...
==> If you run into trouble with CUDA not being available, run nvidia-modprobe first.
Optional dependencies for nvidia-utils
    gtk2: nvidia-settings [installed]
    xorg-server-devel: nvidia-xconfig [installed]
    opencl-nvidia: OpenCL support
installing bumblebee...
Adding user 'nrl' to user-group 'bumblebee'
Optional dependencies for bumblebee
    xf86-video-nouveau: nouveau driver
    nouveau-dri: 3D acceleration features fo nouveau [installed]
    bbswitch: switch on/off discrete card [pending]
    nvidia: NVIDIA kernel driver [pending]
    virtualgl: alternative back-end for optirun [installed]
    lib32-virtualgl: run 32bit applications with optirun [installed]
    lib32-primus: faster back-end for optirun [pending]
installing libxvmc...
installing xf86-video-intel...
>>> This driver now uses DRI3 as the default Direct Rendering
    Infrastructure. You can try falling back to DRI2 if you run
    into trouble. To do so, save a file with the following 
    content as /etc/X11/xorg.conf.d/20-intel.conf :
      Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "DRI" "2"             # DRI3 is now default 
        #Option      "AccelMethod"  "sna" # default
        #Option      "AccelMethod"  "uxa" # fallback
      EndSection
Optional dependencies for xf86-video-intel
    libxrandr: for intel-virtual-output [installed]
    libxinerama: for intel-virtual-output [installed]
    libxcursor: for intel-virtual-output [installed]
    libxtst: for intel-virtual-output [installed]
    libxss: for intel-virtual-output [installed]
installing lib32-nvidia-utils...
Optional dependencies for lib32-nvidia-utils
    lib32-opencl-nvidia
installing lib32-primus...
installing linux414-nvidia...
In order to use nvidia module, reboot the system.
installing linux414-bbswitch...
:: Running post-transaction hooks...
(1/6) Updating linux414 module dependencies...
(2/6) Reloading system manager configuration...
(3/6) Creating system user accounts...
(4/6) Reloading device manager configuration...
(5/6) Arming ConditionNeedsUpdate...
(6/6) Updating the desktop file MIME type cache...
modprobe: FATAL: Module bbswitch not found in directory /lib/modules/4.14.34-1-lts
ln: failed to create symbolic link '/etc/X11/xorg.conf.d/90-mhwd.conf': No such file or directory
xorg configuration file: '/etc/X11/mhwd.d/intel.conf'
Created symlink /etc/systemd/system/multi-user.target.wants/bumblebeed.service → /usr/lib/systemd/system/bumblebeed.service.
> Successfully installed video-hybrid-intel-nvidia-bumblebee

and still I dont have a gpu driver...

Are you in a graphical session when running these commands?

yes, I am using Intel with i915. Also I switched to kernel 4.16 to see if anything change but nothing fixed.

OK, so you do have a working driver. What makes you say that the NVIDIA driver is not working?

I can see nvidia driver output of lspci -k. also I can not configure NVIDIA via NVIDIA X Server Settings program. It says
DeepinScreenshot_select-area_20180425171921

Yes. As I said, you have to run it with

optirun nvidia-settings -c :8

and any applications with either optirun or primusrun (primusrun should be faster), e.g.:

primusrun glxgears

As I said,
output of
optirun nvidia-settings -c :8
is

[  841.510993] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  841.511061] [ERROR]Aborting because fallback start is disabled.

As a result; primusrun glxgears gives;
primus: fatal: Bumblebee daemon reported: error: Could not load GPU driver

No, you ran sudo optirun not optirun:

Same result without sudo too.

└──╼ $optirun nvidia-settings -c :8
[  982.315065] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  982.315098] [ERROR]Aborting because fallback start is disabled.

1 Like

OK, that's more interesting. :slight_smile:

This isn't a Manjaro kernel. Are you running Manjaro?

Isnt there a deterministic and ordered way of to install this annoying driver ?

Yes i am on
$uname -r
4.16.2-2-ARCH

That looks very much like an Arch kernel.

mhwd won't work with Arch.

DeepinScreenshot_select-area_20180425172745
I installed it from here. Does it matter ?

No, you didn't. There's not a 4.16.2-2 in that list, and Manjaro kernels are not suffixed by -ARCH.

Either you're running Arch or you have added Arch repositories to your system.

In any event, mhwd isn't going to work. I suggest you install (or reinstall) Manjaro, or if you want to run Arch, ask on the Arch forums.

It can be related to yaourt idk.
So can I install manjaro kernel back instead of reinstalling whole Manjaro ?

Forum kindly sponsored by