Nvidia GTX1050 Ti driver problem

As I said,
output of
optirun nvidia-settings -c :8

[  841.510993] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  841.511061] [ERROR]Aborting because fallback start is disabled.

As a result; primusrun glxgears gives;
primus: fatal: Bumblebee daemon reported: error: Could not load GPU driver

No, you ran sudo optirun not optirun:

Same result without sudo too.

└──╼ $optirun nvidia-settings -c :8
[  982.315065] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  982.315098] [ERROR]Aborting because fallback start is disabled.

1 Like

OK, that's more interesting. :slight_smile:

This isn't a Manjaro kernel. Are you running Manjaro?

Isnt there a deterministic and ordered way of to install this annoying driver ?

Yes i am on
$uname -r

That looks very much like an Arch kernel.

mhwd won't work with Arch.

I installed it from here. Does it matter ?

No, you didn't. There's not a 4.16.2-2 in that list, and Manjaro kernels are not suffixed by -ARCH.

Either you're running Arch or you have added Arch repositories to your system.

In any event, mhwd isn't going to work. I suggest you install (or reinstall) Manjaro, or if you want to run Arch, ask on the Arch forums.

It can be related to yaourt idk.
So can I install manjaro kernel back instead of reinstalling whole Manjaro ?

If you are running Manjaro, then yes, remove the Arch kernels (both of them), check your /etc/pacman.conf for Arch repository entries and remove them, then reinstall the Manjaro kernels, e.g.

sudo pacman -Rncs linux linux-lts
sudo mhwd-kernel -i linux414 linux416

if you never installed kernels manually with yaourt or installed an AUR package that were asking a specific kernel only available on AUR, it's not possible and @jonathon suggestion about ARCH repository is more probable. or a 3rd party repository

I think this is irreversible :slight_smile:
sudo mhwd-kernel -i linux414

I... don't know what's happened there... :expressionless:

You might be able to recover it from within a chroot.

In GRUB menu go into Advanced options and select a specific NOT-ARCH kernel to boot into, alternatively use 4.14-fallback option.

I am able to run nvidia at the end of the day.
I am writing step by step everything if anyone else looking for same problem.
1- I formatted again (with rufus etc..)
2-I have booted manjaro, login screen show up kinda late.
3-Then when I lock screen, I couldnt unlock, had to reboot again.
4-So I auto install propriatery drivers from Settings-> Manjaro Settings Manager-> Hardware Config.
5-Then I added my username to bumblebee group.( sudo gpasswd -a YourUsername bumblebee)
6-Then I enable bumblebee service via sudo systemctl enable bumblebeed
7-Then I reboot again.
8- Finally, I run the command optirun nvidia-settings -c :8

9- As a last step, I add nv black to default grub,
sudo vi /etc/default/grub

GRUB_CMDLINE_LINUX="nouveau.modeset=0 nv.modeset=0 modprobe.blacklist=nouveaufb"

sudo update-grub


There is only a single problem remaining
System does not boot if i open up windows first then restart to boot into manjaro
I have to shutdown and start again to boot into it.
last logs of journalctl


1 Like

thanks a lot !

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by