nvidia-intel GPU, OpenGL issue

Hello, I am new here so I apologize if the category is incorrect or my thread have issues.
I have already searched the forums and tried some recommendations but with no solution.

My problem is about nvidia and intel hybrid drivers and OpenGL, or something like that.

When I first installed Manjaro I had no issues regarding GPU. However, I believe that some update messed things up and I now have problems with OpenGL.

For example:

I cannot use firefox application that use OpenGL like google earth.

The site get.webgl.org gives the following message:

Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.

I work with MATLAB and had no issues until recently, and now it reads the message:

MATLAB is selecting SOFTWARE OPENGL rendering.

Warning: MATLAB has disabled some advanced graphics rendering features by switching to software OpenGL.

I have video-hybrid-intel-nvidia-440xx-prime driver installed.
In display and monitor > compositor > rendering backend, I choose OpenGL 3.1
I tried to install optimus-manager and switch to nvidia but had no effect whatsoever

[max@max-pc ~]$ inxi -G
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
  Device-2: NVIDIA GM108M [GeForce MX130] driver: nvidia v: 440.82 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.4
 [max@max-pc ~]$ glxinfo | grep OpenGL
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) UHD Graphics 620 (KBL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.0.4
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.0.4
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.0.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
1 Like

What does prime-run glxinfo | grep OpenGL do?

If that gives you nVidia, you should run the applications you want to have access to the nVidia with prime-run :


  • sudo nano --backup /usr/share/applications/firefox.desktop
  • change
    • Exec=/usr/lib/firefox/firefox %u
    • Exec=prime-run /usr/lib/firefox/firefox %u

Do this with all applications you want to run on the nVidia.


Read this and follow from step 7.


Get rid of the hybrid driver and run on nVidia all of the time (and the way I run):

  • Save all your work

  • log off

  • switch to TTY2

  • Execute:

     sudo mhwd --remove pci video-hybrid-intel-nvidia-440xx-prime
     sudo mhwd --install video-nvidia-440xx
     sudo reboot


1 Like

Thank you so much for your answer.

Finally, with this post I could solve my issue.

I'd rather stay with hybrid than just nvidia because of the power consumption.

1 Like

Don't forget to :heart: the post that helped you so it's easier for other people to find!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by