Nvidia M150 Issues On Xiaomi Mi Notebook Pro

Yeah I've tried uninstalling the bumblebee and installing the nvidia only through the hardware manager but that always resulted in the desktop not booting and everything freezing up

[ 557.795837] [ERROR]You've no permission to communicate with the Bumblebee daemon. Try adding yourself to the 'bumblebee' group
[ 557.795944] [ERROR]Could not connect to bumblebee daemon - is it running?
I got this error when running

add your user to bumblebee group:
sudo systemctl enable bumblebeed
sudo gpasswd -a $USER bumblebee

then try again

2 Likes

plus start the service? (and these should be done by mhwd? might indicate some mixups along the way)

Tried it then the previous command and got the Nvidia Settings Panel open :smile:bumblebee

it's working, just know that when you want to run something and have it use the nvidia gpu, you need to put optirun or primusrun before the command
optirun glxgears

here is something you should probably bookmark

Thanks a lot :smile:. Would there be a way to have the Nvidia graphics as a permanent option. I don't mind the battery hit. Thanks again!

Still not sure which version you have/need exactly .. but I might reinstall to be sure:

sudo mhwd -f -i pci video-hybrid-intel-nvidia-bumblebee

[or video-hybrid-intel-nvidia-390xx-bumblebee , depending]

!! - Also - remember that if you want to save settings from that nvidia-config-manager you should save it to /etc/X11/mhwd.d/nvidia.conf

This is explicitly the opposite of bumblebee. What you describe is provided by PRIME.

if only someone had previously mentioned alternatives. hmmmm... :thinking:

i would suggest PRIME or optimus-switch. both of which are the same but optimus-switch lets you use PRIME when you want and switch to intel-only when you want and extend battery life significantly. i am biased since i made optimus-switch recently and it's been working perfectly for me and others using it. it also sets up prime for you even if you intend to stay in prime mode most of the time. up to you.

1 Like

I did mention that I would rather have the Nvidia driver only in use

I can work with bumblebee and I'm currently reading the thread cscs sent

1 Like

Oh, I should have mentioned too ... if you are super lucky you might even have an option in BIOS to turn off intel and only use nvidia. If its there that the easiest way.

2 Likes

Thanks! I'll give optimus-switch a shot :smile:

I'm not fortunate to have that option but thanks for the tip :smiley:

optimus-switch-sddm is the one you need.

and be sure to backup, move, or get rid of any gpu related .conf files left over after removing bumblebee and/or video linux. make sure bbswitch gets uninstalled.

grep -v /etc/X11/xorg.conf.d/*.conf
grep -v /etc/X11/mhwd.d/*.conf
grep -v  /etc/modprobe.d/*.conf
grep -v  /etc/modules-load.d/*.conf

just remove mhwd/gpu/video related .conf files. if you have any questions i should be around for a while. :+1:

1 Like

@dglt thanks so much! Just doing a fresh install on my main disk to give it an install (^_^)

1 Like

just follow the directions and you should be good. let me know if any instructions are not clear so i can edit them.

I followed the instructions fully and they are simple and easy to follow, I just have my system continue to show the logo on boot. This happened any other time I removed the bumblebee driver and installed Nvidia only. Ctrl +Alt +F1 allows me to access the terminal and to switch to Intel but nvidia won't get to the desktop

Screenshot_20190311-212439_Gallery_1

ok so intel mode is working fine, but nvidia mode does not fully load, yes?
please post the following:

mhwd -li
ls -R /etc/X11/
ls -la /etc/modprobe.d/
ls -la /etc/modules-load.d/

please post the actual terminal output instead of pictures. to copy from a terminal it's
Ctrl+Shift+C and then paste it here in proper format using the </> button for example:

 Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI

/etc/X11/:
mhwd.d  xinit  xorg.conf.d

/etc/X11/mhwd.d:

/etc/X11/xinit:
xinitrc  xinitrc.d  xserverrc

/etc/X11/xinit/xinitrc.d:
40-libcanberra-gtk-module.sh  50-systemd-user.sh

/etc/X11/xorg.conf.d:
99-intel.conf

total 16
drwxr-xr-x  2 root root 4096 Mar 11 21:40 .
drwxr-xr-x 88 root root 4096 Mar 11 21:41 ..
-rw-r--r--  1 root root  558 Mar 11 21:40 99-intel.conf

total 12
drwxr-xr-x  2 root root 4096 Mar 11 21:40 .
drwxr-xr-x 88 root root 4096 Mar 11 21:41 ..

Forum kindly sponsored by