Nvidia Optimus

Hello. I am a new user of Manjaro Linux and I ran into a problem today. I am running a notebook with Nvidia Optimus system which is like a magnet for problems. It never works right. Even on Windows. My problem is that I tried to install the hybrid Bumblebee driver but it does not work at all. I have been searching many forums but nothing worked.

When I run nvidia-settings in bash it says:

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

And when I run lspci -v it says:

01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940MX] (rev ff) (prog-if ff)
!!! Unknown header type 7f
Kernel modules: nouveau, nvidia_drm, nvidia

I think it has something to do with the open source nouveau driver. Should I blacklist it? I have added a new conf file to modprobe.d folder with blacklist command so I think it should be blacklisted or is there anything more to do?

My specs:
Device: Acer Aspire A525-51G-51MN
CPU: Intel Core i5-7200U
GPU: Nvidia GeForce 940MX
OS: Manjaro Deepin ver. 18.0.4
Kernel: linux419

I tried to reinstall whole OS and select non-free drivers during instalation but it is still the same.

Looks like you didn't do your homework :wink: . On bumblebee you cannot access nvidia-settings directly, this won't work. You need to use:

optirun -b none nvidia-settings -c :8

Secondly, to check if Bumblebee is working:

$ optirun glxgears -info


$ optirun glxspheres32


This "!!! Unknown header type 7f" looks worrisome thou.


Oh my. I have completely missed this Arch page! Thanks for mentioning it! Also "optirun -b none nvidia-settings -c" gives this output:

ERROR: Unable to find display on any available system

Which sounds really weird to me.

And "optirun glxgears -info" runs, but gives this error:

XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 35 requests (35 known processed) with 0 events remaining.

Thank you again for your reply, kind sir :slightly_smiling_face:

Oh I am such an idiot glxgears -info runs just fine. Ignor that error xD

Fairly! There 's a typo in the command. (courtesy of Discourse!)

optirun -b none nvidia-settings -c :8

If you still have problems, please explain.

1 Like

Ah, sorry, didn't notice that Discourse replaced the signs automatically. Modified my post to contain the correct command.

1 Like

It worked! It opened the settings. But it also gave me this warning:

(nvidia-settings:26885): GLib-GObject-CRITICAL **: 20:28:32.399: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
GPU at BusId 0x1 doesn't have a supported video decoder

I've downloaded CS 1.6 to test it on. With "primusrun %command%" the game simply won't start.

But in Nvidia settings panel everything seems alright. It even shows the GPU temperature which for some reason doesn't work on my Windows 10. Only thing that seems odd there is the Display configuration which auto detects my display on 640x480 resolution.

I will try to reinstall it according to this topic:

Also, you must remember, that Bumblebee don't support Vulkan which is prevalent in Steam Play, so some games like Witcher 3 will return error (not supported Graphical Card), others may silently just won't work.
Try launching the CS on OpenGL (there are some parameters that you can add to a game launcher) or simpy install nvidia-xrun:

Of course, you can also manually set PRIME as recommended above or try optimus-manager (which I currently use), but before you do any of it, do system backup with timeshift so you could roll back in case something goes wrong. Messing with GPU drivers is always risky and certain solutions may not work for all hardware setups.

You may also simply try to run Steam in Bumblebee mode:

primusrun steam

Some won't recommend it and say that running each game with that command is better but in my experience it's usually the least hassle free usage. So if Bumblebee works and the game is not using Vulkan, it will run.
I also recommend installing steam-native package which often resolves potential Bumblebee issues as it adds OS native libraries and makes Steam use them (so they are newer than those bundles in with Steam).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by