Nvidia prime no longer works after installing opencl

  • Fresh install
  • GTX 1650 Max-Q
  • video-hybrid-intel-nvidia-440xx-prime

Checked the graphics driver with prime-run glxgears before installing opencl driver, worked perfectly. Then I tried running the same command after installing opencl-nvidia-440xx from the official repo and glxgears throws this:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  25
  Current serial number in output stream:  26

Xorg log also throws this:

[     5.889] (II) NVIDIA GLX Module  440.82  Wed Apr  1 19:47:36 UTC 2020
[     5.891] (II) NVIDIA: The X server supports PRIME Render Offload.
[     7.330] (EE) NVIDIA(GPU-0): The NVIDIA GPU at PCI:1:0:0 is not supported by the 440.82
[     7.330] (EE) NVIDIA(GPU-0):     NVIDIA driver.
[     7.330] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[     7.330] (EE) NVIDIA(G0): Failing initialization of X screen

I would install the regular nvidia driver but since this is a laptop I can't sacrifice my battery life - please help!

Try to force the reinstall of the drivers:
sudo mhwd -f -i pci video-hybrid-intel-nvidia-440xx-prime
Make sure you check this too

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by