nvidia ryzen5 hybrid gpu blackscreen with cursor

I have tried like this Hybrid AMD/NVIDIA set up
But it not working for me
Please some help me to solve this problem

1 Like

I'm on Ryzen 7 hybrid GPU,
using kernel 5.4 at the moment, everything seems ok
tried 5.3 also, but 5.4 is mostly stable

When I switch back to kernel 4.19 ... black screen

What is your current kernel

image

My kernel is linux5.2 and I have tried linux5.3 it still not working

1 Like

Ok, here's my experience,
try fresh install, from latest manjaro download, I use GNOME btw,
everything is smooth...

What went wrong, cracle sound -> this has been solve by reinstalling pulseaudio
Everything seems working, the only thing that dont work is master volume slider (no effect, but I can still adjust it by it's own app so that's fine)

From googling, kernel 5.4 temporarily solving overheating issue, so from manjaro setting, I install latest kernel and use it

I just download xfce yesterday and now i upgrade to linux5.4 but still not working

Very strange,
Perhaps others could jump in and help

Btw, I disable secureboot on bios,
My laptop is Zenbook UM431DA Ryzen 7 3700U Vega 10,

I create bootable usb using etcher
Ubuntu, Pop-os, Peppermint, other ubuntu based, quite buggy
Last, Manjaro 18 is the most stable

https://pastebin.com/LPnw5DHR
This is my computer info

Have u tried POP OS, the one with preinstalled NVIDIA driver?
(I know, I should not mention other distro here.. forgive me admin!)

My other laptop is vivobook and have similar type, quite struggle to install linux..
(probably since ubuntu bionic, coz no driver is supported by the vendor)

Hope u can find the answer pretty soon...

Thank you edp78 I will find the solution for my laptop

these laptops can be setup in the same way an intel/nvidia optimus setup works. the newer render offload method works but you wont be able to use external monitors or ever power down the nvidia gpu. that thread you linked is to setup render offloading.

if you want something with better performance and more control, i can help you setup optimus-switch which by default is meant to work with an intel/nvidia setup but with a couple simple edits also works fine for ryzen/nvidia.

if you want to do this, post these outputs and please use the </> button above the post entry box when pasting terminal output so it's formatted properly

inxi -Fxxxza
mhwd -li
xrandr --listproviders
ls -laR /etc/X11

are you able to get yourself to a graphical desktop at all? or only when you try to use the proprietary drivers?

inxi -Fxxxza

System:    Host: werterzz-pc Kernel: 5.3.8-3-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 root=UUID=e4fd87c9-49cc-4ebf-b24a-3c17fd07e953 rw quiet apparmor=1 
           security=apparmor resume=UUID=1a94e4f8-1466-42ef-b35c-49aa1b21c2a3 udev.log_priority=3 
           Console: N/A dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X570ZD_A570ZD v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X570ZD v: 1.0 serial: <filter> UEFI: American Megatrends v: X570ZD.304 date: 08/29/2018 
Battery:   ID-1: BAT0 charge: 42.6 Wh condition: 42.6/48.1 Wh (89%) volts: 11.7/11.7 model: ASUSTeK ASUS Battery type: Li-ion 
           serial: <filter> status: Discharging cycles: 236 
CPU:       Topology: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen 
           family: 17 (23) model-id: 11 (17) stepping: N/A microcode: 810100B L1 cache: 384 KiB L2 cache: 2048 KiB 
           L3 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31949 
           Speed: 1367 MHz min/max: 1600/2000 MHz boost: enabled Core speeds (MHz): 1: 1368 2: 1369 3: 1368 4: 1367 5: 1368 
           6: 1367 7: 1488 8: 1596 
           Vulnerabilities: Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
Graphics:  Device-1: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK driver: nvidia v: 418.88 bus ID: 01:00.0 
           chip ID: 10de:1c8d 
           Device-2: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] vendor: ASUSTeK driver: amdgpu v: kernel 
           bus ID: 04:00.0 chip ID: 1002:15dd 
           Display: server: X.org 1.20.5 driver: nvidia tty: 240x67 
           Message: Advanced graphics data unavailable in console for root. 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel 
           bus ID: 04:00.1 chip ID: 1002:15de 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 04:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.3.8-3-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: AzureWave driver: ath10k_pci v: kernel 
           port: f000 bus ID: 02:00.0 chip ID: 168c:0042 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: e000 
           bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 6.68 GiB (0.7%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0J scheme: GPT 
Partition: ID-1: / raw size: 441.09 GiB size: 433.17 GiB (98.20%) used: 6.67 GiB (1.5%) fs: ext4 block size: 4096 B 
           dev: /dev/sda3 
           ID-2: swap-1 size: 14.65 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 42.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: temp: N/A device: amdgpu temp: 42 C 
Info:      Processes: 207 Uptime: 2m Memory: 6.80 GiB used: 346.0 MiB (5.0%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash (sudo) v: 5.0.11 inxi: 3.0.36 

mhwd -li

e[1me[31m> e[mInstalled PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
    video-nvidia-418xx            2019.10.25               false            PCI


e[1me[31mWarning: e[mNo installed USB configs!

xrandr --listproviders

can't open display

ls -laR /etc/X11

/etc/X11:
total 32
drwxr-xr-x  5 root root 4096 ต.ค.  28 18:51 .
drwxr-xr-x 93 root root 4096 พ.ย.  14 08:56 ..
drwxr-xr-x  2 root root 4096 พ.ย.  13 23:29 mhwd.d
drwxr-xr-x  3 root root 4096 ต.ค.  28 18:51 xinit
drwxr-xr-x  2 root root 4096 พ.ย.  13 23:29 xorg.conf.d

/etc/X11/mhwd.d:
total 16
drwxr-xr-x 2 root root 4096 พ.ย.  13 23:29 .
drwxr-xr-x 5 root root 4096 ต.ค.  28 18:51 ..
-rw-r--r-- 1 root root 1522 พ.ย.  13 23:29 nvidia.conf
-rw-r--r-- 1 root root    0 พ.ย.  13 23:29 nvidia.conf.nvidia-xconfig-original

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 ต.ค.  28 18:51 .
drwxr-xr-x 5 root root 4096 ต.ค.  28 18:51 ..
-rw-r--r-- 1 root root  739 มี.ค.   5  2019 xinitrc
drwxr-xr-x 2 root root 4096 ต.ค.  28 18:50 xinitrc.d
-rw-r--r-- 1 root root   45 มี.ค.   5  2019 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 ต.ค.  28 18:50 .
drwxr-xr-x 3 root root 4096 ต.ค.  28 18:51 ..
-rwxr-xr-x 1 root root  318 พ.ย.  10  2018 40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203 ต.ค.  21 16:27 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 16
drwxr-xr-x 2 root root 4096 พ.ย.  13 23:29 .
drwxr-xr-x 5 root root 4096 ต.ค.  28 18:51 ..
-rw-r--r-- 1 root root  266 พ.ย.  13 23:27 00-keyboard.conf
lrwxrwxrwx 1 root root   27 พ.ย.  13 23:29 90-mhwd.conf -> /etc/X11/mhwd.d/nvidia.conf

I just reinstall manjaro with non free driver and I can't get to GUI

1 Like

Same here...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by