nvidia-settings error: NVIDIA driver is not loaded gtx 1050m do not change drivers like that ....

I have a dell xps 15 9560 with a gtx 1050m I would like to be able to turn on and off in order to get better performance / save battery. I come from ubuntu, where once I installed it openning "Nvidia x server settings" had an option to do this. In manjaro I try to open the nvidia settings with 'nvidia-settings' and I get:

ERROR: NVIDIA Driver is not loaded

ERROR: Unable to load info from any available system

I tried to install nvidia drivers with sudo pacman -Sy nvidia and installing nvidia-beta from the AUR, but nothing did it for me.

I also followed Arch's dell xps 9560 guide ( https://wiki.archlinux.org/index.php/Dell_XPS_15_9560 ), as well as Nvidia's ( https://wiki.archlinux.org/index.php/NVIDIA ). There are some xps 9570 (with gtx 1050ti) guides on the internet which didn't work for me.

I really don't know what to do now. Any help is greatly appreciated.

Thanks!

videos drivers under manjao are from

sudo mhwd -li
sudo mhwd -l

@dglt can you see for this ?

As you have a fairly recent card, nVidia's latest and greatest driver for Linux (the 440 series) is compatible with your card.

To make things easier, Manjaro comes with its own utility for installing third-party drivers: Manjaro HardWare Detection or mhwd.

To list the possible drivers that can be installed, do:

mhwd --list

To get a list of already installed drivers do a:

mhwd --listinstalled

If the first list contains something like video-nvidia-440xx and the second list is empty, you can just go ahead and do a:

sudo mhwd --install pci video-nvidia-440xx

If not, please provide the following info:

inxi --full

:innocent:

1 Like

I recommend you my guide, especially point 9 where I show how to install drivers that work for optimus-manager. I assume that this is a hybrid GPU laptop. Of course, you can install drivers in terminal as shown by others. First, uninstall current setup (if there is some configuration loaded) then install new one and follow the setup for optimus-manager (hybrid GPU).

2 Likes

Thanks for answering! I completed the guide, installed 'video-hybrid-intel-nvidia-440xx-prime' and I'm using optimus-manager-qt but I can't switch between the GPUS, Intel is always selected. Any idea why could this be? Thanks.

Tried installing that driver but nothing... I ended up going with the guide that the other comment suggested, but no luck either. Here's what my inxi --full shows

scrinchot

The optimus-manager gpu_setup.log says:

Cannot setup GPU : kernel setupe error : error running modprobe for nvidia : Failed to execute 'modprobe nvidia NVreg_UsePageAttributeTable=1" : modprobe: ERROR: could not insert 'nvidia': Exec format error

I see that you got optimus-manager sort of working. Unfortunately I can't trouble shoot that process as my set up can't use optimus-manager. If you want to switch back to video-nvidia-440xx. Try these out see what happens. What does nvidia-smi produce when you run it.

I had this issue but only after I manually patch the kernel. I had a bootable system but the system said the driver was not loaded. To fix this issue I had to manually rebuild the kernel module to get the system to see that the nvidia driver was indeed installed. This will be strictly for the video-nvidia-440xx that is downloaded using mhwd.

gti clone https://gitlab.manjaro.org/packages/extra/linux54-extramodules/nvidia-440xx.git
cd nvidia-440xx
makepkg -si

After you run this you need to reinstall the linux54 headers and then reboot the system. If this does fix the problem I suggest that you look at optimus switch for using each card separately.

2 Likes

nvidia-smi produces:

NVIDIA-SMI has failed because it oculdn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I am afraid I don't know how to reinstall the linux54 headers. How would I go about that?

sudo pacman -S linux54-headers

Question I was reading through your post again. If you have the video-hybrid-intel-nvidia-44xx-prime installed you do not need optimus manager installed at this point. It should automatically configure the system to use prime render offloading. What that does is it keeps both cards on, and runs the system throught the intel gpu. Only when you specify to run a program via nvidia will the nvidia card work with that driver installed. If this is what you want then you simply uninstall optimus-manager and reinstall the video hybrid driver using mhwd.

If that is not the set up you are looking for and are ok with having to reboot your system to switch cards then optimus switch that I linked early would be a good choice. If that is what you would like to do you would need to remove optimus-manager and the video-hybrid-intel-nvidia-440xx-prime. Do not reboot the system after removing the graphics driver. Then follow this guide to install the optimus switch.

After you have it installed the rebuild the nvidia module with the commands i posted early. Then reboot your system.

1 Like
  1. Please don't post screenshots of text, but post the text itself so we can copy-paste from it :innocent:
  2. use the "preformatted text" button to format said text like this:
    Screenshot_20200121_133123
  3. "It didn't work" doesn't help me help you, so post the output of the commands I previously posted if you want me to help you any further, including the inxi in text format.

Thank you for helping us help you...

:wink: :innocent:

1 Like

sudo pacman -S linux54-headers gives an error, saying:

unable to install module acpi_call/1.1.0 for kernel 5.4.6-2-MANJARO: Missing kernel modules tree.

uname -a says:

Linux 5.4.13-3-MANJARO #1 SMP PREEMPT

Why are those kernel versions different? Should I care about it?

Here you go! (:

inxi --full

System:    Host: jbrbc-pc Kernel: 5.4.13-3-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.17.4 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 15 9560 v: N/A serial: <root required> 
           Mobo: Dell model: 0JHP5H v: A00 serial: <root required> UEFI: Dell v: 1.16.0 date: 07/26/2019 
Battery:   ID-1: BAT0 charge: 35.5 Wh condition: 87.4/97.0 Wh (90%) 
CPU:       Topology: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 1100 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1100 2: 1100 3: 1100 4: 1096 
Graphics:  Device-1: Intel HD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A 
           Display: x11 server: X.Org 1.20.6 driver: modesetting unloaded: intel tty: N/A 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.6 Mesa 19.3.1 
Audio:     Device-1: Intel CM238 HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.13-3-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci 
           IF: wlp2s0 state: up mac: 9c:b6:d0:f7:79:87 
           Device-2: Qualcomm Atheros type: USB driver: btusb 
Drives:    Local Storage: total: 238.47 GiB used: 61.52 GiB (25.8%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50ZNV256G NVMe 256GB size: 238.47 GiB 
Partition: ID-1: / size: 224.78 GiB used: 61.52 GiB (27.4%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2487 fan-2: 2506 
Info:      Processes: 164 Uptime: 6m Memory: 7.63 GiB used: 670.9 MiB (8.6%) Shell: bash inxi: 3.0.37 

mhwd --list

> 0000:01:00.0 (0302:10de:1c8d) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI
video-hybrid-intel-nvidia-435xx-prime            2019.10.25               false            PCI
video-hybrid-intel-nvidia-430xx-bumblebee            2019.10.25               false            PCI
video-hybrid-intel-nvidia-418xx-bumblebee            2019.10.25               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2019.10.25               false            PCI
    video-nvidia-440xx            2019.10.25               false            PCI
    video-nvidia-435xx            2019.10.25               false            PCI
    video-nvidia-430xx            2019.10.25               false            PCI
    video-nvidia-418xx            2019.10.25               false            PCI
    video-nvidia-390xx            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI


> 0000:00:02.0 (0300:8086:591b) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI
video-hybrid-intel-nvidia-435xx-prime            2019.10.25               false            PCI
video-hybrid-intel-nvidia-430xx-bumblebee            2019.10.25               false            PCI
video-hybrid-intel-nvidia-418xx-bumblebee            2019.10.25               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


mhwd --list installed

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-440xx            2019.10.25               false            PCI


Warning: No installed USB configs!

Run sudo pacman -Syy then update the headers.

If that doesn’t work you should be able to use the GUI package manager to install them as well. You can also go the actual repository and download them from the stable branch. Use the GUI package manager to install the package you downloaded.

1 Like

OK, so you've got dual graphics (good!) and the nVidia driver is installed (also good) however you seem to be running an older kernel so if the GUI for the package manager doesn't work do a:

pamac upgrade

Please post logs if that fails! :wink:

Now, to disable the nVidia and maximise your battery, I just go to the BIOS, disable the nVidia and have about 50% more juice if I do that. Good enough for surfing the web and reading mail on-the-go, not so good for watching (HD) movies and playing games on the road...

1 Like

I can't find a way to disable the nvidia card form the BIOS... But I can't use optimus-manager either, it seems it is not working. What logs do you want me to show you? :slight_smile:

I have an error trying to do this:

gti clone https://gitlab.manjaro.org/packages/extra/linux54-extramodules/nvidia-440xx.git
cd nvidia-440xx
makepkg -si

That says:

===> Starting build()...
make[1]: Entering directory '/usr/lib/modules/5.4.13-3-MANJARO/build'
make[1]: *** No rule to make target 'modules'. Stop.
make[1]: Leaving directory '/usr/lib/modules/5.4.13-3-MANJARO/build'
make: *** [Makefile:81: modules] Error 2
===> ERROR: A failure occured in build().
           Aborting....

You need someone else to help you with that as I don't have any experience with that...

:sob:

1 Like

You system is fully up to date.

sudo pacman -Syu

I wonder if @dglt would have any suggestions.

1 Like

you must still have 5.4.6-2 kernel tree so it's trying to build a module for a kernel you no longer have.

post:

mhwd-kernel -li
pacman -Qs linux headers
ls -la /usr/lib/modules/

this can put you in partial update territory, headers version needs to match kernel version exactly.

@juanote before anything else, sync mirrors and update

sudo pacman-mirrors -f5
sudo pacman -Syyu
3 Likes

Forum kindly sponsored by