Octopi isn't properly exiting the update process

Since the latest patch (I think?) I've got the problem that Octopi isn't properly exiting the update process.

The update itself is running fine, but after the latest step "Press any key to continue..." it's not closing and when I want to close the terminal, the message is:

When I press "yes" the next window that opens up requires my sudo password for some reason:
It doesn't matter if I type it in or press "abort", the window just closes.

Some more system information:

1 Like

Use Ksysguard to kill the messed up Octopi process and do this update again in terminal with pacman instead this time around.

sudo pacman -Syu

I already updated everything. It's not that the updates are not going through, but Octopi just closes weirdly. It also doesn't matter which software I'm updating. Octopi is just kinda broken.

1 Like

Doesn't help that Manjaro is running a dev build of Octopi.

1 Like

In stable I have reverted to a known working git-commit. For testing we see if the latest commit fixes it. Feedback appreciated.

With Octopi backend set to pacman the /var/lib/pacman/db.lck file is not being created either.

I am able to commence an update / install / remove simultaneously using both Octopi and pacman ... a recipe for disaster for obvious reasons.

Is this an unwanted byproduct of the newish /usr/lib/octopi/octopi-sudo mechanism?

This has only started happening recently, the testing octopi didn't fix it.

My Arch system with Octopi AUR ( 0.9.0-1) install doesn't do this.


Looks like its been addressed upstream.

Octopi notifier is the culprit not locking the pacman database.

Please check if octopi 0.9.0-12 includes this needed fix.

It is good. I watched /var/lib/pacman in Dolphin whilst i installed some packages with this O version. It correctly created the lock file once i entered my password, correctly did the package installations without any error messages, correctly removed the lock file at the end, & correctly let me then close O without hassles. That's all a bit of a relief - until now, O has been behaving a bit freakily for me.

EDIT: Oh rats. Not all is good with it after all. Another recent problem is continuing. When the O timer for checking for updates initiates that check, it never completes the process. The O icon remains dimmed, & hovering it reveals that it is still checking... even long after Pamac has already detected the available update/s, & notified me.

Idk, I don't see a difference at all to be honest. Same behavior.

I also don't understand why the upgrade process is being started in an own terminal (with a different background color etc.) and not the standard terminal like before this problem occurred.

I'm seeing the exact same phenomenon.
Is this a new feature of Octopi to display all output in its own terminal (it doesn't allow copying btw)?

It looks like broken, even SU tool in options is greyed and check updates button doesn't work.

In 0.9.0-13 the problem is still here, but now "Ctrl+C" in terminal removes the symptom, you can continue to work or close octopi properly.

also, if you start a transaction in the terminal (not AUR), it displays a message:

octopi-helper[aborted]: Suspicious transaction detected 

This problem continues for me. It [= the Notifier] has not been working correctly for at least several weeks, although i suspect it's probably run over into months now. Identical symptoms per my older post.

Today i tried again to fix it [unsuccessful]. I uninstalled Octopi & the Notifier [octopi-notifier-qt5], then renamed my /home/kdemeoz/.config/octopi directory. Then i installed octopi [0.9.0-13], octopi-notifier-frameworks [0.9.0-13]. Over past weeks/months i have alternated between that notifier & octopi-notifier-qt5, but both misbehave as described. I didn't notice anything applicable in https://github.com/aarnt/octopi/issues.

Currently we don't recommend octopi at all. For 18.1 we switch to pamac also on our KDE edition.

Oh? I see, thanks.

I had been following the discussions about Pamac, & Pamac-Qt, but i had not actually realised that we've now given up altogether on Octopi. I suppose i need to remove it now... but i must say, i still do like using its standalone Cache Cleaner GUI.

1 Like

Alrighty I switched to Pamac. If that's the ultimate solution (?).

I have the very same problem as Ares. I have Octopi 0.9.0-14 and it is still not fixed. The terminal does not terminate after the install. I also have to shut it down in the way Ares has to do.

You can use Ctrl + C to close it like @Otter posted. Or switch to pamac of course.

I'm keeping, the last good one for me, pamac-qt is not working well in my sistem, and I still prefer octopi while using mainly pacman

It's a pity Octopi is out of favour now I guess.

Since I started using Manjaro KDE just over a year ago I instantly felt at home with Octopi as it reminds me very much of the Muon Package Manager in Kubuntu (with some differences in operation). Muon is what I'm mostly familiar with as I have been using Kubuntu since 2011.

I have been trialling Pamac-Qt and it is improving, the only glitches I've noticed are minor interface anomalies (inability to adjust column widths and can't resize certain dialog boxes).

Forum kindly sponsored by