Old desktop (6 years) and nvidia GeForce GT 730

Hi everyone!

I've spent yesterday evening trying to get my PCI GeForce GT 730 to work with the propietary drivers with no luck so far.

I first tried to install the nvidia drivers through the manjaro-settings-manager, and the nvidia card hdmi output stoped working. Then I switched to the integrated hdmi output and tried removing every driver with mhwd (I had both video-linux and video-nvidia) and installing only video-nvidia, with no luck. I cannot disable the intel integrated video on the BIOS, but I could choose the nvidia pci card as the primary, that enabled the hdmi output of the card, but only with the free drivers (video-linux). I also tried to install bumblebee following this instructions. Everything seemed to work at first but only through the integrated hdmi (it disabled the nvidia card hdmi) and the performance was almost the same (if not worse) so I switched back to video-linux.

I know the card works just fine because I've been using it with Arch Linux without a problem for the last two years. I guess I could go back to Arch, but I've been using Manjaro without any problem on my laptop, and if I could solve this, I'd like to switch on my desktop too.

Can someone shed some light on this?


[joe@desktop ~]$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DVI-D-1 disconnected (normal left inverted right x axis y axis)
HDMI-3 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080     60.00*+  50.00    59.94    30.00    25.00    24.00    29.97    23.98  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1366x768      59.79  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  
VGA-2 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
[joe@desktop ~]$ inxi -G
  Card-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel 
  Card-2: NVIDIA GK208B [GeForce GT 730] driver: nouveau v: kernel 
  Display: x11 server: N/A driver: nvidia resolution: <xdpyinfo missing> 
  OpenGL: renderer: NV106 v: 4.3 Mesa 18.1.6 
[joe@desktop ~]$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
[joe@desktop ~]$

Please apply proper code wrapping in the outputs posted.

bumblebee is mainly for laptops, for power saving features, so it's not always easy for desktops, though it may work fine.
On desktops with integrated GPU and Addon GPU card, it is not easy (if at all) to use outputs from both cards.
You may disable Intel via some Xorg config and just use nVidia.
To check the available drivers for your system (there are some changes after Xorg upgrade to 1.20), run


You may install a nvidia-only option and use a config to disable Intel, before reboot, or... :stuck_out_tongue_winking_eye: after you are stuck in TTY

I will try to find this Xorg config on Archwiki (you may look yourself, too).

If you still want bumblebee, I think you can try, but use only Intel output and respective commands (optirun and primusrun)

Edit: You may try blacklisting the Intel modules in /etc/modprobe.d/

I tried using only the nvidia drivers: blank screen. If I blacklist the intel modules I dont get the blank screen, but it crashes before X starts and I cannot change to another tty.

I also tried changing the BusID for the device in the xorg conf and setting the pci e card as the primary device in the BIOS. I either get the blank screen or it crashes.

I'm using the card right now with the nouveau driver, and I used it in Arch with the nvidia driver, so it should work... I think I'm out of ideas.

Thanks for your help, petsam!

1 Like

One more... try PRIME

that may end up being key:

"NVIDIA's GeForce GT 730 is available in a number of configurations. The one with 96 cores uses the older Fermi architecture, while the 384 core version uses the latest, highly efficient Maxwell one..."

1 Like

I found that post yesterday and tried to set up prime, but it didn't work. :cry:

The one I have is less than two years old and I used it in Arch with the nvidia driver.

Did you try to run programs with optirun/primusrun with bumblebee?

Yes, I did. glxgears showed the same framerate in both cases.

So your problem is the poor performance of nvidia using bumblebee, or something else?
I think I need some rest, I get confused too easily.. :dizzy_face:

I didn't really want to install bumblebee, I tried it because I couldn't get the nvidia driver to work, but it didn't work either. I just wanted to use the nvidia card with the nvidia driver.

It's been two days without any progress, so I think I'll go back to Arch. But thank you very much for your help! I owe you a beer! :blush:

1 Like

Forum kindly sponsored by