Only sound in VLC player

I have done a fresh new install of Manjaro XFCE 17.0.2, but I don't get VLC player to work. I only have sound, but no screen, that stays black. I have changed from VLC-Nightly to VLC (2.2.6), same problem there.

It gives me this error:
vdpau_display error: output surface creation failure: A catch-all error, used when no other error code applies.

Inxi - Fw

System:    Host: oxygene Kernel: 4.9.34-1-MANJARO x86_64 (64 bit)
           Desktop: N/A Distro: Manjaro Linux
Machine:   Device: desktop System: ASUS product: All Series
           Mobo: ASUSTeK model: Z97-K v: Rev X.0x
           BIOS: American Megatrends v: 2308 date: 11/04/2014
CPU:       Quad core Intel Core i7-4790K (-HT-MCP-) cache: 8192 KB 
           clock speeds: max: 4400 MHz 1: 2386 MHz 2: 976 MHz 3: 1419 MHz
           4: 899 MHz 5: 993 MHz 6: 1297 MHz 7: 1302 MHz 8: 1228 MHz
Graphics:  Card: NVIDIA GM206 [GeForce GTX 960]
           Display Server: N/A drivers: nouveau (unloaded: modesetting)
           tty size: 80x24
Audio:     Card-1 NVIDIA Device 0fba driver: snd_hda_intel
           Card-2 Intel 9 Series Family HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.34-1-MANJARO
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full
           mac: f0:79:59:63:0b:d2
Drives:    HDD Total Size: 4120.8GB (5.5% used)
           ID-1: /dev/sdb model: WDC_WD40EZRX size: 4000.8GB
           ID-2: /dev/sda model: Samsung_SSD_850 size: 120.0GB
Partition: ID-1: / size: 93G used: 7.9G (9%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 18.45GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 0
Weather:   Conditions: 55 F (13 C) - Clear Time: June 27, 7:10 AM CEST
Info:      Processes: 187 Uptime: 23 min Memory: 905.4/15994.0MB
           Init: systemd Client: Shell (bash) inxi: 2.3.20 

What can I do to solve this ?

Is qt4 installed? You will need it for GUI.

`sudo pacman -Sy qt4`
1 Like

Yes, I think so, I get this:

qt4-4.8.7-20 is up to date

Should I re-install it ?

...fresh install? Done all the updates?
If yes, uninstall vlc, and in your .config empty the vlc-folder.
Then install vlc 2.6.6-1
Just noticed, you have nvidia. Is

   libva-vdpau-driver 0.7.4-2

installed?

I see you are using the Nouveau (free driver) for your Nvidia Card, and i think it will perform better with the Proprietary Driver installed.
From Manjaro Settings Manager > Hardware click on Auto Install Proprietary Driver and let detect and configure it. Do a reboot and test again if VLC is working.
I hope it helps!

Yes, that works. Didn't know this. Thanks bogdancovaciu.

Yeah , I has the same problem and the solution was install the Propietary driver for my Nvidia card

Thanks bogdancovaciu.

Okay, I have the same problem, but I do not want to change the driver free to non- free (nvidia), another solution?

Use other player like kmplayer?

Yes I have other players and it works very well . Only vlc has this problem, and more freeze the system after 1 or 2 minutes watching a movie. "" Trying to watch a movie only sound""

Same problem appeared for my notebook after fresh install of Manjaro XFCE 17.05

Strangely most of videos work properly but mobile recorded .mp4 ones can not be played. Sound comes video stucks as an image.

Tried most of thing:

  • Removed nighlty VLC

  • installed normal VLC

  • and qt4 also

  • SmPlayer not work too :frowning:
    tweaked other topics' setting on VLC to solve that maniac issue however nothing changed yet. Please someone help me?

No one helps?

Any particular reason for it? IS not like you have to pay for it because is nonfree ... It means is a close source driver, provided by Nvidia and not by linux community.

@linuxtopia - do you also use the nouveau (free) drivers ?

One way to change the video display is to disable acceleration in VLC settings >> advanced >> output modules >>> framebuffers. I never had to do that, an i never changed the default settings in VLC, but i always was assured to have the GPU drivers installed correctly ...

1 Like

-do you also use the nouveau (free) drivers ?

@bogdancovaciu > That PC's graphic card is Intel so its driver is already open source / free one.

My nephew's notebook is Lenovo S10e. He uses it for network, office and some video/phone documents. I've especially chose Manjaro as you know how fast and enough stable for that old notebooks.

I tweaked nearly every suggested manner on VLC but nothing changed and then installed other media player like SMPlayer, MPV Player, KM Player. Unfortunately saw that result was same how VLC showed.

Then I decided that the reason should be graphic card so tried other distros live USB boot options on this notebook. And tataa... The reason was really Intel driver.

Problem is not according to Manjaro XFCE 17.05 or VLC, cause I've tried Manjaro's Live USB on another PC, everything smooth on other PC but issued on this notebook.

And addition to situation S10e's original OS was Windows XP. On XP all HD videos worked but all we do not wanna use Windows.

Then, what should I do for this Intel graphic card to watch HD videos on it?

Thanks

Dis is a different issue (somehow) but solved some flickering/blinking of the menu elements.

If you can report the output of inxi -Fx would be easier to identify that hardware and the driver in use, and i'm sure there is a better solution. You can also look in the forum, i have seen this issue discussed.

inxi -Fx
Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System: Host: lenovo Kernel: 4.9.51-1-MANJARO i686 bits: 32 gcc: 7.2.0
Desktop: N/A Distro: Manjaro Linux
Machine: Device: laptop System: LENOVO product: 4187KW1 v: Lenovo serial: N/A
Mobo: Lenovo model: Kuril v: Rev 1.0 serial: N/A
BIOS: LENOVO v: 14CN57WW date: 02/25/2009
Battery BAT0: charge: 0.0 Wh 0.0% condition: 26.3/27.8 Wh (95%)
model: Celxpert LE30_C status: N/A
CPU: Single core Intel Atom N270 (-HT-)
arch: Bonnell rev.2 cache: 512 KB
flags: (nx pae sse sse2 sse3 ssse3) bmips: 3193
clock speeds: max: 1600 MHz 1: 800 MHz 2: 800 MHz
Graphics: Card: Intel Mobile 945GSE Express Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: N/A drivers: intel (unloaded: modesetting)
tty size: 80x11
Audio: Card Intel NM10/ICH7 Family High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.9.51-1-MANJARO
Network: Card-1: Broadcom Limited NetLink BCM5906M Fast Ethernet PCIE
driver: tg3 v: 3.137 bus-ID: 02:00.0
IF: enp2s0 state: down mac: 00:23:8b:82:8b:6a
Card-2: Broadcom Limited BCM4312 802.11b/g LP-PHY
driver: wl bus-ID: 05:00.0
IF: wlp5s0 state: up mac: 00:23:4e:de:d6:ef
Drives: HDD Total Size: 160.0GB (6.8% used)
ID-1: /dev/sda model: HITACHI_HTS54321 size: 160.0GB
Partition: ID-1: / size: 141G used: 5.6G (5%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 5.21GB used: 0.00GB (0%)
fs: swap dev: /dev/sda5
Sensors: System Temperatures: cpu: 30.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 132 Uptime: 1 min Memory: 272.9/995.0MB
Init: systemd Gcc sys: 7.2.0
Client: Shell (bash 4.4.121) inxi: 2.3.39

I think this will help to solve that issue. Follow the entire post and the comments from there.

1 Like

the problem was already solved , yes i use the nouveau driver , was solved in two ways first I changed the player, second in some updates solved the problem thank you.

Forum kindly sponsored by