OpenCL install conflict while nvidia driver installing

Hi, just like i said in the subject when i trying to install nvidia 440 driver from the pamac it says that

  • conflicting dependencies: - opencl-nvidia-440xx and opencl-nvidia-340xx are in conflict

and even i setup with a fresh install its just says this error i just want to install Nvidia driver with latest OpenCL version.

Hello,
If by default MHWD is identifying the Nvidia GPU, your system has, to be compatible with video-nvidia-340xx and installs that, then the OpenCL will follow the same version. If you want to manually install a different driver, then make sure you remove the older one. Before you move forward please provide:
inxi -Fxxxza --no-host

Sure: System:
Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64
root=UUID=6a31f9b1-eaea-40dd-bcc1-4a7fbafd71db rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.18.5 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Machine:
Type: Laptop System: ASUSTeK product: X542URR v: 1.0 serial:
Mobo: ASUSTeK model: X542URR v: 1.0 serial:
UEFI: American Megatrends v: X542URR.309 date: 05/21/2019
Battery:
ID-1: BAT0 charge: 27.5 Wh condition: 27.5/38.0 Wh (72%) volts: 7.7/7.7
model: ASUSTeK ASUS Battery type: Li-ion serial:
status: Not charging cycles: 680
CPU:
Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP
arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10)
microcode: CA L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 28808
Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 801
3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes,
SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:5917
Device-2: NVIDIA GM108M [GeForce 930MX] vendor: ASUSTeK driver: nouveau
v: kernel bus ID: 01:00.0 chip ID: 10de:134e
Display: x11 server: X.Org 1.20.8 driver: intel,nouveau
unloaded: modesetting alternate: fbdev,nv,vesa compositor: kwin_x11
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
v: 4.6 Mesa 20.0.7 direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71
Sound Server: ALSA v: k5.6.15-1-MANJARO
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus ID: 02:00.0
chip ID: 10ec:8168
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac:
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: AzureWave driver: ath10k_pci v: kernel port: d000
bus ID: 03:00.0 chip ID: 168c:0042
IF: wlp3s0 state: down mac:
Drives:
Local Storage: total: 931.51 GiB used: 8.25 GiB (0.9%)
ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s rotation: 5400 rpm serial: rev: SDM2
scheme: GPT
Partition:
ID-1: / raw size: 161.77 GiB size: 158.23 GiB (97.81%)
used: 8.25 GiB (5.2%) fs: ext4 dev: /dev/sda1
Sensors:
System Temperatures: cpu: 48.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2600
Info:
Processes: 224 Uptime: 48m Memory: 7.69 GiB used: 2.30 GiB (29.9%)
Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17
running in: konsole inxi: 3.0.37

That means you are using the free driver and not the proprietary one. Make sure you follow this:

Read it upfront before committing to install. Once is done and working, then install the
opencl-nvidia-440xx package if is not installed during that procedure.

Thanks for your help i installed as you said drivers and opencl without any problem but now i have another problem vsync is not working correctly i tried to switch nvidia then programs opened but panel and window manager didnt open and background was dark i tested the vsync its working on nvidia then i went back to intel its not working and switched to hybrid (its not actually switched by log out so i made it as startupprogress then i restarted my laptop it switched) and yeah vsync is not working on hybrid like intel, i changed optimus-manager settings for vsync before all i have done then i tried to use __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia vivaldi then it said vivaldi commant not found if you can show me how can i use this i really appreciate you thanks for taking care of me btw.

Most is covered by that tutorial, i can't add more to it, just make sure if in hybrid mode you use the shorter command:
prime-run vivaldi
If using just the Nvidia GPU, then you need no custom command as everything will run trough it. SInce i had no hands on such devices i can't give more advice than there already is there. :slight_smile:

Alright then have a nice day!

Sometimes vivaldi is launched by vivaldi-stable if you use AUR install.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by