OpenGL compositing has crashed kwin

I am new to manjaro and using KDE version of manjaro. My manjaro version is 19.0.2 and linux version 5.4.23-1. After installing manjaro, it ran well for couple of days. But now opengl crashes the Kwin. It takes longer time to boot and tears the screen. Previous I installed kubuntu and experienced the same issue.
Screenshot_20200314_005543
I tried both opengl 2 and 3.1. I also reduced the animation speed to two level. But the problem still persists after reboot.
The output of inxi -Fxzc0 -

[parag@parag-PC ~]$ inxi -Fxzc0
System:    Host: parag-PC Kernel: 5.4.23-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
           Desktop: KDE Plasma 5.17.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC v: 0889100000005B10000600000 
           serial: <filter> 
           Mobo: Hewlett-Packard model: 1970 v: 95.33 serial: <filter> UEFI: Insyde v: F.28 date: 03/14/2017 
Battery:   ID-1: BAT0 charge: 0.3 Wh condition: 6.2/6.2 Wh (100%) model: Hewlett-Packard Primary status: Charging 
CPU:       Topology: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 
           L2 cache: 3072 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20761 
           Speed: 1197 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1197 2: 1199 3: 1198 4: 1200 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard driver: i915 v: kernel 
           bus ID: 00:02.0 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] 
           vendor: Hewlett-Packard driver: radeon v: kernel bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.7 driver: intel,radeon FAILED: ati unloaded: modesetting tty: N/A 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.3.4 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.4.23-1-MANJARO 
Network:   Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard driver: rt2800pci v: 2.3.0 
           port: 4000 bus ID: 07:00.0 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel 
           port: 3000 bus ID: 08:00.0 
           IF: eno1 state: down mac: <filter> 
Drives:    Local Storage: total: 223.57 GiB used: 67.47 GiB (30.2%) 
           ID-1: /dev/sda vendor: Western Digital model: WDS240G2G0A-00JH30 size: 223.57 GiB 
Partition: ID-1: / size: 56.41 GiB used: 8.78 GiB (15.6%) fs: ext4 dev: /dev/sda7 
           ID-2: swap-1 size: 6.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 50.0 C mobo: N/A gpu: radeon temp: 45 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 183 Uptime: 19m Memory: 3.74 GiB used: 1.12 GiB (29.8%) Init: systemd Compilers: gcc: 9.2.1 
           Shell: bash v: 5.0.16 inxi: 3.0.37

What is the meaning of this-

Display: x11 server: X.Org 1.20.7 driver: intel,radeon FAILED: ati unloaded: modesetting tty: N/A 

Do I need a graphics driver for my radeon HD graphics. Is there driver that I can install?

:+1: Welcome to Manjaro! :+1:

AMD drivers are built into the kernel:

Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] 
vendor: Hewlett-Packard driver: radeon v: kernel bus ID: 01:00.0 

so there is nothing to do except to up / downgrade the kernel.

As the Radeon HD 8670A was a mobile graphics chip by AMD, launched in February 2013, I would advise the 4.19 LTS kernel:

 sudo mhwd-kernel --install linux419

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by