Operating system not found after install

Hi guys! I'm getting "Operating system not found" after installing Manjaro. First a bit of context.

On my Dell XPS 13 L321X I had a dual boot windows/manjaro. Yesterday I had the brilliant idea of
deleting the windows partition since I didn't want it anymore (also because I wanted some more space). After deleting the windows partition I got "Operating system not found" upon boot. Very well, I proceeded then by following the wiki's guide on how to restore GRUB following the UEFI guide. The problem was that i got "EFI variables are not supported on this system.". I followed the suggestions of the guide of installing efibootmgr, dosfstools and load the "efivarfs" module but once I got in chroot again I got the same error as before. So I've tried to reinstall the system from scratch.

I tried to install from the KDE edition and from manjaro-architect but every time I got the same
"Operating system not found" error after installing. Upon doing some research online, I realised that
the problem might lay on the EFI dos/gpt partition scheme of my SSD. I reinstalled a couple of times
trying a certain number of combinations of GPT + EFI partition and MSDOS classic grub install, none of wich worked.

The problem, I think, is the fact that the USB media that I used to install Manjaro (I tried also Arch Linux and KaOS, with no luck) boots not in UEFI mode but in legacy mode despite my system needs a EFI partition in order to start GRUB and consequently the OS. Here I am stuck. I don't know what I can do at this point. I also should point out the fact that this problem has arised only after the deletion of the windows partition and in the past I had various Linux distros installed (Manjaro and KaOS) and I never had too much trouble installing and booting. Could it be related to windows' fast boot mode maybe? I don't think I had it disabled.

In the BIOS of the computer there is not a single entry that could be of help, there is no mention of secure boot or UEFI/EFI either.

Anyhow, any idea of what could I do to actually boot a working system? If you have further questions please do ask, english is not my first language sorry.

Thanks to all in advance!

1 Like

Boot into manjaro using this method.. Any mode (uefi or bios-legacy) But just try bios-legacy, when booted provide..output from terminal.

sudo parted -l
sudo blkid
cat /etc/fstab
efibootmgr -v

I had a similar problem when I installed Manjaro on this machine ─ it's my first machine with an EFI, and I didn't know about this issue either.

The problem is indeed that your installer thinks it's in legacy BIOS mode, and then instead of recognizing the EFI System Partition, it'll see it as merely a DOS/Windows partition.

The workaround is to enter the EFI setup ─ commonly by pressing Del at boot time ─ and making sure that the firmware is set to boot in EFI mode only. Then proceed with a new installation, and then the installer will recognize that the machine is in EFI mode, and it will recognize the ESP and put the required efivar in it, which will in turn start your GRUB boot loader. :wink:

I installed the system using the default configuration for my SSD. Here are the outputs:

[teo@teo-pc ~]$ LC_ALL=C sudo parted -l
Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  250GB  250GB  primary  ext4

[teo@teo-pc ~]$ LC_ALL=C sudo blkid
/dev/sda1: UUID="626587b1-af5d-4054-9265-d02bbcb83aa5" TYPE="ext4" PARTUUID="b4a4f9d9-01"

[teo@teo-pc ~]$ cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=626587b1-af5d-4054-9265-d02bbcb83aa5 /              ext4    defaults,noatime,discard 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

[teo@teo-pc ~]$ efibootmgr -v
EFI variables are not supported on this system.

I could correctly boot using the "Simple First Start" from the guide you provided in the link.

The problem is, that there is no "EFI mode" only settng anywhere in the BIOS or by pressing any of the keys at boot. Maybe I'm wrong and the computer does not support UEFI? It should.

No, this is not the problem. You have no problem.
You are not on uefi and you should not be using uefi, as I suspected.
You just keep trying to boot in uefi.
If you still in the system, or if you have logged off, boot up again in bios-legacy as per my method,
At the terminal

sudo grub-install /dev/sda
sudo update-grub

ps; if new installed, you may want to do this first

sudo pacman-mirrors -f4
sudo pacman -Syyu

Good luck,

Ok, then no UEFI. I tried to reinstall GRUB but after reboot I still get "Operating System not found" error. Also, Arch and KaOS both showed this problem when I tried to install them. I did the grub-install after updating the system.

So, at the end I managed to solve the problem, the partition that contained /boot wasn't marked as boot, marking it solved all the problems. It was really simple in the end. Thank you for the help!

1 Like

You mean root partition? Or do you have another partition for /boot?

Root partition. The default installer only creates 1 partition.

1 Like

Well, that clearly illustrates that it's not an EFI installation, because in an EFI setup, it would be the EFI System Partition that must be marked as bootable, not any of the other partitions. :wink:

1 Like

Then you're not booting it in UEFI mode and the installation was not a UEFI installation. :wink:

If you have a half-decent boot selection menu you should be able to select BIOS or UEFI boot modes for bootable media.

If you want a UEFI-based system then you should reinstall now before making customisations etc. to your system.

1 Like

Yeah, that's right. I don't know why I kept insisting on the UEFI side.

1 Like

Seeking clarification, how did you mark the partition as 'boot'?
Also, how did you 'delete' the windows partition?

1 Like

For Linux, it is not normally necessary to flag the boot partition as "boot", except for.. exceptions.
As this happened after partition actions, maybe you needed to force install grub to MBR. Normal install is not enough.

sudo grub-install --recheck /dev/sda
1 Like

From the KDE partition manager, I added boot as a flag. I deleted the windows partition also from the partition manager.

I tried this too, no luck.

1 Like

Okay, @chaosphere
You have either a buggy bios (which needs a boot flag) or a buggy drive (which has not set partitioning table -kde partition manager does not set partitioning table).
Ciao, take care.

@AgentS, perhaps best when troubleshooting, just set a boot flag to a msdos drive, particularly if it has only one partition.

Yes, you (and I) are right, boot flag is not necessary for linux, but the following links (that say we are right) also has noted buggy bios's and buggy partitioning (see somewhere below about only one partition drive).

link 1
link 2
link 3
link 4

1 Like

We can only bookmark those

Maybe it's the BIOS, the SSD it's only a few months old. I don't know.

ah... I had wanted to ask right at the beginning if you had a new ssd drive.
Then I noted you said you had removed windows from it and so I assume that is not a new drive.
A new ssd bought off the shelf does not have any partitioning on it. It is 'raw'. Not msdos, not gpt.
Bios will then 'guess' what it thinks that raw drive is.
Always set a partition table to drive, especially if it is a new drive or if we want to set up the whole drive again. And use gparted for this purpose. kde partition manager or other partition managers (as far as I know, unless improved) cannot do this function well.

Anyway, 'water under the bridge' [1] now and you have got everything working. But thanks for this clarification. Quite [2] useful.

Useless quibbles -
[1] love those english metaphors, tickled by them, but perhaps I'm autistic
[2] quite - 'somewhat' or 'absolutely' ? - only double entendre in any language that has contrary meanings

Forum kindly sponsored by