optimus-manager not working

Hi,
I have an optimus laptop and want to use my nvidia GPU by default when im plugged in (which is most of the time) but also want the ability to switch to the intel iGPU when on the go. Optimus-manager is supposed to do just that, unfortunately when I try to switch to the NVIDIA GPU by
optimus-manager --switch nvidia
its gives the following error message:
"the nvidia module does not seem to be available for the current kernel. It is likely the Nvidia driver was not properly installed. GPU switching will probably fail, continue anyway ?" -and sure enough it fails, with x server failing to restart leaving me on a blank screen --- oddly enough the cursor works tho.
how can I fix this?
Specs:
KDE, kernel 5.0.9.2, CPU Celeron N3350 GPU Nvidia GF 810m
thanks in advance!

Go once again trough the tutorial and see where it went wrong:


Since you get the message

it should be a clue to what to do, and properly install the driver. :slight_smile:

I tried to do just that, but MHVD gives the following error when I try to install the video-nvidia-390xx driver:
"error: failed to prepare transaction (could not satisfy dependencies)
:: optimus-manager: removing linux316-nvidia breaks dependency 'nvidia'
Error: pacman failed!
Error: script failed!"

are you doing this first from terminal:
sudo mhwd -r pci video-nvidia
and then
sudo mhwd -i pci video-nvidia-390xx
or are you using
sudo mhwd -a pci video-nvidia-390xx
?

I tried

sudo mhwd -i pci video-nvidia-390xx

because I thought

sudo mhwd -a pci video-nvidia-390xx

would install bumblebee which is incomatible with optimus-manager

Ok, optimus-switch https://archived.forum.manjaro.org/t/call-for-testing-optimus-switch/75773 can do the trick with relatively little fuss, but it would be nice to have an actual GUI option to easily switch between GPUs..

1 Like

@loradona98 recently modifed one for use with gnome but nothing as of yet for kde, and i've never done gui creation so if someone else capable would like to do so thats great. glad to hear everything worked out.:+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by