Optimus-manager, nvidia module does not seem to be available for the current kernel.

Hi there, I've followed the tutorial here
I never had Bumblebee installed so I have installed the 390x Nvidia driver, that driver works for me as I've ran prime using it.
However I get the following message when attempting to switch gpus-

WARNING : the nvidia module does not seem to be available for the current kernel. It is likely the Nvidia driver was not properly installed. GPU switching will probably fail,
 continue anyway ? (y/N)
user@manjaro Linux 5.0.21-rt16-MANJARO x86_64 18.0.4 Illyria
~ >>> inxi -Fxz                                                                                                                                                                                                   
System:    Host: manjaro Kernel: 5.0.21-rt16-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: Gnome 3.32.2 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: FX503VD v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: FX503VD v: 1.0 serial: <filter> UEFI [Legacy]: American Megatrends v: FX503VD.302 
           date: 10/03/2017 
Battery:   ID-1: BAT1 charge: 58.3 Wh condition: 58.3/64.4 Wh (90%) model: ASUS A32-K55 status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44928 
           Speed: 900 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1425 2: 1396 3: 1389 4: 1265 5: 1150 6: 948 7: 1263 
           8: 1647 
Graphics:  Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.org 1.20.5 driver: intel,modesetting resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 19.1.4 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.0.21-rt16-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: d000 
           bus ID: 02:00.0 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: d000 bus ID: 04:00.0 
           IF: wlp4s0 state: down mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 1.03 TiB used: 21.42 GiB (2.0%) 
           ID-1: /dev/sda vendor: SanDisk model: SD8SN8U128G1002 size: 119.24 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
Partition: ID-1: / size: 116.38 GiB used: 21.42 GiB (18.4%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 67.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 273 Uptime: 24m Memory: 7.67 GiB used: 1.67 GiB (21.7%) Init: systemd Compilers: gcc: 9.1.0 Shell: zsh 
           v: 5.7.1 inxi: 3.0.35 

Do not try it with another kernel.
Not try rt kernel.

I think that @admdb misspoken. He rather meant: do not try rt kernel, however, that is too late since you already installed it. Just install regular kernel 5.2 for example. Also, kernel 5.0 reached end of life, that is why there is no nvidia modules for it anymore. Strangely it's seems to be still available in rt version which you have it. Maybe there is a reason to keep it but I don't know it. If you are not a music producer or don't do any work with sound, rt kernels are to be avoided.

A good practice is to keep at least two kernels installed. A newest stable one (so skip experimental ones, unless you are an experienced user or have the newest hardware) and the latest LTS. So currently it's 4.19 and 5.2. When the new kernel arrive, install it and ditch the older non-LTS one as it becomes EOL (end of life) at some point, unless they are made to be the new LTS.

2 Likes

Ok thanks, I have reinstalled Manjaro as I'm going to try and set up Optimus manager from scratch.
To get Architect to load I have to use the non free video driver in Architects boot screen. During the actual install I chose the free driver. To get the system to boot I've added nouveau.modeset=0 in the kernel params.
Any assistance, guides will be greatly appreciated.
I will hopefully have the time to set this up in the morning.

If possible, use always non-free drivers for nvidia. No sure why people even load free ones for nvidia, but some claim their system won't boot so they have to use free drivers and then switch to non-free later.

If there are no issues, non-free drivers should be chosen always from the start because you need them anyway and free ones are basically useless. Free nvidia drivers are just because of ideology but almost no one is that crazy to use them.

1 Like

Hey, thanks for the response.
My laptop requires that non free drivers are installed first. On Manjaro the only way (so far) I can get the Nvidia card running is by using Prime. I really would prefer been able to switch between GPUs for all the obvious reasons.
I'm having no luck trying to set up Optimus manager, should I set up prime and then attempt installation of Optimus manager??
Thanks

Then you are lucky and don't need to mess with a free version anyway. Usually, people have the opposite situation, they have to install free ones first and only then they can switch to non-free ones.

If optimus-manager is not working for you somehow (did you read about changing switching method? if nouveau isn't working, try bbswitch) try optimus-switch, it's said to be way easier to set up. PRIME is an option but it will take more energy and will heat the laptop more so it's only good if you want to use it mostly for gaming with AC plugged in.

Currently, the 435 nvidia driver series (available in testing branch, will be later probably on stable branch but this is being discussed now) introduced some prime off-loading, so you may try out PRIME setup with 435 drivers. We didn't test it thou and we don't know how and if it works. In theory 435 driver should use intel by default and switch to nvidia during intensive GPU work, just like on Windows but the technology is brand new, less tested and maybe not fully equal to window's counterpart so we don't know how it will really work. Those things are the cutting edge things in Linux so we simply don't have experience yet and little ways to test it with certainty.

EDIT: For more information about nvidia 435, requirements and setup see this topic:

Since this is a brand new thing, it requires a good knowledge how Manjaro works so it's not for Manjaro newbies.

2 Likes

I suggest you try this (supposing you are using GDM because you are on GNOME), I've come across it a while ago and it worked fine for me.

2 Likes

Thanks for the replies.
The 435 driver sounds like what everyone has been waiting for... once stable.
In the mean time switch is working great for me, and yep so easy to set up.

2 Likes

I talked with optimus-manager developer and he said that it's compatible with 435 drivers. However, I personally will wait and stay with 430 series, because:

  • most of the time I don't need nvidia so saving the batter is the best thing to do, hence I prefer to be on intel most of time, nvidia mode with off-loaded GPU is not powering it off completely so it uses more energy then intel (someone reported it to be only 6% more so that's not much but since I don't game much, intel mode is more reasonable)
  • some reported 435 drivers to work badly with KDE but some had no issues in Plasma with them, anyway I'm not in hurry to find out
  • technology used in 435 series is new, buggy, incomplete and not fully tested and I lack of skills and time to play with it, I prefer something that works and since optimus-manager works well for me, I don't need to switch to 435 series just yet
  • 430 series breaks CUDA but I don't use it so I don't need 418 or 435 to make it work, 430 series works fine for me.

Maybe there will come time I will want to try out 435 or newer series but for now, I'm happy where I am.

1 Like

I tend to agree, right now I can switch between GPU's. Its manual and no GUI option but it works just fine.
I thought about creating icons for sudo set-intel.sh and sudo set-nvidia.shbut decided I didn't need the extra glitter.
All this been said I am eagerly awaiting 435 hitting stable.

2 Likes

you dont have to, @linesma put this together.

2 Likes

Fantastic!
I should of known. I assumed the indicator was just working with Optimus manager.
Thanks for pointing this out.

1 Like

Hi, I see the Nvidia driver 435xx is listed in mhwd.
Is Switch compatable? if I install 435xxx do I even still need Switch?
Am I missing an obvious thread on this..?
Thanks in advance.

yes

like you would any other version nvidia drivers. the new render offload feature in 435.xx is sadly not the optimus solution linux users have been hoping for. both the nvidia and intel gpu's have to remain powered on for it to work. there is no situation where the nvidia gpu is powered down.

yes. a few actually :wink:

unless theres a specific reason for using 435.xx, your probably better off sticking to the 430 series for now while the bugs get worked out of 435.xx drivers.

1 Like

Would you recommend updating to 435xx, is it as simple as hitting it in mhwd? I suspect not but its very tempting to try.

also: if you do install the 435.xx drivers via mhwd, you'll need to delete these .conf files so they dont conflict with optimus-switch configurations.

rm /etc/X11/xorg.conf.d/90-mhwd.conf
rm /etc/modprobe.d/mhwd-gpu.conf
rm /etc/modules-load.d/mhwd-gpu.conf

mhwd will create these files any time you do a new install of video drivers using mhwd. just be sure to remove them before rebooting so they dont interfere. otherwise, test all the drivers you want :+1:

1 Like

Thanks, I think I may follow your advice and stick with what I have for the time being.
Everything just works at the moment so why give myself the extra work....

1 Like

Hi just my 50 cents:
I've removed bumblebee and installed nvidia-435xx.
Didn't remove neither 90-mhwd.conf nor mhwd-gpu.conf in any location mentioned by dglt.
Made a link ln -s /etc/X11/mhwd.d/intel-nvidia.conf /etc/X11/xorg.conf.d/01-nvidia-offloading.conf where intel-nvidia.conf is as follows:

Section "ServerLayout"
  Identifier "layout"
  Option "AllowNVIDIAGPUScreens"
  Screen 0 "iGPU"
EndSection

Section "Device"
  Identifier "iGPU"
  Driver "intel"
#  BusID "PCI:0:2:0"
  Option "TearFree" "true"
  Option "AccelMethod" "sna"
  Option "DRI" "3"
EndSection

Section "DRI"
    Group "video"
    Mode 0666
EndSection

Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER" "Enable"
EndSection

Section "Screen"
  Identifier "iGPU"
  Device "iGPU"
EndSection

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
#  BusID "PCI:1:0:0"
EndSection

That was about 4 days ago, everything has been working fine since then and no signs of issues.
I mean I have now the default mhwd config for nvidia-435xx and custom intel-nvidia config, they seem to not conflict with each other.

1 Like

Forum kindly sponsored by