Optimus Manager Overheating Laptop?

I have successfully installed Optimus Manager for my Matebook X Pro because I would like to use the Nvidia card for its performance.

2 problems that I am having is that I can't use the Nvidia setting for more than 30 minutes because my laptop starts to overheat and the fans start going crazy.

  1. I have followed this guide and I read and applied step 10 but even with the bbswitch setting turned on - it overheats my laptop.

  2. How do I configure the power savings mode with Nvidia? Is it possible to maintain my battery life as if it were running on the Intel GPU? I get about 7 hours with the Intel GPU and I believe I only get about 3-4 with the Nvidia but I haven't been able to test it fully due to the overheating issues...
    Edit: I've noticed that the battery life lasts for 7-8 hours only with Bumblebee... I can't mimic that battery life with Optimus Manager whether it is using the Intel or the Nvidia Card... How do I go about extending my battery life? Please help

inxi -Fxxxz
System:    Host: joe-pc Kernel: 4.19.69-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.4 
           tk: Qt 5.13.0 wm: i3 4.17.1 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HUAWEI product: MACH-WX9 v: M15 serial: <filter> 
           Mobo: HUAWEI model: MACH-WX9 v: M15 serial: <filter> UEFI: HUAWEI v: 1.28 date: 03/15/2019 
Battery:   ID-1: BAT0 charge: 32.2 Wh condition: 47.8/56.3 Wh (85%) volts: 7.8/7.6 model: DYNAPACK HB4593R1ECW type: Li-ion 
           serial: <filter> status: Discharging cycles: 227 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
           Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 4: 800 5: 800 6: 801 7: 800 8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Huawei driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A bus ID: 01:00.0 chip ID: 10de:1d12 
           Display: x11 server: X.Org 1.20.5 driver: modesetting compositor: compton resolution: 3000x2000~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.1.5 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Huawei driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k4.19.69-1-MANJARO 
Network:   Device-1: Intel Wireless 8265 / 8275 vendor: Huawei driver: iwlwifi v: kernel port: 5040 bus ID: 03:00.0 
           chip ID: 8086:24fd 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 24.59 GiB (10.3%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
           rev: AAXA4103 scheme: GPT 
Partition: ID-1: / size: 120.52 GiB used: 24.59 GiB (20.4%) fs: ext4 dev: /dev/nvme0n1p3 
           ID-2: swap-1 size: 3.91 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 51.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 237 Uptime: 2m Memory: 7.55 GiB used: 1.26 GiB (16.7%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           Shell: zsh v: 5.7.1 running in: konsole inxi: 3.0.36 

Please help me fix this issue :pray: I would really like to use my laptop at full potential. I am sick of the graphical delays and slow browser loading with the Intel gpu...

Try tlpui - it is a GUI for TLP.

Since tlp settings are incredibly reach and complex, there is no easy guide. You can only read tlp documentation or some arch wiki articles for it.

Overheating can be also caused by some problems. Check your journalctl to see if there are any ACPI problems or anything that raises cpu or gpu usage above the norm and debug it.

I will try the tlpui gui when I get a chance.

As for overheating - which line should I be keeping an eye out for? I typed journalctl -f for the new messages but there's way too much info. How should I narrow it down for debugging purposes?

The overheating issue has been preventing me from using the Nvidia driver... It's cool for 10 minutes and then all of a sudden my fans start to go bezerk and I am forced to restart my laptop... Please help - thanks in advance

Ok so apparently the Nvidia (only) option is not compatible with my device but I tried the hybrid and this is exactly what I needed so the overheating issue has been solved :smiley:

However I noticed that the hybrid option doesn't run glx? I have compton running but I can't start it on hybrid mode and I get the following errors for when I do attempt to run it. Do you happen to know what I can do to fix this?

compton
glx_init(): No GLX extension.

and then

glxinfo 
name of display: :0
Error: couldn't find RGB GLX visual or fbconfig

Another thing is that I have been trying to adjust my external monitor resolution because the external monitor is way too zoomed in. It should be a 1920x1080 display but it feels like it is 500x600 therefore making it useless. Here is the information I get from the following:

xrandr -q
Screen 0: minimum 320 x 200, current 3000 x 2000, maximum 8192 x 8192
eDP-1 connected primary 3000x2000+0+0 (normal left inverted right x axis y axis) 293mm x 196mm
   3000x2000     60.00*+  48.01  
DP-1 connected 1920x1080+3000+0 (normal left inverted right x axis y axis)
   1920x1080     60.00 +  60.00    50.00    59.94  
   1920x1080i    60.00    60.00    50.00    59.94  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1152x864      75.00  
   1280x720      60.00    60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    60.00    59.94    59.94  
   640x480       75.00    72.81    60.00    59.94    59.94  
   720x400       70.08  
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)

when you say "nvidia (only)" are you referring to nvidia mode of optimus-manager or something else?

same question in regards to what your calling "hybrid" ? please clarify.

both of these sound like your using vesa and not intel, modesetting, or nvidia. post these outputs

inxi -Gxxxz
mhwd -li
ls -laR /etc/X11
systemctl status optimus-manager
xrandr --listproviders

Oh sorry. Yes I am using Optimus Manager - and with that it provides 3 separate modes: nvidia, intel, hybrid. For clarification, if I set optimus manager to nvidia mode then it overheats my laptop within 5 minutes but the only way I can get the nvidia card is by using the hybrid option that optimus manager provides which is perfect for my studies (provides long lasting battery and renders chrome extremely quickly compared to intel mode).

inxi -Gxxxz
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Huawei 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Huawei 
  driver: nvidia v: 430.40 bus ID: 01:00.0 chip ID: 10de:1d12 
  Display: x11 server: X.Org 1.20.5 driver: modesetting 
  unloaded: nvidia resolution: 3000x2000~60Hz 
  OpenGL: renderer: N/A v: N/A direct render: N/A 
mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-430xx-bumblebee            2019.08.24               false            PCI


Warning: No installed USB configs!
ls -1aR /etc/X11
/etc/X11:
.
..
mhwd.d
xinit
xorg.conf.d

/etc/X11/mhwd.d:
.
..
intel.conf
nvidia.conf.nvidia-xconfig-original

/etc/X11/xinit:
.
..
xinitrc
xinitrc.d
xserverrc

/etc/X11/xinit/xinitrc.d:
.
..
40-libcanberra-gtk-module.sh
50-systemd-user.sh

/etc/X11/xorg.conf.d:
.
..
00-keyboard.conf
10-optimus-manager.conf
70-synaptics.conf
optimus.conf
systemctl status optimus-manager
● optimus-manager.service - Optimus Manager Commands Daemon
   Loaded: loaded (/usr/lib/systemd/system/optimus-manager.service; >
   Active: active (running) since Tue 2019-10-15 11:14:31 EDT; 6min >
  Process: 536 ExecStartPre=/usr/bin/prime-switch-boot (code=exited,>
 Main PID: 831 (python3)
    Tasks: 1 (limit: 4915)
   Memory: 45.7M
   CGroup: /system.slice/optimus-manager.service
           └─831 /usr/bin/python3 -u /usr/bin/optimus-manager-daemon
xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x46 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 4 associated providers: 0 name:modesetting

Monitor Issue
monitor_bug
I played around with some xrandr commands and now my main display only uses a portion of the main display (shown in the picture above). This cropped display on my main screen fills up the whole external monitor screen (hence why I described it as being zoomed in). I would like my main display to be it's default (works perfectly fine without the monitor plugged in) and set the external monitor display to be 1920x1080 without it being zoomed in.

Thank you in advance :slight_smile:

so what optimus-manager calls "hybrid" is actually just "enable fumblebee" :rofl: .

this i highly doubt, since nvidia mode is not truly an "nvidia only" mode, it's a PRIME setup where the nvidia does the heavy lifting then uses the intel to display it. the problem with overheating might have to do with the nouveau module being loaded which optimus-manager uses to power off/on the nvidia gpu but just having nouveau loaded can cause problems, usually it's "my fans are stuck on maximum speed" but in your case might be "my fans dont come on at all" :man_shrugging:

maybe @michaldybczak has some better ideas.

Oh I had no idea - well the hybrid option works best and keeps my battery life the longest so I think I will continue using this. I just need to figure out how to enable glx so I can get compton properly working again.

Interesting, does switching the mode to bbswitch under the Nvidia mode option fix that? In my case, I have tried that and the overheating issue is quite annoying so there must be something I'm missing.

P.S. If you have any solutions that can help me overcome my external monitor issue, please let me know! :smiley: Thanks for the support again guys

I thought that hybrid mode is rather for nvidia 439 series to utilize native gpu off-loading (which isn't that great in current form). When in doubt I checked the optimus-manager documentation:

  • optimus-manager --switch hybrid to switch to the Intel GPU but leave the Nvidia GPU available for CUDA and PRIME Render offload

So I was correct, this is meant for 435 and higher series. If used on 430 or lower drivers it will offer Intel GPU and nothing more.

Usually, it's best to start with:

journalctl -b -p3

This will show you errors from the current boot. Make terminal full screen to get whole message lines. This shows various errors and it MIGHT show an issue behind overheating (when you are on nvidia mode). Usually, everyone gets some errors, some are serious, some not. Just copy and paste them to the search engine and see what came out. If there is some solution, try it. Some hardware errors may not be (easy) fixable thou.

With overheating I would do just that:

  • check journalctl
  • run and observer system monitor for high CPU usage
  • monitor CPU temperature
  • if available GPU temperature and usage
  • check if some process is not overly active
  • install LXQt to see if the issue persists on nvidia in LXQT session
  • create a new, clean test user, log in, switch to nvidia and see if the issue exists there (if not, user configs are at fault)
  • try different kernels, especially the newest ones, you use relatively old 4,19 one and for this laptop newer kernel might do the trick

Overheating can come from a few sources:

  • CPU issue (like fan not working, etc.)
  • GPU issue (drivers)
  • software issue (causing unnaturally high CPU or GPU load, something is badly configured)
  • ACPI issue
  • badly working TLP for this specific hardware (maybe it needs some kernel module to be turned off, or turned on, etc.)
  • kernel issue
1 Like

Ok so I moved to another kernel (5.2x) and there are no errors when I type in the command journalctl -b -p3 which is good.

I do notice some strange CPU errors though. I went inside htop within the first few seconds of boot and there is always 1 CPU that maxes out @ 100%... It changes CPU # too, so lets say first minute it is 100% on CPU2 and then the next minute CPU2 becomes normal and CPU5 maxes out at 100% and so forth... Still unable to last more than 5 minutes with Nvidia mode on.
nvidia_htop_bug

P.S. On Kernels 5.x+ (5.2 and 5.3), I have some really slight screen glitching when booting up and shutting down before I get to the log in page. This is a completely different issue that I will look into but changing kernels takes no affect so I will remain on 4.19 to be safe.
Nvidia Mode

glxinfo | grep vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

Hybrid Mode

glxinfo | grep vendor
Error: couldn't find RGB GLX visual or fbconfig

Honestly, my laptop runs perfectly fine with optimus manager's hybrid mode and I'm comfortable using it. But I really need to figure out a way to enable glx on it so that compton works properly... Any setting that I can tweak for this to work out?

i just noticed you still have optimus.conf which im assuming is left over from a previous PRIME setup and 10-optimus-manager.conf from your current setup which gets changed on every boot by optimus-manager . the 10-optimus-manager.conf should stay but optimus.conf needs to be removed or renamed so it doesnt conflict with optimus-managers configuration.

sudo mv /etc/X11/xorg.conf.d/optimus.conf /etc/X11/xorg.conf.d/optimus.conf.bak

you also dont have video-linux installed which has the intel driver packaged with it, instead of installing video-linux and screwing with your current setup you can just install the intel driver instead

sudo pacman -S xf86-video-intel

reboot when your done and do some testing

I can add that when using Intel, I am using Modesetting drivers because this is the only one capable of using my HDMI output that is attached to Nvidia card. This can be set in optimus-manager-qt - this tray icon utility for optimus-manager.

If you want to use nvidia in hybrid mode, consider manually installing nvidia-435 series (proper drivers + kernel modules) and read this topic to know how to use it:

Just tried both but unfortunately did not do anything. :C

The problem with intel mode for my machine is that it does not perform well in browser. Everything is laggy and graphics especially are incredibly slow when attempting to load in browser. But the benefit about intel mode is that compton and glxinfo are properly loaded with no errors.

The benefits of hybrid mode is that there is no lag absolutely and for once I am able to use this machine to its fullest potential in terms of no input lag. But the problem with hybrid mode is that glxinfo returns that error that I posted above us. If I can get glxinfo to work then my issue with the graphics drivers will be solved completely.

I have that setting set in optimus-manager-qt as well. I believe I tried installing just the nvidia cards before and it broke my laptop because it is a hybrid machine. My attempt can be found here.

there should be an optimus-manager configuration file somewhere that lets you choose which driver to use, change from modesetting to intel.

if the hybrid mode is suppose to work like the render offload feature of the 435.xx driver as @michaldybczak mentioned then the nvidia gpu remains powered on at all times. if your intention is to stick with hybrid mode then bumblebee would even make more sense. at least the gpu would be powered down when not in use.

I will try setting the modesetting to intel and will let you know how that goes.

And yes correct, I can not use the 435.xx drivers or any of the nvidia drivers alone on my machine because if you look at the article from my last attempt at installing these drivers my machine broke. I am currently using bumblebee which is perfectly fine but the issue is glx not loading when in hybrid mode. I just need to figure out why this is happening and fix it and everything would be perfectly fine :sweat_smile:

With such problems, I suggest studying the gpu possibilities and configs. It's possible that you did some stupid mistake by the last attempt and after you get more knowledgeable, you can fix this in tty.

I would make a backup and still attempt some experiments. Have some other computer with Internet available and troubleshoot if DM and X session won't start due to some driver setup issues.

As to 435 drivers, in theory with correctly set optimus-manager, all you need to do is to install:

nvidia-435xx-utils
lib32-nvidia-435xx-utils
linuxXX-nvidia-435xx (dependently on which kernel you are on, so XX means the kernel number like 53, etc.)
I assume, this will force you to uninstall 430 packages and modules first. Do this in the same session, otherwise you will have to finish it in tty.

and nothing more. Optimus-manager will create own configs that should work. Then you probably need to know a command to trigger nvidia use for something like glxinfo.

EDIT: I looked on your first attempt and you did everything wrong. Bublebee doesn't have to be uninstalled, just made inactive, reboot without having a working alternative setup was also a mistake. So no wonder why it failed you. Whatever wrong choice there was, you made it :wink: . That is how you learn the hard way.

I'm still using 430 drivers because I see no gain in hybrid mode, plus my system is running fine for over 3 years and I don't want to risk it. But if I had a fresh install, then playing with drivers is a good idea because you don't lose much and can learn a lot.

1 Like

Sweet, thank you for the insight! I will attempt this later this week hopefully and then report back with my progress. I really appreciate the patience and the support. :smiley:

Messing system up is how you learn. Almost everyone broke their system at least two times so don't worry.

Hybrid laptops can really work fine if set properly so find a way. Bumblebee is not a valid option nowadays since it can't run Vulkan and that is the main thing that Proton uses.

2 Likes

couldnt agree more.

if only it was just 2 times. :sob:

2 Likes

Forum kindly sponsored by