Optirun problem on Manjaro KDE

Still not work after editing grub. I can enter desktop though after going fallback initramfs and install the driver

Weirdly I can boot live with FREE driver but not for NON FREE.

Even though nouveau which is a free driver crash on me

When chrooting it should no matter whether you use free or non-free drivers.

Let's back to the topic, why I optirun crash

Have you tried if Optimus-manager work for you???

it does matter, im only able to boot the live desktop with free drivers and after install i remove them, install video-nvidia using prime.
sometimes people can get the nonfree to boot on optimus setups by blacklisting nouveau and/or adding kernel parameters by editing command line before trying to boot. in my situation bumblebee just flat out would not work if i installed it later or if trying to boot live environment.

@mitsuha what is your intended use for this laptop? if you want best performance without needing to primusrun,optirun,bbswitch, etc.. then optimus-manager or prime are better options, but you should still be able to boot properly with bumblebee since you have already done so previously. read through what @fademind linked.
here are links to tutorials for prime and optimus-manager if you choose to go that way.


That's strange. I always booted non-free and it worked on my optimus laptops. Maybe something has changed, because I had my last install 2,5 year ago or maybe it depends on hardware and it's 50/50.

I'm not an expert and as you see I'm not giving details, but my understanding or suspicion is:

  • you installed both free and non-free drivers and bbswitch don't know it should use non-free ones, because it's all misconfigured in such a situation.

So @dglt was showing you how to uninstall the free driver, then uninstall missconfigured bumblebee and install then bumblebee again, which should (in theory) be correctly configured by mhwd now that free driver is not there.

1 Like

that was my intended outcome although i dont believe he had the chance to uninstall/reinstall bumblebee properly. so @mitsuha now that you able to get to desktop, have connection, can you uninstall bumblebee the and then reinstall it.
sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -a pci nonfree 0300
sudo systemctl enable bumblebee
sudo gpasswd -a mitsuha bumblebee

then reboot normally

I have acpid.service disabled and bumblebee working just fine, so I am sure acpid is not necessary in ALL cases.
Also, video-linux is a good fallback option because most times it just works and when one screws things up with bumblebee/whatever, he is always able to have a working X session instead of fighting with drivers and other follow-up issues in cli.

Back to topic: I'd suggest to remove xf86-video-nouveau, bumblebee, bbswitch, nvidia drivers, delete everything in /etc/bumblebee, /etc/X11/mhwd and /etc/X11/xorg.conf.d, remove mhwd* files in /etc/modprobe.d and /etc/modules-load, delete /lib/modprobe.d/bumblebee, remove blacklist options from GRUB_CMD_LINE in /etc/default/grub and do a sudo update-grub, and then start over again with installation of video-linux -- reboot -- then activation of video-hybrid-intel-nvidia-bumblebee using mhwd, systemctl and gpasswd.

1 Like

i agree with all the deleting of previous configs, removing xf86-video-nouveau , bumblebee , bbswitch , but not with the part of installing video-linux as a fallback. lets get bumblebee working with just bumblebee without adding video-linux to the mix

I agree with the @openminded solution. This should work.

As to ACPID, I also have it non working on my optimus laptop and I can't complain on bumblebee (it's a gaming laptop which servers well):

[michaldybczak@alienware-PC ~]$ sudo systemctl status acpid
[sudo] hasło użytkownika michaldybczak: 
● acpid.service - ACPI event daemon
   Loaded: loaded (/usr/lib/systemd/system/acpid.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:acpid(8)

Thank you guys, but I have to revert to mint since I'm so rushed because I have lot of things to do

if you find your way back one day, your better off with optimus-manager or prime instead of bumblebee. best of luck.

Ubuntu based distros always worked for me :slight_smile:
I will wait till Manjaro fully working out of the box for Nvidia, because Manjaro feel fast and stable

You are jut lazy. Bumblebee works MOSTLY out of box - need small user step guide tasks (like add user to bumblebee group for pass sudo) or add custom flags to grub cause instablillity (in OTHER distro is same).
Ubuntu preffer NVIDIA Prime solution, this is not the best.

I dont know but handling gtx 900m series is a pain as said by nouveau developers

which method you should go with is a personal preference, for me i use prime and its worked perfectly since first setting it up and it fits my needs, i want nvidia working on the fly, i dont mind having both the iGPU and nvidia gpu on at the same as i never need to do anything to start programs or logout/login for nvidia gpu to work the way it should.
if you want the option to be able to use the intel integrated gpu only and only use the nvidia gpu when you need it then optimus-manager is a good fit. both of those options imo are better than bumblebee but again, its personal preference. go with what suits your needs the best.

just wait until Nvidia joined the Open source community :v

when will nvidia create package of driver for linux that run like windows without thinking about x, kernel and the other ?

Btw @FadeMind have you tried patched bumblebee which doesn't need pmmethod for loading / unloading nvidia driver?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by