Overclocking, Multiple DEs, on 20.02 Raspberry Pi 4

Hey guys,

I have just updated my Pi 4 to the latest release, 20.02. I re-installed everything, so I can have the latest KDE updates enabled without having to do it all manually. I am running the BOOT from my SD card, and the OS portion (ROOT) from a crucial SSD. The performance and stability is pretty amazing. I almost think I could install chrome, an email client, and an office suite (I think it has one already) and give it to my father as a daily driver for his spreadsheets, paying bills, and emailing, without any issues.

My questions are-

Can I also have xfce installed without causing problems? I would like to test it. I've tried installing multiple DEs on my desktop in the past, and had to re-install everything because it caused so many issues.

My next question- Has anyone had any luck with overclocking the pi 4 on Manjaro? I have the latest eeprom firmware and here is some of my config.txt

initramfs initramfs-linux.img followkernel

I don't think my over_voltage or arm_freq are doing anything, when I try to move the arm_freq to the next line the pi won't boot. I do have active and passive cooling, and a proper power supply (canakit, known to be a good one).


1 Like

bump, anyone?

Maybe @Darksky or @Strit Can help you, as they're the ones with RPI4.

1 Like

You might not have that great of a chip to get that high of an overclock. I stopped at 1900 because that was pretty stable for me.

Here is my confix.txt:

initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4

# Enable 4Kp60 Video

# Overclock CPU
1 Like

Also side note, I'm about to move my root over to a USB mSATA SSD. Do you have any good links for doing that? Thanks!

Sure. I used this link.](https://www.tomshardware.com/news/boot-raspberry-pi-from-usb,39782.html)

no problems whatsoever. as long as you have the right set up. I have the star tech usb to ssd adapter. that is known to work. make sure you check the list here to make sure the adapter you're going to use is known working. James Chambers Blog

If you have known working set up you shouldn't have to use quirks.

1 Like

you're overclock config booted. I guess I just had to tone down the arm_freq a bit.

1 Like

I normally do not overclock but lately I have been test compiling firefox and some kernels using distcc using the pi4, rock64pro, vim3 and my x64 desktop all hooked together and upped my pi4 to 1800 to be more in line with the other processors.


You may have either too much voltage or processor speed or both.


1 Like

Sorry for the late reply. Would it be beneficial for me to lower my over _voltage?Screenshot_20200228_192900

From what The Pi Hut says looks like you have it set what they said in their wiki. I set mine to that and going to compile a kernel and monitor my temp with cpu-temp-speed that is in the repo.

If you have our latest image the gpu_mem should be 64 if you have not changed around the config. It is using cma=256 for that instead. There needs to be some gpu_mem but not much. Anything else is wasted and not used where it can be added to the system's available memory.

Changed to 64. CMA? I am on 20.02 but am using the exact same config.txt from the previous version.

So gpumem=192 doesn't do anything?


It does (and have to have) if you have vc4-fkms-v3d and fbturbo enabled.

When using vc4-fkms-v3d and fbturbo enabled then KMS / mesa 3D kicks in. When using this mode The system knows to add cma=256 to the kernel command line when it is in this mode when the vc4-fkms-v3d overlay gets applied. When in this mode the gpu uses cma memory instead of gpu_mem when it enters graphics mode. When booting up it will use gpu_mem until it reaches graphics mode is the reason for the 64 gpu mem. Most of the time 32M would work here but I have noticed for some reason 32m seemed to be at the breaking point so I upped it to 64.

vc4-fkms-v3d is a raspian thing they use and they have not yet gotten around to make vc4-kms-v3d work with the pi4 and to be honest I do not know if they will anytime soon but it should make things even better.

Bottom line is with out vc4-fkms-v3d and fbturbo enabled the gpu uses gpu_mem and the other way the gpu uses CMA and you have gpu acceleration. In both instances at first boot gpu_mem is used but with vc4-fkms-v3d and fbturbo disabled when the boot enters graphic mode then the gpu uses CMA. If you have vc4-fkms-v3d enabled and fbturbo enabled the you loose the mesa gpu 3d acceleration.

1 Like

So what's our best graphics solution right now? Leave vc4-fkms-v3d enabled and fbturbo off?

In my testing the mesa 3d (with fbturbo disabled) I got fewer dropped frames playing youtube video high resolution videos with aarch64.

With 64 bit our choices are so limited with out the use of omxplayer. I maintain a 32 bit image / kernel for my satellite friends and with the pi4 the hand cuffs has been put on also as most of the streams are in mpeg2 and the pi4 does not support mpeg2 hardware decoding or does omxplayer support the new codecs that the pi4 is capable of decoding and never will from what I gather from the author popcornmix.

Arch's kodi in their 32bit repo will play this NASA HEVC stream off the satellite nicely I tested in frame buffer mode (gpu_mem=320 and vc4-fkms-v3d / fbturbo enabled)

ID :
4161 (0x1041)
Menu ID :
104 (0x68)
Format :
Overall bit rate :
15.6 Mb/s
Format/Info :
High Efficiency Video Coding
Format profile :
Codec ID :
Duration :
4 min 22 s
Width :
3840 pixels
Height :
2160 pixels
Display aspect ratio :
Frame rate :
59.940 (60000/1001) FPS
Color space :
Chroma subsampling :
Bit depth :
8 bits

They say that kodi 19 is being switched to use v4l2 m2m using MMAL but and VLC is rumored to be working on some sort of hardware decoding but I have no clue if those will even work on 64bit as ffmpeg with MMAL as it is now will not compile as they have 64 bit shut off in their code. The code headers / libs required does not support 64bit. Then there is the pi4 "Is a different animal" on top of that to get things working.

That's interesting for sure. I'm running raspbian on a pi zero and Adafruit's Pi Looper to play videos at trade shows that we've made or downloaded from youtube and it plays pretty good. I know that is using omxplayer.

here is my config....

initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4


running latest KDE Plasma 20.02 on my Rpi4 with Biostar SSD 240Gb and it's running flawless..make sure you put some active cooling with fan..

1 Like

pi 4 w tower

I just got this tower the other day, it's keeping the pi a cool 40 degrees C at 2000MHz.

The Crucial SSD (BX 500) is amazing as well. I can tell it's even faster than the budget version of (MX500) Crucial SSD I have internally in my laptop.

I don't think I will ever switch a machine I am using as a desktop/daily driver to another OS ever again. Manjaro is (how are the kids saying it these days) LIT!


So we should assume / hope for kodi 19 to be in the AUR when it is released?

I have been curious as to how kodi would run on Manjaro ARM with our pi's overclocked and working as well as they are.

I am sure it will run great.

I think it should run smoothly, I have tried it on PBP, Please try this.
How to install
For users on Stable branch
Step 1: sudo pacman-mirrors -b unstable
Step 2: sudo pacman -Syy kodi

Users on unstable branch can skip Step 1.

Try and let me know how well it runs and how it decodes the video playback :smiley:

Forum kindly sponsored by