Pacman freezes during system upgrade

are you sure you did a memtest meaning full as your 24hrs is only about 4 hrs lol
But glad it working for you but it would have been nice to find the real cause if only to help others :zipper_mouth_face:

1 Like

Something to try. Before doing a system upgrade open a terminal and run journalctl -f, then in another terminal (or using the gui) perform the system upgrade. Something might be displayed before the machine freezes hard.

Looking at your hardware everything seems pretty standard except the "Microsoft Xbox 360 Wireless Adapter", If it's USB i'm wondering about unplugging it during the upgrade, maybe something weird is happening when the drivers update sometimes.

2 Likes

You have an issue with updates hard-freezing the system?

This still sounds hardware-related to me. "Random" freezes almost always are.

1 Like

I guess I did not :smiley: I let it run a hour til it reached 100% and thought it repeated the test after that. Maybe I will do a full test some time

Thank you, I will do that in the future

Yes, I think you are right.
It will probably freeze again during the next upgrade and then I can look if journalctl shows something

I am in nightshift and on smartphone. No, system did not freeze, only pacman freezes. After close and open terminal again it was fine.

What part of the update did pacman freeze during? Was it while downloading packages or actually unpacking/upgrading them? Only a freeze during the second would actually ■■■■■ your install...

It always happened during the upgrading and I couldn't boot after that anymore. It's probably possible to repair it with a live-usb using manjaro-chroot, mkinitcpio etc. but in the end it was faster for me to just reinstall manjaro.

I guess another question since you mentioned mkinitcpio: Does it fail during the actual pacman process or while it's running post-install hooks?

It fails during the actual upgrading.
The last line I see on the terminal is something like (28/128) upgrading xorg-mkfontscale [#####] 100%

Please post your specs as @mandog requested.

I did...

1 Like

My apologies. I overlooked the link, as I was expecting to see the full ouput.

If you never ran the full (long) memtest, have you ever gotten 3 beeps during boot.

1 Like

Never got any beep during boot

I had a similar problem.
Couldn't solve it yet. Freezes during update, for a long time. I forced to shutdown. Turn it on again and goes to an emergency shell and I can't even write any words. So I back up everything, downloaded the curren ISO with xfce, reinstall, update, and the same happens. The live boot works fine. After install with non-free drivers works great. when update the problems begins.
Sorry I can't be more specific, but I can't boot right now to show error messages.

The only thing I notice is that I am also using a SSD drive and I have a similar GPU card. Could it be related to video drivers?

I was using manjaro gnome, then used fresh install for manjaro xfce 17.1.6
CPU: intel core i5-7300HQ
GPU: Nvidia GeForce GTX 1050Ti
It is a dell inspiron 15 7000 laptop

What about running the updates from TTY?
CTRL+ALT+F2
then
sudo pacman-mirrors -f0 && sudo pacman -Syyu

just for information..
I had the same problem when pacman was updating the kernel 4.15 today in my plasma VM (windows 7 host) on unstable branch. the system was freezed and not responding and had to hard reset the VM. I will try to check logs tomorrow.

Yeah, I already did the last update in TTY following this post and it worked without any problems: Applying manjaro update from TTY
It could be a graphics driver problem, but IIRC I also had freezes with free drivers.
I also guessed that KDE would cause this, but if it also happens with xfce it probably doesn't.

I also got a few pictures of journalctl -f when it freezed. (Pictures because I couldn't recover it in the journal-file, it cut off before that)
When it freezes I still can move the mouse and scroll in the terminal but as soon as I try to move or minimize a window everything freezes.

Pictures of journalctl -f

IMG_20180323_130041
IMG_20180323_125910

Hello to everyone!
I have been battling a very similar problem for the past two weeks. In total, this led to about 17 fresh installations of the OS and in the end, it was one simple setting. I apologize in advance for lack of evidence, but I did not save any logs! I did not find ANY lead to anything helpful online so I am sharing my experience here. So here is my story:

Configuration
This all happened on my Dell Latitude e7440 (4th gen. i5), 8 gb RAM, 275 GB SATA SSD (Crucial), Manjaro KDE installed in UEFI (with /boot/efi partition...if that is relevant...)

Symptoms

  1. as mentioned above, system completely froze during "pacman -Syu". On thing left alive was mouse cursor. Switching to tty only yielded black screen with blinking cursor.
  2. when updating from tty directly, same thing occurs. Packages are downloaded, but about halfway through installation (~135/310, always on a different package), the system just hangs.
  3. the only thing I could do in these situations was to forcefully shut the pc down, after which it was never able to boot back into a functioning system.
  4. the only info tty provided was the fact, that some processes were not responding for more than 120 seconds (cannot recall the exact error, sorry :frowning: )
  5. this only happened with full upgrade and from where the system usually hung up and messages when later trying to turn it back on, usually sddm or network-manager were failing

Solution
I had a spare dell optiplex next to me so I tried to install and update there: no problems. A thought occured to me to look into the pc UEFI/BIOS. It was important for the optiplex to set SATA to AHCI, so I figured I should probably check that the settings are correct on the latitude as well. Latitude actually has 3 possible settings for SATA operation: Off, AHCI and RAID On (very relevant on an ultrabook!!! :confused: ). For some reason, it was set to RAID. I set it back to AHCI, installed fresh OS, updated with -Syu and BAM, all working now!

EDIT: Just checked the settings again. Anyway, they say a picture is worth a thousand words...so here you go:IMG_0441

1 Like

Hey, I also installed it in UEFI like you but I had SATA mode set to AHCI the whole time :confused:
Glad it worked for you though!
For me doing the updates in TTY worked today again without any problems, lets see if this stays that way

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by