pacman-mirrors is way out of date

I have two Raspberry Pi 4s. One is updating and the other is not.

I checked pacman-mirrors for both. The one that is updating is has a version number on pacman-mirrors of 4.16.5 the other is at 2.0.

Also the one with pacman-mirrors at 2.0, responds to sudo pacman -Syu with 'there is nothing to do'.

How do I get update working again? I assume my pacman-mirrors us wrong, how do I fix it?

It seems you missed some posts in this category .. such as ..

Yes I missed it, thanks!

And I did make progress but it's not completing the upgrade....

error: failed to commit transaction (conflicting files)
nss: /usr/lib/p11-kit-trust.so exists in filesystem
Errors occurred, no packages were upgraded.

compounding with another old manual intervention:

1 Like

Yes, that did the trick. I'll have to find a way to keep up to date.

Those things dont always come up .. but in a rolling release they will from time to time.
Someone created a little newsfeeder if you are interested in that ..

(it is in the repos as mntray)

3 Likes

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by