Palm detection Alps touchpad

Hi, I installed Manjaro 2 days ago and I already love it.
Most things worked right out of the box, my hotkeys were fixed by a single edit to a text file, I enabled LDAC support for my bluetooth headphones with a package from the AUR. All of this with limited knowledge of linux systems (some experience with Ubuntu desktop some years ago, and setting up a Ubuntu server earlier this year).

The one thing I haven't figured out so far is how to enable palm detection for my Alps touchpad. I have found an article on the Arch wiki which makes me think it has something to do with libinput (although I am not sure about that one), but it leaves me in the dark regarding palm detection.

Thanks in advance

Hello and welcome to Manjaro!

Please provide more information on what hardware and software you use with

inxi --full --verbosity=7 --filter --no-host

as explained here

These are the results from the command:

System:
  Kernel: 5.6.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: KDE Plasma 5.18.5 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP ZBook Studio G3 v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 80D4 v: KBC Version 11.75 serial: <filter> UEFI: HP 
  v: N82 Ver. 01.45 date: 01/05/2020 
Battery:
  ID-1: BAT0 charge: 56.6 Wh condition: 56.6/56.6 Wh (100%) 
  volts: 17.2/15.2 model: Hewlett-Packard Primary type: Li-ion 
  serial: <filter> status: Full 
Memory:
  RAM: total: 15.52 GiB used: 1.83 GiB (11.8%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP 
  arch: Skylake-S rev: 3 L2 cache: 6144 KiB bogomips: 41621 
  Speed: 963 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 984 2: 1000 
  3: 1000 4: 1002 5: 1000 6: 1000 7: 1001 8: 1000 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon 
  art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb erms est f16c 
  flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window hwp_epp 
  hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca 
  mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti 
  pts rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep ss ssbd sse 
  sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc tsc_adjust 
  tsc_deadline_timer vme x2apic xgetbv1 xsave xsavec xsaveopt xsaves 
  xtopology xtpr 
Graphics:
  Device-1: Intel HD Graphics 530 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:191b 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: intel 
  alternate: fbdev,vesa compositor: kwin_x11 resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) 
  v: 4.6 Mesa 20.0.6 direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  chip ID: 8086:a170 
  Sound Server: ALSA v: k5.6.11-1-MANJARO 
Network:
  Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e 
  v: 3.2.6-k port: efa0 bus ID: 00:1f.6 chip ID: 8086:15b7 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: efa0 
  bus ID: 01:00.0 chip ID: 8086:24f3 
  IF: wlp1s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 12.44 GiB (5.2%) 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 57HA4103 scheme: GPT 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / size: 216.63 GiB used: 12.44 GiB (5.7%) fs: ext4 
  dev: /dev/nvme0n1p2 label: N/A 
  uuid: 56916778-1b4f-4cd8-a99d-6ccbe87981cd 
  ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p1 label: N/A uuid: 778A-4918 
  ID-3: /var/lib/snapd/snap/core18/1754 raw size: 54.9 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop1 label: N/A uuid: N/A 
  ID-4: /var/lib/snapd/snap/snapd/7264 raw size: 27.1 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop0 label: N/A uuid: N/A 
  ID-5: /var/lib/snapd/snap/spotify/41 raw size: 163.7 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop2 label: N/A uuid: N/A 
  ID-6: swap-1 size: 17.07 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p3 label: N/A 
  uuid: a54681b8-c23a-484e-9421-6f3091949291 
Unmounted:
  Message: No unmounted partitions found. 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-5:2 info: Logitech Optical Tilt Wheel Mouse type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s 
  chip ID: 046d:c019 
  Device-2: 1-7:3 
  info: Cheng Uei Precision Industry (Foxlink) HP HD Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 05c8:0383 
  Device-3: 1-8:4 info: Validity Sensors VFS495 Fingerprint Reader 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 
  speed: 12 Mb/s chip ID: 138a:003f serial: <filter> 
  Device-4: 1-12:5 info: Intel type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0a2b 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 
  speed: 5 Gb/s chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 37.0 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 234 Uptime: 9h 41m Init: systemd v: 245 Compilers: 
  gcc: 9.3.0 Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37

I will post this immediately the next time I start a topic. :wink:

Did you try this?
https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Using_the_driver's_automatic_palm_detection

I installed the Synaptics driver yesterday, and played around with the PalmMinWidth an PalmMinZ.
The issue seems to have improved, but the cursor still jerks around every minute or so when typing. It doesn't really feel like it works like it should.

You may have to tweak a bit more

Did you use evtest as suggested in the wiki?

The output of cat /proc/bus/input/devices was

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input0
U: Uniq=
H: Handlers=kbd event0 
B: PROP=0
B: EV=3
B: KEY=4000 0 0

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input1
U: Uniq=
H: Handlers=event1 
B: PROP=0
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
U: Uniq=
H: Handlers=kbd event2 
B: PROP=0
B: EV=3
B: KEY=10000000000000 0

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input3
U: Uniq=
H: Handlers=sysrq kbd event3 leds 
B: PROP=0
B: EV=120013
B: KEY=20 0 0 1500f02100000 43803078f900d401 feffffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name="HP Wireless hotkeys"
P: Phys=hpq6001/input0
S: Sysfs=/devices/virtual/input/input8
U: Uniq=
H: Handlers=kbd event4 rfkill 
B: PROP=0
B: EV=3
B: KEY=80000000000000 0 0 0

I: Bus=0010 Vendor=001f Product=0001 Version=0100
N: Name="PC Speaker"
P: Phys=isa0061/input0
S: Sysfs=/devices/platform/pcspkr/input/input10
U: Uniq=
H: Handlers=kbd event5 
B: PROP=0
B: EV=40001
B: SND=6

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name="HP WMI hotkeys"
P: Phys=wmi/input0
S: Sysfs=/devices/virtual/input/input15
U: Uniq=
H: Handlers=kbd event6 
B: PROP=0
B: EV=33
B: KEY=4000000000 0 1000700000000 2102400 0 0
B: MSC=10
B: SW=0

I: Bus=0018 Vendor=044e Product=120c Version=0100
N: Name="ALP0011:00 044E:120C"
P: Phys=i2c-ALP0011:00
S: Sysfs=/devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1/i2c-ALP0011:00/0018:044E:120C.0001/input/input16
U: Uniq=
H: Handlers=event7 mouse0 
B: PROP=5
B: EV=b
B: KEY=e520 10000 0 0 0 0
B: ABS=660800001000003

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input17
U: Uniq=
H: Handlers=kbd event8 
B: PROP=0
B: EV=3
B: KEY=3e000b00000000 0 0 0

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH Mic"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input18
U: Uniq=
H: Handlers=event9 
B: PROP=0
B: EV=21
B: SW=10

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH Headphone"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input19
U: Uniq=
H: Handlers=event10 
B: PROP=0
B: EV=21
B: SW=4

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH HDMI/DP,pcm=3"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input20
U: Uniq=
H: Handlers=event11 
B: PROP=0
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH HDMI/DP,pcm=7"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input21
U: Uniq=
H: Handlers=event12 
B: PROP=0
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH HDMI/DP,pcm=8"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input22
U: Uniq=
H: Handlers=event13 
B: PROP=0
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH HDMI/DP,pcm=9"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input23
U: Uniq=
H: Handlers=event14 
B: PROP=0
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH HDMI/DP,pcm=10"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input24
U: Uniq=
H: Handlers=event15 
B: PROP=0
B: EV=21
B: SW=140

I: Bus=0011 Vendor=0002 Product=0008 Version=0700
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio3/input0
S: Sysfs=/devices/platform/i8042/serio3/input/input12
U: Uniq=
H: Handlers=event16 mouse1 
B: PROP=5
B: EV=b
B: KEY=e520 10000 0 0 0 0
B: ABS=260800000000003

I: Bus=0003 Vendor=05c8 Product=0383 Version=0106
N: Name="HP HD Camera: HP HD Camera"
P: Phys=usb-0000:00:14.0-7/button
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.0/input/input26
U: Uniq=
H: Handlers=kbd event17 
B: PROP=0
B: EV=3
B: KEY=100000 0 0 0

So I ran evtest on event 7 and event 16. Event 7 only gave me output of X and Y. Event 16 didn't report anything.
Does this mean, that X only receives an X and Y output from my touchpad?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by