pamac is broken

i tried opening pamac-manager/add or remove programs and didnt work
so i tried to remove and install pamac-gtk and im stuck here

❯ pamac list -i | grep pamac
pamac-cli                          9.4.2-1                     extra      133.0 kB
pamac-common-dev                   9.5.0beta-3                 extra      2.3 MB
pamac-flatpak-plugin               9.4.2-1                     extra      80.2 kB
pamac-snap-plugin                  9.4.2-1                     extra      68.1 kB
❯ pamac install pamac-gtk

** (pamac:31504): WARNING **: 14:28:06.893: transaction_interface_daemon.vala:47: failed to connect to dbus daemon: Error calling StartServiceByName for org.manjaro.pamac.daemon: Failed to activate service 'org.manjaro.pamac.daemon': timed out (service_start_timeout=25000ms)
Preparing...

** (pamac:31504): CRITICAL **: 14:28:07.114: pamac_daemon_start_get_authorization: assertion 'self != NULL' failed


help is appreciated.

You mixed up pamac versions.
Remove the dev package and install the correct versions:
sudo pacman -Syu pamac-common pamac-gtk

1 Like

oh litttt, thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by