Pamac manager GUI preview terminal indentation/ spacing issue

In the pamac manager GUI, i know, there is an option to view what is happening in the command line. But the command line doesn't show everything properly. There is no proper indentation.
If i use CLI of pamac manager from terminal to build a AUR package it shows me the progress of the process. And the progress report updates continuously.
But in the GUI "add or remove software" App, if i press the > button to view the background processes it doesn't show things as flawless as terminal does.....
Please fix this issue :pray:.
You can consider this as a feature request if you want.

2 Likes

Sounds like a valid request. I know having more information in the GUI would've helped me a couple of times.

Also please re-categorize your post as a "Feature Request" so that it is easier to find.

1 Like

Post it in the issues tracker of the application

1 Like

I couldn't find any option to add issues there..

This is not a terminal nor a preview.

It is the actual responses from other commands - so what formatting are you referring to?

If I install an AUR package through terminal I can easily understand the download rate, remaining time etc. It's because of proper indentation and spacing.
But, when i build an AUR package through the GUI it shows those things but I can't understand them. They aren't placed properly. (Allignment problem). And they change slower than the terminal.

What you see in pamac is - for the lack of a better idiom - a read only text document which gets content appended on the fly.

It is not a terminal - nor a terminal emulator - it is just text feed back provided by pamac - sometimes the feed back is provided by an application like pacman-mirrors or it is provided by libalpm - but it is received by pamac and is parsed by pamac and displayed by pamac - so yes - it is slower than using the terminal.

So there is nothing to fix - it is how it is.

But it should be at least understandable :wink:

It is like this
Download rate. Upload rate. Time elpsed time remaining Downloaded. Estimated time 23 34. 56. 66. 78
:confused:

If you have a problem understanding what the application says - you need to learn the language of the application.

There is no way any application can satisfy all users.

No matter how hard one try - it is next to impossible.


In any case - if you find the output of the CLI version easier to understand - use the CLI version - GUI applications are - very often - wrappers for terminal commands - so mastering the terminal is mastering the GUI :slight_smile:

1 Like

Its like this

Sample from building nordvpn-bin using Pamac GTK - appears formatted to me

Text inside Pamac progress view
Preparing...
Checking dependencies...
Removing nordvpn-bin (3.7.4-1)...
Running post-transaction hooks...
Reloading system manager configuration...
Arming ConditionNeedsUpdate...
Transaction successfully finished.

Preparing...
Cloning nordvpn-bin build files...
Checking nordvpn-bin dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building nordvpn-bin...
==> Making package: nordvpn-bin 3.7.4-1 (lør 11 jul 2020 09:16:04 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading nordvpn_3.7.4_amd64.deb...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
 22 8430k   22 1887k    0     0  4672k      0  0:00:01 --:--:--  0:00:01 4660k
100 8430k  100 8430k    0     0  12.0M      0 --:--:-- --:--:-- --:--:-- 12.0M
==> Validating source_x86_64 files with sha256sums...
    nordvpn_3.7.4_amd64.deb ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting nordvpn_3.7.4_amd64.deb with bsdtar
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "nordvpn-bin"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Adding install file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: nordvpn-bin 3.7.4-1 (lør 11 jul 2020 09:16:08 CEST)
==> Cleaning up...

Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Installing nordvpn-bin (3.7.4-1)...
Configuring nordvpn-bin...
:: In order to enable nordvpn you have to start the following service:
     sudo systemctl enable --now nordvpnd
Running post-transaction hooks...
Reloading system manager configuration...
Arming ConditionNeedsUpdate...
Transaction successfully finished.

If you are referring the status line at the bottom of the primary window - just left of the Cancel and Apply buttons - it is a single line reflecting overall status - don't expect immense details there.

1 Like

Text inside pamac progress view that you posted here is perfect.. Even there is multiple colours as well as proper spacing and indentation.. Its only because you used the </> button or respective tag to view the tags. But in reality what the pamac progress view shows is this,
Preparing...
Cloning nordvpn-bin build files...
Checking nordvpn-bin dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building nordvpn-bin...
==> Making package: nordvpn-bin 3.7.4-1 (lør 11 jul 2020 09:16:04 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Downloading nordvpn_3.7.4_amd64.deb...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
22 8430k 22 1887k 0 0 4672k 0 0:00:01 --:--:-- 0:00:01 4660k
100 8430k 100 8430k 0 0 12.0M 0 --:--:-- --:--:-- --:--:-- 12.0M
==> Validating source_x86_64 files with sha256sums...
nordvpn_3.7.4_amd64.deb ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
-> Extracting nordvpn_3.7.4_amd64.deb with bsdtar
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
-> Removing libtool files...
-> Purging unwanted files...
-> Removing static library files...
-> Stripping unneeded symbols from binaries and libraries...
-> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "nordvpn-bin"...
-> Generating .PKGINFO file...
-> Generating .BUILDINFO file...
-> Adding install file...
-> Generating .MTREE file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: nordvpn-bin 3.7.4-1 (lør 11 jul 2020 09:16:08 CEST)
==> Cleaning up...

Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Installing nordvpn-bin (3.7.4-1)...
Configuring nordvpn-bin...
:: In order to enable nordvpn you have to start the following service:
sudo systemctl enable --now nordvpnd
Running post-transaction hoo

I swear, I'm speaking the truth. You saw them in the above form without code this formating.
It's very very hard to understand.
Look at that part where it shows download speeds. Can you understand

No - it is not because I used code tags. It looks like that on my system (albeit not colored because pamac gui do not support colored output).

Example from building popcorntime-bin

20200712-113633_946x645_screenshot.

So my thought is - you have changed your configuration in a manner where you have replaced the system mono font with a non mono font.

1 Like

I found that i had changed my fixed width font from noto mono to another font. now i've restored the default settings. this my screenshot:

Photo of current settings

image

i've these settings now...
i've also restarted the computer. And now english is the only language in my system.
But the problem is steel there...
See..
image

The font you are using for mono space is not mono space - try using DejaVu Sans Mono Book as your mono space font.

sudo pacman -Syu ttf-dejavu

Mono spaced fonts are equally spaced.

If it continues to be an issue it is not Pamac but the theme settings.

It looks like you are using KDE and Pamac is a gtk application - so something must be overriding the system Noto Mono font.

I don't know much of KDE but from the look of it - I reckon it is a KDE issue because on my system (Openbox window manager) - there is no problem.


ping @Alif
If you install the package qt5ct - and launch the qt settings app - you will find the default font used for mono spaced content in gtk - noto sans 10 - not mono just noto sans.

Set the mono spaced font to an actual mono font and the output window in pamac will be aligned to you satisfaction.

not a good idea

1 Like

thank you very much. after your help i could find it. The font settings change did not help. then I thought about gtk application. so I did reset the gtk application style to the defaults. Here the themes were causing the problem. The themes are buggy here.
image
I've pressed the "defaults" button.

Pressing the defaults button revert to KDE defaults - not Manjaro.

In the lower right you can select a gtk theme to be applied to gtk applications.

the problem occured because of selecting a theme here.

Forum kindly sponsored by