pamac-manager stürzt während Update ab

Hallo zusammen,

ich habe auf meinem kleinen HP-Notebook das aktuelle XFCE 19.0.2 (minimal) installiert. Da war vorher schon XFCE drauf und funktionierte einwandfrei. Nach der Neuinstallation stürzt nun pacman laufend ab wenn ich etwas installieren will. Das heisst die Maus funktioniert noch, doch das System reagiert auf keine Mausklick mehr.

Ich habe mir dazu diese Seite angesehen, doch ich blicke da nicht durch was zu tun ist (mein Englisch ist diesbezüglich nicht das Beste). :relaxed: Für einen Hinweis zu einer deutsche Seite bin ich dankbar, oder natürlich für einen konkreten Hinweis wie ich das einfach korrigieren kann.

Danke :wink::vulcan_salute:

PS. Im Moment installiere ich schlicht via Terminal.

pacman hat keine GUI. Du kannst pacman nur im Terminal verwenden. Bist du sicher das pacman abstürzt?

Oha, wieder etwas gelernt! Das ist ja der pamac-manager (GUI) der abstürzt.

Wenn du den pamac-manager von der Konsole ausführst, wird ggf. ein Fehlerbericht ausgegeben der etwas zur Ursache des Absturzes verrät.

@xabbu / @mepi0011: Danke für Eure Hinweise.
Ich hatte im Terminal, nach dem Aufruf von 'pamac-manager' und dem Aufruf einer Aktion im GUI eine Fehlermeldung, die ich nur noch ansatzweise wiedergeben kann :thinking: die den Text "io-error-quark 18" beinhaltete. Ich habe dann mit diesem Hinweis gesucht und folgenden Befehl gefunden:

pacman -Syu pamac-gtk

Somit habe ich wohl einen entsprechenden Upgrade gemacht. Nach dieser Aktualisierung wird der Fehler nicht mehr angezeigt und ich kann wieder normal in der GUI Installationen ausführen. Ich weiss allerdings nicht genau weshalb es nun wieder funktioniert. Denn aufgerufen habe ich ja 'pamac-manager'. Für eine Erklärung bin ich offen, damit ich daraus lernen kann.

Da bin ich doch wieder... wie Ihr wohl bereits erwartet habt. :partying_face:

Also, das Problem tauchte erneut auf. Während des Updates im Terminal via "pacman -Syyu" wurden zwei fehlerhafte Pakete angezeigt:

vulkan-intel-... und
vulkan-radeon-...

Danach fand ich einen Hinweis auf ein Kernel-Problem, so dass ich den zusätzlich installierten 5.6.7-1 deinstalliert habe und 5.4.35-1 aktiv ist. Jetzt läuft die Aktualisierung durch. Wie Ihr seht, bin ich kein Vorzeige-Linux-User und manchmal einfach via "try and error" unterwegs. :relaxed: ... oh Mann, es gibt noch viel zu lernen.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by