Partitioning problem when trying to dual-boot Manjaro with Windows 10


I want to dual-boot Manjaro to my Windows 10 system without losing any data.

I have a 250 GB SSD (Samsung 970 EVO) and a 1 TB HDD (WD Blue). Windows 10 is on SSD, and games, mobile ROM-s, etc. are on HDD. I followed this guide [HowTo] Dual-boot Manjaro - Windows 10 - Step by Step to install Manjaro.

But when I try to install it from USB (to HDD), I get stuck at manual partitioning. It just shows the whole disc as "unknown" (empty) although I shrank it in Windows.

Did you set your disk mode in firmware to AHCI?

IMG_20200705_150123 I hope so. (Sorry for the quality, I don't have free USB.)

I don't know :man_shrugging: - even if Windows features such as Hybrid Sleep and Fastboot is enabled - I would think the installer should still be able to read the partitions and know the filesystem.

Your statement that the installer doesn't read anything from the disk is - kind of - worrying and I have no idea what could be the cause.

I turned off fastboot, but I couldn't find the hybrid sleep option in Windows.
Screenshot_20200706_011550 Screenshot_20200706_011617
Here are the screenshots

I have no idea - when the sda partition 1 and 2 appears unformatted - and you know they are containing data then there is something wrong and you should not proceed until you have fixed it.

The obvious step is to reboot into Windows and run chkdsk driveletter: /F /X.

Exactly this command? Windows just says:

The drive, the path, or the file name is not valid.

:slight_smile: you will have to replace driverletter with your actual drive.

Oh, sorry, my bad. But it didn't help.

I do think you have a problem. I have however - except the this last suggestion

  • before your disk crashes completely - backup your data

Should I turn the Windows WHQL support on or off?

I don't know - enabling WHQL usually includes Secure Boot - you won't know until your test it - and you can't destroy your computer - so what's stopping you?

I tried that, nothing changed. I can still try to update Windows to 2004 and Bios.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by