PC beeps before shutdown

Hello,
I'm using Manjaro i3 Edition for pretty while with different problems. One of those is beep sound when shutting down. I found some threads with muting PC speaker, but this isn't a way for me because I wanna know whats wrong with it.

To shutdown system I'm using command 'shutdown now' via dmenu, normally is fine but time to time (once for a week or two) for a second before shutdown, PC just beeps one single time. This beep is half second long. I've observed that more often I hear something like HDD head hitting drive. I've 3 HDDs.

I'm pretty sure I didn't have this problem with other distros.
Yes, I've TLP installed.
This is desktop build

What's wrong with what?

If the issue is the PC Speaker beeping then the solution is to mute the PC Speaker.

1 Like

Wrong with shutting down procedure. As I mentioned, drives also sounds weird. There was no problem on Windows or other Linux distros. I'm looking for a source of the problem to prevent damage if that is a power failure.

If the issue is not persistent - on every single shutdown - then it is a local system issue - one way or another.

None of several Manjaro systems I am using exhibit the behavior you describe - so your system is trying to tell you something - I don't know what - you are really the only one with hands on.

shutdown now is potentially quite a hard shutdown:

$ man systemctl
...
poweroff
           Shut down and power-off the system. This is mostly equivalent to systemctl start poweroff.target
           --job-mode=replace-irreversibly --no-block, but also prints a wall message to all users. This command is
           asynchronous; it will return after the power-off operation is enqueued, without waiting for it to
           complete.

           If combined with --force, shutdown of all running services is skipped, however all processes are killed
           and all file systems are unmounted or mounted read-only, immediately followed by the powering off. If
           --force is specified twice, the operation is immediately executed without terminating any processes or
           unmounting any file systems. This may result in data loss. Note that when --force is specified twice the
           power-off operation is executed by systemctl itself, and the system manager is not contacted. This means
           the command should succeed even when the system manager has crashed.

From seeing data loss and corruption in the past from using CLI power commands I now always use the DE's "shut down" option, or log out then shut down.

Are they using the same version of systemd?

Depending on the actual noise you're hearning:

  • If you are hearing drive noise then possibly you are running applications which are still writing out to disk (or disk buffers need to be written out).
  • A drive head parking noise will happen when the power is cut while the drive is spinning.

You can disable that and see if it makes any difference (it shouldn't).

I'm using 'shutdown' command since someone told me that the 'power off' is hard shutdown. Problem was exacly the same.

Not sure. I don't even know that my systemd version could have issues.
I've looked up logs with journalctl, thats a lot of lines. Is there any way to display only errors?

Is there any way to shut it down in "soft" way? I didn't notice any data loss.

shutdown beep is a just a warning, not an error

Ubuntu has added 'blacklist pcspkr' to their distributions by default for a few years
search on Ubuntu forum shows that users now ask how to turn beep back on
but for posts > 10 years old users were asking how to turn it off

AFAIK Debian based distributions have beep on by default. Linux Mint has tutorial just for LMDE version to blacklist pcspkr - https://community.linuxmint.com/tutorial/view/1116.

Archwiki page for PC Speaker only advises how to disable the annoyance of various beeps

The softest way to power down the system is using the GUI or:

systemctl poweroff

the second one is:

shutdown --halt now

and then pressing the power button lightly.

For more ways of shutting down your computer, see this excellent cough, cough article:

:innocent: :grin:

2 Likes

That's the one what I was looking for :slight_smile: yesterday I just added '-P' argument to try if that makes process softer, but 'systemctl poweroff' is probably more familiar with poweroff button from graphical environments :slight_smile:

But if it's a warning, so why it doesn't warns every single time? Anyway I'll mute PC Speaker. Hopefully 'systemctl poweroff' will solve my problem with hard shutting down, then I'll don't care about Speaker noises.

Thank you All

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by