persistent hp-plugin problems

sudo hp-plugin -i


DOWNLOAD PLUGIN

Checking for network connection...
Downloading plug-in from:
Downloading plug-in: [\ ] 0% warning: manjaro linux distro is not found in AUTH_TYPES
Plugin is not accessible. Trying to download it from fallback location: [https://developers.hp.com/sites/default/files/hplip-3.20.2-plugin.run]

error: /root/.hplip/hplip-3.20.2-plugin.run file does not match its checksum. File may have been corrupted or altered

1 Like

There is an issue with 3.20.2. Try installing hplip 3.20.3 from unstable, that worked for me:

sudo pacman -U https://your.mirror/unstable/extra/x86_64/hplip-1%3A3.20.3-1-x86_64.pkg.tar.zst

Just change the "your.mirror" part with the mirror, you are using.

It partially works: the plugin is installed "OK" but then this message ends up in an indefinite loop and the HP Device Manger cannot be used. I wonder why hplip has been that. buggy for decades.

Screenshot from 2020-03-17 21-11-28

The above did not install the plugin, but the HPLIP itself. Have you tried to do what is written in the error message? Open terminal and type

hp-plugin

You will be asked to install the plugin then.

So I did install the plugin with the same version thereafter. HPLIB installs it once again and gets in this infinite loop. Looks like a mess. All this happens on a clean new Manjaro install.

Have you checked if the device itself is up to date? My OfficeJet Pro 8720 downloaded and installed a large update tonight.

Good idea - thanks! However, the device is an old HP Laserjet that currently works with most other Linux flavors except Manjaro.

probably because they use an older build of hplip. you should really report this to the hplip developers so that you don't end up with a printer you can't use on them either soon.

https://launchpad.net/hplip/+filebug

bump. arrrg! hp printing has always made me neurotic.

https://bugs.launchpad.net/hplip/+bug/1868320 filed it!

1 Like

I just installed Manjaro stable on 2 laptops and a desktop, and can confirm this exact infinite loop on all 3 machines. I recently moved from Kubuntu, and all 3 machines (and actually, a fourth) successfully installed the hplip-plugin. As it stands, none of my Manjaro machines can scan from my hp Color LaserJet Pro MFP M277dw. This is frustrating in an otherwise excellent distro. I should add that one key difference between my Manjaro and Kubuntu hplip plug-in experience is that in Kubuntu, I am prompted to enter my username password, but in Manjaro I'm prompted to enter the root password.

I just installed Manjaro on a standard desktop, no frills. All worked fine, but not the printer. I have the exact same model of printer as above, and got stuck in the exact same loop. Printer has worked perfect in vanilla Ubuntu for me using hplip.

Solution is here: Can't install printer HPLIP password error

Force the setup to run in terminal to get around buggy gui. Run:
sudo hp-setup -i

Worked fine for me.

2 Likes

I had the same issue, but now I'm missing some settings such as paper type.

How do you mean? Where are the settings missing? I see them everywhere I normally find them, the list of paper types is very long...

Worked great for me with a HP LaserJet MFP M426.

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by